Just nu i M3-nätverket
Jump to content

JPEG-bilder visas inte


AnteMynning

Recommended Posts

Jag använder Windows XP och installerade nyligen Service Pack 3. Sedan dess kan jag inte visa JPEG-bilder på datorn (vilket jag kunnat dessförinnan). Försöker jag öppna dem med Visningsprogram för bilder och fax får jag felmeddelandet:

 

Det gick inte att läsa in C:\WINDOWS\System32\shimgvw.dll

Det går inte att hitta filen

 

Försöker jag öppna dem med Paint kommer detta meddelande:

 

Ett läsfel inträffade när filen laddades. Ogiltig bitmappsbild eller format som inte stöds.

 

Om jag startar Paint och öppnar en bitmappsbild går det bra, men vill jag spara som finns inte JPEG med bland alternativen (endast bitmappar i olika versionser stöds).

 

Det enda sätt jag kan öppna JPEG-bilder på är med Internet Explorer. Då visas de på rätt sätt, men jag har ingen möjlighet att ändra format på mina foton (som jag alltid tidigare gjort på datorn utan problem).

 

Uppenbarligen är det något krångel med filen shimgvw.dll -- Jag har letat i mappen System32 och hittat den. Så den finns.

 

Jag har försökt ett tips som jag hittade på annat håll: att välja Start -> Kör och regsvr32 shimgvw.dll , men då får jag beskedet:

 

LoadLibryary("shimgvw.dll") misslyckades - Det går inte att hitta filen.

 

Tacksam för all hjälp.

 

Vänligen

Anders

 

Link to comment
Share on other sites

Stefan Eklinder

 

Du har uppenbarligen inte provat såsom här står angående filen shimgvw.dll:

 

http://www.msfn.org/board/Unable-display-JPG-files-t114691.html

 

Try an uninstall and reinstall like this

 

regsvr32 /u %windir%\system32\shimgvw.dll

 

then

 

regsvr32 /i %windir%\system32\shimgvw.dll

 

 

---

C:\Eforum\Stefan Eklinder>|

 

"Man kan inte kämpa ihjäl en skugga, den dödar man med ljus."

 

- Sigfrid Siwertz.

 

Link to comment
Share on other sites

Tack för tipset, Stefan!

 

Tyvärr hjälpte det mig inte. Återigen får jag felmeddelandet

 

LoadLibryary("shimgvw.dll") misslyckades - Det går inte att hitta filen.

 

Kan dll-filen ha blivit korrupt, så att systemet inte hittar den? Jag hittade något ställe på nätet där man kunde ladda hem dll-filer (och shimgvw.dll fanns där). Kan det vara idé att ersätta den gamla filen -- eller är risken stor att jag förvärrar läget. Bortsett från bildvisningen har jag inga andra problem med datorn (trots att den har några år på nacken).

 

Jag misstänker att jag måste ominstallera Windows, men just nu har jag inte tid för det. Det var därför jag undrade om någon hade en enklare lösning på problemet.

 

Vänligen

Anders

 

Link to comment
Share on other sites

Stefan Eklinder
Jag misstänker att jag måste ominstallera Windows, men just nu har jag inte tid för det. Det var därför jag undrade om någon hade en enklare lösning på problemet.

 

Letade efter ett sätt för dig att kopiera aktuell fil från din XPCD.

Om du nu har en sådan?

 

Har aldrig sysslat med det, så jag letade efter hur man ska göra. Hittade inget om det där just. Enklast blir väl i så fall en repairinstall. Du formaterar inte utan systemfiler ersätts från CD:n istället.

 

Glöm inte att besöka WindowsUpdate efteråt!

 

Du kan läsa lite här under "XP Repair Install":

http://www.michaelstevenstech.com/XPrepairinstall.htm

 

I korthet trycker du R när du ska välja partition för att formatera och installera XP. Nu trycker du R istället och följer instruktionerna på skärmen.

 

Inget går förlorat, men backup skadar ju aldrig att ha ut i fall att.

 

---

C:\Eforum\Stefan Eklinder>|

 

"Man kan inte kämpa ihjäl en skugga, den dödar man med ljus."

 

- Sigfrid Siwertz.

 

Link to comment
Share on other sites

Letade efter ett sätt för dig att kopiera aktuell fil från din XPCD.

Om du nu har en sådan?

Man kan också se om den finns i någon annan mapp under Windows, t ex dllcache eller någon mapp för en windowsuppdatering.

 

Link to comment
Share on other sites

Tack för tipset.

 

Jag har letat och hittat två kopior av filen. De har alla samma senast-ändrad-datum (2008-04-14, d.v.s. innan jag installerade Service Pack 3), och det hjälpte inte att ersätta den i systemmappen med någon av de andra.

 

Anders

 

Link to comment
Share on other sites

Har du registrerat filen efter att du har flyttat över den?

 

Ett annat alternativ är ju att avinstallera SP3.

 

Link to comment
Share on other sites

Har försökt. Fick återigen felmeddelandet: "LoadLibryary("shimgvw.dll") misslyckades - Det går inte att hitta filen."

 

Jag har också försökt avinstallera Service Pack 3, men det gick inte (jag kommer inte ihåg felmeddelandet), så en god gissning är att något gick snett med installationen av SP3.

 

Tack för alla goda råd. Men det verkar som om det får bli ominstallering när tiden räcker till.

 

Anders

 

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...