Just nu i M3-nätverket
Jump to content

Fel i registerfil?


Corinna

Recommended Posts

Igår stängde jag ner datorn ett tag (trodde jag), när jag skulle dra igång den igen visade det sig att den varit på hela tiden. Skärmen var blå och felmeddelandet

"STOP: c0000218 Fel i registerfil

Registret kan inte läsa in registreringsdata (filen)

/SystemRoot/System32/Config/SAM

eller dess logg eller dess alternativa version.

Den är skadad, saknas eller går inte att skriva till" dök upp.

 

Jag har sökt på det här problemet, och det verkar som att det kan hjälpa om man installerar om XP, men då jag inte har någon skiva till hands undrar jag om någon möjligtvis känner till något annat sätt att lösa problemet på, utan att filerna på datorn försvinner? Har inte hunnit backa upp som jag borde, något jag bittert ångrar nu.

 

Jag har försökt starta om i felsäkert läge men det funkar inte, får bara meddelandet "Hard Error".

 

Mycket tacksam för all hjälp!

 

Link to comment
Share on other sites

Microsofts metod förutsätter tyvärr att man har en XP-skiva med en reparationskonsol (återställningskonsol).

http://support.microsoft.com/default.aspx?scid=kb;sv;Q307545

Har du någon kompis som du kan låna en sådan skiva från?

 

När det gäller viktiga filer som det inte finns säkerhetskopior på så kan det gå att flytta över hårddisken till en annan dator som extradisk.

 

Link to comment
Share on other sites

Tack för snabb återkoppling!

Tror jag kan få tag i en sådan skiva i dagarna, men då jag skulle behöva åtkomst till vissa filer ganska så snart så funderar jag på att testa att göra det via Knoppix, vad tror du om det?

 

Link to comment
Share on other sites

Tack, finfint att få tumme upp från ett proffs!

Återkommer, men måste bara fråga: har du (eller någon annan kunnig själ här?) en susning om vad det här problemet kan bero på? Har ju som sagt googlat på det och det verkar inte vara helt ovanligt, däremot är det svårt att hitta information som anger skälet till att det uppstår.

 

Link to comment
Share on other sites

Det finns nog många anledningar till att det blir fel i registret, t ex datorn kraschar medan en skrivning pågår till registret så att den blir till hälften utförd, något program innehåller något fel som får det att skriva något felaktigt i registret, hårddisken har trasiga delar, RAM-minnet är trasigt.

 

Link to comment
Share on other sites

Aha, jobbigt...hoppas verkligen jag kommer åt filerna med Knoppix, håller på att ladda ner det nu. Tack återigen för snabb återkoppling och moraliskt stöd, återkommer förhoppningsvis med info om att jag lyckats med det hela!

 

Link to comment
Share on other sites

återkommer förhoppningsvis med info om att jag lyckats med det hela!
Oavsett hur det går hoppas jag att du återkommer för det är alltid intressant att få veta hur det går med datorerna.:thumbsup:

 

Link to comment
Share on other sites

Absolut! 1 timme och 4 minuter kvar av nedladdningen.....

 

Det här måste för övrigt vara världens bästa forum. Ever!

 

Link to comment
Share on other sites

Sådärja, nu har jag laddat ner Puppy Linux och ska försöka köra den i skadade datorn, men tror jag missat hur jag gör för att komma åt det som finns på skivan?

 

Link to comment
Share on other sites

Om jag inte uppfattat allt fel så borde jag få igång cd-skivan genom att gå in i BIOS, låter det rimligt?

 

Link to comment
Share on other sites

Om jag inte uppfattat allt fel så borde jag få igång cd-skivan genom att gå in i BIOS, låter det rimligt?
Ja, eller om det finns någon särskild tangent för att bara ändra startordningen (Boot Order) så räcker det ju med den funktionen.

 

Link to comment
Share on other sites

Lyckades komma in på BIOS (oh joy!) och ändrade BOOT-preferens.

Men, så typisk, då får jag ett felmeddelande som säger

Could not find kernel image: linux

boot:_

 

Blir lite konfunderad eftersom det funkade bra att bränna skivan och innehållet såg ok ut sen.

 

Link to comment
Share on other sites

Testade, inget hände förutom att samma meddelande kom upp igen. Ska försöka med en USB-sticka, få se om det händer något då.

 

Link to comment
Share on other sites

Det funkade inte med USB-stickan heller. Hm. Kanske får ladda ner den igen, vet inte om jag kan ha missat något när jag laddade ner programmet.

 

Förmodligen en väldigt korkad fråga, men kan det spela in att jag laddat ner Puppy från min Mac och att det är därför PCn inte läser av infon?

 

Link to comment
Share on other sites

Vet inte, jag har aldrig använt Mac. När jag googlade på ditt felmeddelande så såg jag en tråd där de skrev något om att det kunde ha blivit stora bokstäver på filnamn i stället för de små det skulle vara pga olämpligt val av program i något skede. Kolla hur det ser ut på CDn.

 

Link to comment
Share on other sites

Hm, nej, det ser ut att vara små bokstäver där också. Hursom, laddar ner programmet igen, för över det på stickan och testar att dra igång datorn från den, få se om det gör någon skillnad.

 

Link to comment
Share on other sites

Nu så! Brände ner programmet på ny skiva och poff, så funkade det.

Det ser ut som om mina filer och program finns kvar på disken, ska försöka föra över dom till extern hårddisk a.s.a. och sedan invänta svar från DELL om hur man kan lösa det hela.

 

Tack återigen för schysst återkoppling och moraliskt support! Förhoppningsvis behöver jag inte skriva något nytt inlägg här på ett bra tag, men om så blir fallet så på återseende.

 

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...