Just nu i M3-nätverket
Jump to content

Jämföra och kopiera


neggard

Recommended Posts

Jag skulle behöva lite hjälp, jag sitter med 2st excel filer.

I ena filen som vi kan kalla master innehåller en förteckning över produkter + serienummer

och i den andra filen som vi kan kalla slave innehåller även den produkter + serienummer.

 

Nu vill jag jämföra dessa 2 filer med varandra.

De produkter som ligger i slave skall jämföras med de som ligger i master och innehåller masterfilen inte serienummret så skall det kopieras dit.

 

 

Hur gör man detta på det bästa sättet?

 

OBS! För tillfället innehåller inte master filen några serienummer.

 

Link to comment
Share on other sites

vad ska de jämföras på för data?

Om inte alla har serienummer kan man inte söka efter det. har de alla unika namn kan man använda det givet att de är exakt lika i filerna.

 

Annars är funktionen PASSA den du söker. Dvs skriv in något i stil med

=PASSA(A1;Blad1:A:A;0)

i ditt slav-blad givet att det du vill söka efter finns i A1, den tabell du vill söka i finns på Blad1 och värdet du söker efter, kanske, i A-kolumnen.

 

Denna funktion ger antingen ett radnummer eller ett felvärde. Sortera tabellen i slav på felvärdet och kopiera alla med felvärdet till master. Klart.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Det som skall jämföras är de 2st serienummrena.

Återfinns detta serienummer i båda filerna skall serienummret kopieras till masterfilen.

 

Link to comment
Share on other sites

Kanske skall sammanställa det så här.

 

om produkt abc finns i både kolumn B i masterfilen och i kolumt A i slavefilen

så skall serienummret i kolumt D i slavefilen kopieras till kolumn F i masterfilen på samma rad som produkten fanns på.

 

Link to comment
Share on other sites

Vi har ett värde i B i master (blad1).

Vi ska söka efter det i kolumn A på slaven (blad2)

Om värdet hittas ska ett annat värde, serienumret, hämtas från kolumn D i slavfilen och sparar i kolumn F i master.

 

 

Gärna i två steg om det går bra, annars kan man skriva ihop det men:

I kolumn G på blad1 (master), om denna är tom, skriv

=PASSA(B2;Blad2!A:A;0)

som då söker reda på raden där värdet finns eller ger ett felvärde

I kolumn F skriv:

=OM(ÄRFEL(G2);"";INDEX(Blad2!D:D;G2))

Där då OM-satsen ser till att inget skrivs i cellen om PASSA inget hittat och INDEX hämtar värdet i kolumn D på den rad som PASSA hittat.

 

Skriv in i detta på rad 2, kopiera utmed hela tabellen. Vill du spara/låsa värdena. Kopiera kolumn F och klistra in special, enbart värden, över kolumn F.

 

Anpassa referenserna (blad2) så att det fungerar med dina data.

 

Antagit att detta är något du bara ska göra ibland eller kanske en gång. Om en ofta repetetiv uppgift kan man tänka sig blanda in VBA. Kanske. men bättre troligen att ha en mall där du göra detta för att sedan kopiera in det på rätt plats.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...