Just nu i M3-nätverket
Jump to content

Bilder syns inte efter rewriting!?


LisaT

Recommended Posts

Hej!

Jag är medveten om att det kan uppstå problem med sökvägar till bilder när man använder sig av URL rewriting (använder ISAPI_REWRITE och htaccess). Därför har jag ändrat bildernas sökvägar till t.ex;

<img src="http://localhost/minsajt/img/frontpage.jpg" border="0">

eller

<img src="/minsajt/img/frontpage.jpg" border="0">

 

Detta borde i min värld fungera men icke. Stänger jag av rewritingen så syns de igen....

 

Det konstigaste av allt (?) är kanske att med sökvägarna nämnda ovan så bildas en ram i samma storlek som bilden skulle varit, med ett sedvanligt kryss i som antyder att bilden inte hittats. Om jag däremot i sökvägen ändrar till en bild som inte finns så blir ramen bara lika stor som krysset. På något sätt måste den ju alltså "känna av" bilden men visar den ändå inte?!??!

 

min htaccess ser ut som följer:

 

RewriteEngine on

#RewriteCond %{REQUEST_FILENAME} -f [NC]

#RewriteCond %{REQUEST_FILENAME} -d [NC]

 

RewriteRule ^(.+?)/(.+?)/(.+?)/(.+?)/(.+?)/?$ /minsajt/show.asp?var1=$1&var2=$2&var3=$3&var4=$4&var5=$5 [NC,L]

RewriteRule ^(.+?)/(.+?)/?$ /minsajt/show.asp?var1=$1&var2=$2 [NC,L]

RewriteRule ^(.+?)/?$ /minsajt/show.asp?var1=$1 [NC,L]

 

har provat att ha med de två översta, nu bortkommenterade, raderna men ser fortfarande inga bilder och parametrarna hamnar då på fel ställe.

 

Är helt ny på htaccess så all hjälp mottages tacksamt!

 

Mvh,

 

Lisa

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...