Just nu i M3-nätverket
Jump to content

index passa om


stefan_rk

Recommended Posts

Hej, Har lite problem med en index+passa formel i excel och vet inte hur jag ska lösa den.

 

Jag har en tabell med massa poster med id-nummer (Kolumn B) och ett datum (kolumn E). Id-numren förekommer flera gånger med ett datum knytet till sig. Och kan se ut typ så här

1084 2008-10-03

1345 2008-10-03

1764 2008-10-05

1084 2008-10-04

1345 2008-10-05

1764 2008-10-07

1084 2008-10-10

1345 2008-10-10

1764 2008-10-10

1084 2008-10-13

1345 2008-10-13

1764 2008-10-15

1084 2008-10-23

1345 2008-10-23

1764 2008-10-23

 

Vad jag vill göra är att plocka ut minsta och högsta datum för ett specifikt id-nummer och räkna ut antal dagar som skiljer mellan dessa två.

 

Vad jag hittills lyckats med är det här

=INDEX(Pejling!E:E;PASSA(MAX(Pejling!E:E);Pejling!E:E;0);1) - INDEX(Pejling!E:E;PASSA(MIN(Pejling!E:E);Pejling!E:E;0);1)

 

Men det här tar största och minsta datum i hela tabellen och inte för ett specifikt id-nummer

 

Det verkar inte gå att lösa med en enkel OM som det här:

= OM(Pejling!B:B=1084;INDEX(Pejling!E:E;PASSA(MAX(Pejling!E:E);Pejling!E:E;0);1)) osv...

 

Någon som har något förslag?

Mycket tacksam för hjälp!

 

/Stefan

 

 

 

 

Link to comment
Share on other sites

Om du vill använda formler måste du i förväg känna till vilket ID-nummer du söker. Har du det kan man använda en matrisformel för att ta fram raden. Säg att du har ID-numret givet i cell D8 och din tabell i A1:B16

 

Max:

{ =MAX(((MAX((A2:A16=D8)*B2:B16)=B2:B16)*RAD(B2:B16))) }

min

{ =MAX(((MIN(OM((((A2:A16=D8)*B2:B16)=B2:B16);1;99))*RAD(B2:B16)))) }

 

Matrisformler, måsvingarna ska du icke kopiera. Excel skriver in dem när du matar in dem som matrisformler, avsluta inmatningen med CTRL+SHIFT+Enter.

Fast notera att formlera ger sista raden som samma datum finns på, ej exakt den raden som datumet och ID-värdet finns.

 

Ed: äsch, skriv dem som

{=MAX(((MAX((A2:A16=D8)*B2:B16)=B2:B16)*B2:B16))}

istället så får du ut datumet istället för raden.

 

Samt matrisformler är tunga att beräkna.

 

En pivottabell kan däremot fixa det hela mycket enkelt.

 

Du har rubriken ID för ID-fältet, Datum över datumfältet. Skapa en Pivot utifrån din tabell, lägg ID som radettikett och två kopior av datum som värden/datavärden. Sätt ena datum till Max, andra till Min.

Klart

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2008-12-03 13:19:25 av Monshi]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...