Just nu i M3-nätverket
Jump to content

SATA problem


Mardin

Recommended Posts

Jag har efter att ha fått virus på datorn formaterat den och tänkte installera Windows XP. Här stötte jag på ett problem under installationen kom ett felmeddelande upp där det står följande: Installationsfel "Det gick inte att aktivera installationsprogrammet för CDROM. Kontakta din maskinvaruåterförsäljare för besked."

 

Efter de försökte jag några gånger till utan framgång. Sen försökte jag installera Vista istället där blev det också problem tyvärr. Men jag fick lite mer information om vad det kunde bero på. Det stod att en drivrutin saknas eller var skadad, namnet på filen som saknades hette adp94xx.sys. Jag sökte på det på Internet och det är troligtvis drivrutiner till SATA. Jag laddade ner denna drivrutin och la in den på ett USB-minne och försökte installera den i installationsprogramet för Vista men det står att det inte gick att hitta några drivrutiner. Jag försökte även att hitta dessa drivrutiner på skivan som kom med moderkortet men samma sak där.

 

Är det någon som vet hur man installerar drivrutiner utan opperativsystem eller om jag gör något fel när jag försöker hitta dem innan installationen av Vista?

 

Link to comment
Share on other sites

Är det någon som vet hur man installerar drivrutiner utan operativsystem

Välkommen till eForum!

 

Det lär inte gå.

Har du rätt drivrutiner för moderkortets SATA-kontroller?

Under installationsfasen har du alternativet Läs in drivrutiner, men jag antar att det har du sett. Om inte drivrutinerna hittades vid ditt försök, kanske du kan testa en annan USB-port?

 

Link to comment
Share on other sites

Tack!

Jag provade nu med två andra USB-portar men de gick inte att hitta några filer då heller. De drivrutiner jag har laddat ner var dels några jag hittade på en sida som heter runscanner.net (första sidan jag fick upp när jag sökte på "adp94xx.sys"), när datorn inte hittade den filen laddade jag ner nya från asus hemsida. Dessa måste ju vara rätt eftersom jag hittade de efter att ha valt just mitt moderkort i en lista. Jag trodde att det skulle fungera men de gick inte att hitta de filerna heller.

Vet du om det måste vara något speciellt filformat på drivrutinerna för att datorn ska kunna hitta de?

 

Link to comment
Share on other sites

P5K Pro

 

Jag provade att trycke på reparera istället för installera då kom det upp en ruta där jag kunde välja att lägga till drivrutiner. Där lyckades jag hitta drivrutiner på moderkortsskivan och installera dessa. Jag får lov att leta manuellt men jag vet inte vilken det är som löser mitt problem, jag har provat ett par stycken nu men de har inte fungerat...

 

Link to comment
Share on other sites

Moderkortet har två olika controllers för SATA. Både Intel och Marvell. Vet du vilken du har kopplat din hårddisk till? Har du 32- eller 64-bit Vista?

 

Link to comment
Share on other sites

32-bit vista.

Hur vet jag om hårdisken är kopplad till Intel eller Mavell?

Så här stod det om moderkortets lagringsgränssnitt på datorbutikens hemsida:

 

Intel ICH9R : Serial ATA-300 - kontakt(er): 6 x 7 pin seriell ATA - 6 Enhet (Enheter) - RAID 0 / RAID 1 / RAID 10 / RAID 5

Marvell 88SE6102 : ATA-133 - kontakt(er): 1 x 40 pin IDC - 2 Enhet (Enheter)

 

Om det då betyder att jag har 6st Intel och 1 Marvell så är båda mina hårddiskar och min DVD-brännare kopplade till Intel.

 

[inlägget ändrat 2008-10-14 21:49:23 av Mardin]

Link to comment
Share on other sites

Intel ICH9R

Har du kopplat till Intels SATA controller behöver du inte ladda några drivrutiner, då dessa ingår i Vista. Intel är en garanti för inga problem med Windows.

Har du däremot kopplat SATA-disken till Marvells, kan du behöva ladda drivrutiner. Men det är ändå ingen garanti. Marvell SATA-controller och Windows är ett dokumenterat problem, i alla fall med 64-bitars Windows.

Du får helt enkelt titta i moderkortsmanualen där det finns en bild på var resp. controllers portar sitter.

Har du en full- eller uppgraderingsversion av Vista, bootat datorn med den och startat från DVD:n... för att göra en nyinstallation?

 

Link to comment
Share on other sites

Skivan jag har är en fullversion av Vista. Av det jag kan utläsa av manualen så använder jag Intel portarna.

 

Nu har jag lyckats installera den senaste versionen av BIOS genom ASUS EZ Flash 2 utility. Efter det har jag försökt installera Vista igen men ett nytt fel uppstår.

Det stod: "Det gick inte att komma åt den begärda filen F:\Sources\Install.wim. Kontrollera att alla filer som behövs för installationen är tillgängliga, och starta därefter om installation. Felkod: 0x800701E7."

 

Jag försökte en gång till denna gången gick det bättre. Första delen av installationen gick för första gången bra men sen när datorn skulle starta om och fortsätta gick det inte att starta datorn. Den fastnade i de läget där man kan välja att starta i felsäkert läge osv. Det stod att jag skulle försöka reparera installationen genom att boota med skivan och välja "reparera".

 

Jag försökte reparera men det gick inte. Under fliken visa probleminformation kom det upp en lång lista med numrerade "Problemsignaturer". Problem händelsens namn var "StartupRipairV2".

 

Vet du vad det beror på och hur jag kan lösa detta problem?

 

[inlägget ändrat 2008-10-15 18:55:39 av Mardin]

Link to comment
Share on other sites

Boota med Vista-skivan och välj att installera, men gör en formatering först. Då du har kommit till "Var vill du installera Vista?", välj Formatera och när det är klart skapa en ny partition.

 

[bild bifogad 2008-10-15 19:35:25 av Maratonmannen]

1090206_thumb.jpg

Link to comment
Share on other sites

Jag har gjort en speciell partition som jag har avsett för att bara ha OS och andra program på. Den har jag formaterat i stort sett varje gång jag har försökt.

 

Nu har jag försökt ett antal gå gånger till med varierande resultat. Ibland kommer rutan upp om "...Install.wim...". Andra gånger går installationen igenom, men sen när datorn startar om går det inte.

 

Jag har försökt hitta information om problemet men jag har inte hittat något som har hjälp mig specifikt men det mesta tyder på att det har med SATA-drivrutinerna att göra.

 

Link to comment
Share on other sites

ok, du har skippat xp och ska ha in vista? Varifrån kommer Vista-skivan? Låter för mig som filen install.wim är korrupt

 

[inlägget ändrat 2008-10-15 21:11:01 av 2Many2]

Link to comment
Share on other sites

Jag skulle helst ha in XP igen som jag hade förut, men när jag försöker med min XP skiva får jag alltid upp samma ruta om att det inte gick att aktivera installationsprogramet för CDROM. Så därför har jag mest försökt med vista där jag får olika fel så det känns som att det går lite mer åt en lösning på problemet i alla fall.

 

Efter att jag tröttnat på samma fel i XP hela tiden har jag lånat en kompis vista-skiva för få igång datorn.

 

 

 

 

Link to comment
Share on other sites

jag undrade nog mer om det var en köpeversion av vista eller en egenhändigt hemtankad :) Är det en äkta går det ju att ladda ner helt fräscha installationsfiler

 

Link to comment
Share on other sites

Kan bli svårt att hämta fräscha filer eftersom nyckeln redan används.

 

Försökte installera XP en gång till fast denna gång på den andra fysiska hårddisk jag har. Tänkte att felet kunde ha något att göra med den andra hårddisken. Men denna gång fick jag upp ett nytt felmeddelande ganska likt det första. Istället för att det stod att det inte gick att aktivera installationsprogramet för CDROM stod det DiskDrive.

 

 

Link to comment
Share on other sites

Hur ska jag installera denna fil? Jag kommer ju inte igenom installationen helt så jag måste få in den någon gång under installationen.

 

Link to comment
Share on other sites

När jag testkörde WAIK så tankade den snällt ner en helt fräsch image på Vistas installationsfiler som jag kan bränna eller montera i Daemon.

 

Om det nu kan vara så, som jag sett i vissa trådar, att det är fel på en del installations-cd så kan man alltså skapa en ny

 

[inlägget ändrat 2008-10-16 18:36:00 av 2Many2]

Link to comment
Share on other sites

Hur ska jag använda skivan? Jag har försökt nu med att installera Vista som misslyckades. Sen försökt använda skivan men lyckas inte. Har dels försökt boota med den, provat att reparera installationen och försökt hitta drivrutiner men inget fungerar.

 

Link to comment
Share on other sites

om jag läser tillbaka en smula... är verkligen diskar och cd kopplade till rätt kontroller? Om datorn inte ens bootar med skivan, eller när den gör det klagar på disken, kan tyda på att nåt är skevt med koppling och ev drivrutiner

 

Link to comment
Share on other sites

De går att boota med både Windows skivan för XP och Vista. Jag har inte gjort om någon fysisk koppling sen jag köpte datorn. Jag har formaterat datorn en gång förut och då gick det bra så jag vet inte vad som kan ha hänt nu?

 

Är det meningen att datorn ska vara helt formaterad när jag bootar med skivan jag laddade ner?

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...