Just nu i M3-nätverket
Gå till innehåll
jp84

Problem komma in i mapp, win2003 server php

Rekommendera Poster

jp84

Hej

 

Har en win2003 server som jag skall köra en php-sida på. Har dock problem att komma åt mappen där webbplatsen ligger.

 

Går jag in via en webläsare på http://ipnummer/mapp/ så kommer ett lösenordskrav upp: (se bifogad bild).

 

Fyller jag i mina inloggningsuppgifter till servern kommer jag in.

 

Hur tar jag bort lösenordsskyddet?

 

Kör .NET sidor på samma server där detta problem inte uppkommer..

 

Tack på förhand!

 

[bild bifogad 2008-09-12 16:32:10 av jp84]

1081568_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Stäng av Integrated Windows authentication och använd bara Anonymous access i säkerhetsinställningarna för sajten i IIS.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jp84

Jag har anonymous access ikryssat. Som jag förstår det så "kör den över" alla inställningar man har under den, till exempel "Integrated Windows.."?

 

De används först då den Anonyma Accessen inte lyckats, eller hur?

 

Om jag gör som du säger så får jag bara "No Authority..." och lösenordsprompten kommer inte ens upp. Detta borde ju betyda att det är något problem med att ge en Anonym Access överhuvudtaget?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cluster

Kan även mycket väl vara NTFS-rättigheter. Har för mig att IUSR måte ha execute-rättigheter på den mapp där php.exe / php-cgi.exe ligger.

 

Du kan kolla detta genom att anropa en statisk .htm-fil (i samma mapp) direkt.

 

/Cluster

I do not fear computers. I fear the lack of them

> http://eforum.kicks-ass.net <-

 

 

[inlägget ändrat 2008-09-12 17:10:54 av Cluster]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jp84

Är osäker, men tror inte att det är där felet ligger, eftersom ex. phpmyadmin fungerar fint. Det är endast en mapp/websida som inte fungerar.

 

[inlägget ändrat 2008-09-12 17:19:05 av jp84]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Ditt problem verkar då kanske ligga i filsystemets rättigheter. Slå av Windows Auth och kontrollera att IUSR_-kontot har läsrättigheter på alla filer som skall ha det och execute på de som skall ha detta.

 

[inlägget ändrat 2008-09-12 17:14:47 av Anjuna Moon]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jp84

Hur kontrollerar man IUSR_-kontot på filerna?

 

Såg att Cluster hade svar på hur man kontrollerade. Hur ändrar man då?

[inlägget ändrat 2008-09-14 10:47:04 av jp84]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jp84

Det hände samma sak när jag anropade htm-filen. Så då antar jag att det inte har något med php-koden att göra iaf?

 

Hur ändrar man rättigheterna för IUSR?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...