Just nu i M3-nätverket
Jump to content

Excel 2007, tabeller, namn och formler - låsa kolumner


Monshi

Recommended Posts

Det är ju smidigt att i Excel 2007 att använda tabellnamn i formler. Men hur gör man för att låsa en referens till en viss kolumn?

 

Säg att man har en tabell med kolumnerna Namn, Datum, Värde

 

man vill summera alla värden för ett namn givet ett datum och man skapar då en tabell med namn som radrubrik, datum som kolumnrubrik och så skriver man i stil med

=SUMMA.OMF(Tabell1[[#Allt];[Värden]];Tabell1[[#Allt];[Namn];$A2;

Tabell1[[#Allt];[Datum];B$2)

Så vill man kopiera ut denna åt höger, för att ta fler datum men samma namn.

 

Hur låser man referenser till tabellens kolumner?

 

och ja, jag vet, det ovan skulle en Pivot klara av galant men ta exemplet för vad det är, inget annat. (samt formeln skriver på frihand, något litet fel kan ha smugit sig in)

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2008-09-02 09:44:36 av Monshi]

Link to comment
Share on other sites

ExcelSpecialisten

Mig veteligen går det inte att skapa absoluta referenser av tabellkolumner i 2007.

 

Har försökt några gånger tidigare men fått namnge mina kolumner själv istället.

 

Så lösningen för dig blir nog att namnge din namnkolumn.

 

Ursäkta för det tråkiga svaret. Hittar du en lösning så blir skulle det hjälpa oss också.

 

 

Verksamhetslösningar i MS Excel.

www.xls.se

utbildning@xls.se

 

Link to comment
Share on other sites

Misstänkte att det svaret skulle komma. Har själv testat och letat och...

 

Ja, kanske enklast är att gå via ett namn som i sig refererar till kolumnen.

 

Slutsats - detta har inte MS löst på något bra sätt! Kan till detta bifoga att redigeringen av referens/automatiska ifyllnaden även den har sina brister. Inte ovanligt att man skriver över del av formeln när man låter Excel fylla ut en referens.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Men - va fnkn!

 

Skapar ett namn

tbNamn = =Tabell2[Namn]

och använder det i en enkel formel

=ANTAL.OM(tbNamn;M8)

och kopierar/drar den till höger, dvs

=ANTAL.OM(tbNamn;M9)

så ändras den namngivna referensen till

tbNamn = Tabell2[Datum]

vilket då är nästa kolumn i tabellen.

 

Är mitt Excel som är knäppt eller går inte ens detta? Måste jag ta till INDEX eller Förskjutning för att det ska gå? kan jag ens nyttja de ack så smidiga kolumnamnen så som jag önskar? Detta är ju knäppt!

 

Edit: Eller kanske INDIREKT. Men då tappar jag ju möjligheten att någon ändrar namnet på tabellen... Fast det är kanske ett litet problem jämförelsevis. Men fasiken vilken miss av MS.

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2008-09-02 11:58:15 av Monshi]

Link to comment
Share on other sites

Fast nu kanske en enklare lösning.

 

problemet uppstår ju om man drar/fyller ut formler.

 

Om man kopierar cellerna istället, då stannar referensen till tabellen kvar. Likaså om man skriver in en formel över flera celler via inmatning med avslut med CTRL+Enter så förblir referensen densamma.

 

Tja, man lär sig något nytt varje dag (om man har tur)

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...