Just nu i M3-nätverket
Gå till innehåll
Timzorize

Hosta själv

Rekommendera Poster

Hej,

 

Jag använder WAMP5 och har tänkt hosta en webbsida från min egna dator.

 

Jag förstår förstås att så länge man har på datorn hostas sidan.

 

Som sagt, jag använder mig utav WAMP5 och har OS Windows XP Professional Sp2.

 

 

Finns ju en tråd om detta:

 

//eforum.idg.se/viewmsg.asp?EntriesId=988112

 

Men det går inte att högerklicka på WAMP servern nere i aktivitetsfältet och sedan klicka "Put online".

 

Alternativen vid högerklick är: About, Help file..., Exit.

 

Har statisk ip, kan öppna portarna, vilken port ska upp? 80?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hmmm... Har för mig att man ska vänster-klicka.

Nåja

 

Har du IIS installerat/igång på datorn?

 

Snurrar Apache- och MySQL-tjänsterna?

Vad är det för färg på WAMP-ikonen i aktivitetsfältet?

If the colour of the semicircle is white then its working correct.If the color is yellow then either Apache or Mysql is not running on your system.If the color is red then none of them are running on your PC.

 

Har du följt någon speciell guide vid installation/konfigurationen, i så fall vilken?

Om du gjorde det fungerade allt på det sätt som det beskrevs i guiden?

 

 

Timzorize skrev:

vilken port ska upp? 80?

Jupp!

 

Dessutom så är det väl så, om jag har fattat rätt att WAMP5 numer heter WampServer 2.0?

Vet inte om det skiljer något mellan dessa eller om det bara är namnet men jag skulle nog rekomendera att se till att köra den senaste versionen av WAMP (vad den än må heta) för att dels se till att få med all funktionalitet men främst för säkerhetens skull.

 

[edit:] För övrigt så har du ju haft liknande frågor uppe tidigare (samt en korspostning som har raderats)...

//eforum.idg.se/viewmsg.asp?entriesid=1004746

//eforum.idg.se/viewmsg.asp?entriesid=1009987

Dock så har du inte varit så bra på att återkomma med svar på frågor eller återkoppling på hur det har gått. Om du hade gjort det så kanske det hela hade varit löst vid det här laget...

 

/Cluster

I do not fear computers. I fear the lack of them

> http://eforum.kicks-ass.net <-

 

 

[inlägget ändrat 2008-08-05 01:41:44 av Cluster]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har inte IIS installerat/igång på datorn.

 

Apache- och MySQL-tjänsterna snurrar, (All service running) och ikonen är vit med hastighetsmätaren fullt till höger.

 

Jag följde ingen guide, men min localhost fungerar utmärkt.

 

 

Nu är det så att port 80 redan används, så jag antar att jag måste konfigurera om något i httpd.conf för att den ska veta vilken den nya porten ska bli?

 

Min config ser just nu ut såhär:

 

http://www.aspsidan.se/code/?c=23488

 

 

 

Sedan, ska folk kunna connecta genom min ip samt jag skriver localhost eller 127.0.0.1?

 

Exempel: minpublicaip:minport/index.php ?

 

 

[inlägget ändrat 2008-08-05 09:16:26 av Timzorize]

[inlägget ändrat 2008-08-05 09:21:01 av Timzorize]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Själv har jag registrerat ett namn hos DynDNS och installerat deras program för att automatiskt uppdatering av ip-nummer. Nu har du tydligen statisk publik IP så då behövs väl inte det sista.

 

Jag kan connecta till min lokala webserver genom det namn jag registrerat, oavsett om jag sitter inne i mitt LAN eller om jag är utanför.

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nu är det så att port 80 redan används[...]
Om den redan används så kan det göra, beroende på vilken applikation som använder den och hur, att det hela inte funkar som du har tänkt dig.

Om du väljer att köra Apache på en annan port än 80 så måste de som skall surfa till din(a) webbplats(er) veta att de måste ange den port som du har valt, typ: http://dittipnummerellerwebbadress.nu:8080

 

[...]jag antar att jag måste konfigurera om något i httpd.conf för att den ska veta vilken den nya porten ska bli?
Jobbar själv väldigt sällan med Apache men dokumentationen finns på nätet för allmän beskådan och begrundan....

http://httpd.apache.org/docs/2.2/bind.html

 

Sen måste du såklart portforwarda den aktuella porten i ev. router samt se till att din brandvägg tillåter inkommande trafik på porten.

 

lizardKng skrev:

Nu har du tydligen statisk publik IP så då behövs väl inte det sista.

Är den verkligen publik?

Nåja, Timzorize du kan iaf kolla på tex. http://mittip.se/ för att se vilket IP det är som dina besöka skall gå till.

 

/Cluster

------------------------------------------------------

I do not fear computers. I fear the lack of them

--------> http://eforum.kicks-ass.net <---------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Så här har jag skrivit i min httpd.conf:

 

NameVirtualHost 192.168.0.200:9100
Listen 9100

<VirtualHost 192.168.0.200:9100>
  DocumentRoot "C:/nobackup/apache-htdocs"
  <Directory "C:/nobackup/apache-htdocs">
     Options None
     AllowOverride None
     Order allow,deny
     Allow from all
  </Directory>
</VirtualHost>

 

Att skriva in det som en "VirtualHost" är bra, det gör det t ex enkelt att hosta flera websiter med samma webserver.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Lugn å fin. Försöker bara hjälpa till här...

 

Om du läser/söker i din httpd.conf så hittar du ganska fort en rad (268

) med Port 80

 

Länkar för övrigt så mycket jag vill.

Det kan ju hjälpa andra som söker efter lösningar på sina problem och orkar/kan läsa (engelska) manualer...

 

/Cluster

I do not fear computers. I fear the lack of them

> http://eforum.kicks-ass.net <-

 

 

[inlägget ändrat 2008-08-05 14:02:55 av Cluster]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vad ska jag skriva där det står: "C:/nobackup/apache-htdocs"?

 

 

Jag har gjort samma sak som LizardKng fast ändrat porten till 1337. Det kommer upp en ruta när jag skriver in localhost:1337 och frågar om jag vill ladda ner en fil (application/octet-stream).

 

Skriver jag localhost utan :1337 efter så kommer jag till min index.htm som funkar utmärkt.

 

 

 

När min kompis prövade från ett annat nätverk fick han samma meddelande, dvs att ladda ner filen (application/octet-stream).

 

Så det betyder att han kommer in genom portarna, men nu måste jag väl ändra så att den ska läsa av index.php istället för application/octet-stream

(2sutgB48.part). Där innehållet i filen är: B

5.0.51b-community-nt . |,b-UE:3 ,¢ 1;rQ{<Tq[V}6 ÿBad handshake

[inlägget ändrat 2008-08-05 14:30:26 av Timzorize]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Vad ska jag skriva där det står: "C:/nobackup/apache-htdocs"?

 

Sökvägen till dina websidor.

 

Vill du bara ha en site så behöver du inte använda virtual hosts.

 

En virtual host är en site fristående från de andra. Man kan ha olika direktiv för olika siter.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Alltså såhär ser hela min httpd.conf fil ut:

 

NameVirtualHost 192.168.1.5:1337
Listen 1337

<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/nobackup/apache-htdocs"
  <Directory "C:/nobackup/apache-htdocs">
     Options None
     AllowOverride None
     Order allow,deny
     Allow from all
  </Directory>
</VirtualHost>

 

 

 

Och om jag skriver:

 

NameVirtualHost 192.168.1.5:1337
Listen 1337

<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/wamp/www"
  <Directory "C:/wamp/www">
     Options None
     AllowOverride None
     Order allow,deny
     Allow from all
  </Directory>
</VirtualHost>

 

Så vill den fortfarande att jag ska ladda ner application/octet-stream.

 

 

Kan man inte skriva såhär, t.ex:

 

 


NameVirtualHost 192.168.1.5:1337
Listen 1337

<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/nobackup/apache-htdocs"
  <Directory "C:/nobackup/apache-htdocs">
     Visa "C:/wamp/www/index.php" <---- Jag vill att den ska visa DEN Filen istället för att jag ska måsta ladda ner application/octet-stream! Kan man länka den till C:/wamp/www/index.php? Isåfall, HUR?!
     Options None
     AllowOverride None
     Order allow,deny
     Allow from all
  </Directory>
</VirtualHost>

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vad har du för värde angivet för DirectoryIndex ?

 

Det du kan/ska göra är alltså att lägga till DirectoryIndex index.php i Directory-direktivet för din VirtualHost.Typ:

<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/wamp/www"
  <Directory "C:/wamp/www">
     Options None
     AllowOverride None
     Order allow,deny
     Allow from all
     DirectoryIndex index.php
  </Directory>
</VirtualHost>

 

[edit:]Funkar det för övrigt om du går direkt till

http://dittipnummerellerwebbadress.nu:1337/index.php ?

 

 

/Cluster

I do not fear computers. I fear the lack of them

> http://eforum.kicks-ass.net <-

 

 

[inlägget ändrat 2008-08-05 17:21:41 av Cluster]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Får samma meddelande med din kod, och mina kompisar får samma sak.

 

Sen så vill jag inte ha virtual host, jag vill ha EN bara.

 

 

ni kan kolla själva hur det ser ut: www.zorize.foo.se

[inlägget ändrat 2008-08-05 17:25:54 av Timzorize]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hmm, håller som sagt aldrig på med Apache så det är lite gissa, rita, spring här... :)

Testa med minimalt antal operander:

<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/wamp/www"
  <Directory "C:/wamp/www">
     Options All
     DirectoryIndex index.php
  </Directory>
</VirtualHost>

 

Kolla även DirectoryIndex för <IfModule mod_dir.c>

 

Har du testat att gå direkt mot index.php som jag skrev ovan?

 

/Cluster

------------------------------------------------------

I do not fear computers. I fear the lack of them

--------> http://eforum.kicks-ass.net <---------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Japp, det har jag testat.

 

 


<VirtualHost 192.168.1.5:1337>
  DocumentRoot "C:/wamp/www"
  <Directory "C:/wamp/www">
     Options All
     DirectoryIndex index.php
  </Directory>
</VirtualHost>

 

Funkade inte heller :S Precis samma fil som kommer upp.

 

Alltså koden ovan är den koden som jag har i httpd.conf

 

Jag har ENDAST den koden, jag tog bort ALLT annat.

 

[inlägget ändrat 2008-08-05 18:05:12 av Timzorize]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

hmm, det tror jag inte är helt ok...

 

Varför inte börja med en komplett httpd.conf som du anpassar. Sen kan du ta bort onödigt/överflödigt samt anpassa den efter dina behov/önskemål.

 

/Cluster

------------------------------------------------------

I do not fear computers. I fear the lack of them

--------> http://eforum.kicks-ass.net <---------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nej precis, det går ju inte alls. Håller med, börja med standardkonfigurationen.

 

Timzorize: Du hade en konfiguration som fungerade så när som på portnumret?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Timzorize: Du hade en konfiguration som fungerade så när som på portnumret?

 

 

Va?

 

 

 

 

Vadå konfigurera om, då gör jag ju allt själv från början. Kan inte NI som är här för att hjälpa mig konfigurera om den så den connectar till port 1337?

 

Min lanip är 192.168.1.5

 

Min publika är: 79.133.25.27

 

www root ligger: C:\wamp\www\index.php

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Kan inte NI som är här för att hjälpa mig konfigurera om den så den connectar till port 1337?

Det är ingen på Eforum som får betalt för att hjälpa någon utan alla gör det gratis för att det är kul. Men folk tycker inte att det är kul längre om någon ställer krav och inte vill göra något själv.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Va?

 

Jag fick intrycket av vad du skrev 09.17 i går att du hade en fungerande konfiguration men den använde fel port.

 

För örvigt, läs vad Cecilia just skrev. Jag har inget emot att hjälpa till men grovjobbet får du allt göra själv.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ni är faktist inte snälla alls nu, jag har inte fått någon hjälp för det funkar inte!

 

 

Okej, säg HUUUUUUUUUUUUUUUUUUUUUUR jag ska göra för att kunna göra så att den connectar till port 1337. MIn lanip är 192.168.1.5 och publika är 79.133.25.27.

 

Ni måste berätta i MINSTA detalj för jag förstår inte annars!

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag tycker vi är jättesnälla som hjälper till, helt gratis och på vår fritid!

 

1. Återställ httpd.conf som den var från början.

2. Ändra portnumret från 80 till 1337 på de ställen det förekommer.

3. Ändra sökvägen till där du har dina websidor. Samma sak här, det är flera ställen det måste ändras på.

 

Starta sedan servern och kika i logfilen så det inte blir nåt fel. Testa sedan om det funkar med localhost:1337 och/eller 192.168.1.5:1337

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...