Just nu i M3-nätverket
Gå till innehåll

Ta bort felaktiga mailadresser


BjörneL

Rekommendera Poster

Hejsan!

 

Jag lärde mig något nytt här idag.

Att rensa bort dubletter i en jättelång lista av mailadresser.

 

Nu har jag ett problem kvar.

 

Kan man på något sätt få excel att radera fält/rader som inte innehåller @ osv.

Så att man bara får "korrekt inskrivna" mailadresser

 

Mvh

 

Björne

 

Länk till kommentar
Dela på andra webbplatser

Nja, enklast är att hjälpa Excel på vägen:

1: skriv in denna formel i kolumn bredvid din kolumn med mailadresser:

=OM(ÄRFEL(SÖK("@";A1));FALSKT;SANT)

(antar adress skriven i A1).

2: Applicera sedan Autofilter på hela din lista, välj i kolumnen med formeln ovan att visa celler med FALSKT i.

3: Markera de rader som visas (hela raderna) och radera dem.

4: Ta bort autofiltret.

 

Klart.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Länk till kommentar
Dela på andra webbplatser

Du kan faktiskt hoppa över formeln.

 

Filter, Autofilet

Klicka på "rullgardinspilen" och välj Anpassa.

Där kan du välja "innehåller inte" @.

Högerklicka och välj "ta bort rad"

Visa alla.

 

Eller, om du vill använda formeln, sortera istället. Mycket smidigare.

 

 

Länk till kommentar
Dela på andra webbplatser

Ack så enkelt...ack så dumt att missa.

tack MH2 för det självklara!

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Länk till kommentar
Dela på andra webbplatser

Fast å andra sidan är det ganska kul att krångla till det. Vad ytror du om den här UDF'en?

 

Public Function ÄrAdress(Cell As Range) As Boolean
If Cell.Hyperlinks.Count > 0 Then
   If InStr(1, Cell.Hyperlinks(1).address, "@") _
       And InStr(1, Cell.Hyperlinks(1).address, ".") Then
           ÄrAdress = True
   End If
Else
ÄrAdress = False
End If
End Function

 

Ok, jag är uttråkad...

 

Länk till kommentar
Dela på andra webbplatser

det blir :thumbsdown:

då jag givit en Excel-funktion som fixar det. Men visst, vill man komplicera det än mer så kan man göra på det viset.

 

Kan även tänka mig en Find som söker efter celler inom ett område som innehåller @-tecken. Sedan tar man alla celler Find inte fann och raderar dessa...

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Länk till kommentar
Dela på andra webbplatser

Arkiverat

Det här ämnet är nu arkiverat och är stängt för ytterligare svar.

×
×
  • Skapa nytt...