Just nu i M3-nätverket
Jump to content

DVD-ljud fungerar ej


Perry

Recommended Posts

Har varit här tidigare med samma fråga men lyckades inte få något svar. Har fått lite mer kött på benen så jag försöker igen.

 

Har en toshiba laptop A100-230 inköpt för ett par månader sedan. Tog ett tag, men när jag skulle kolla en dvd så funkade det inte (knappt). Bild är perfekt. Det är ljudet som inte hänger med. Knastrar, hoppar, ekar. Ringde toshiba support. Deras råd var att avinstallera allt... En produktåterställning - för att sedan se om det blev bättre. Dom trodde att det kunde vara ett annat program som (kommer inte på det korrekta ordet...) "störde". Det skulle isåfall visa sig när jag installerade allt igen... Nu har jag inte gjort något av ovanstående än - känns väldigt stort och jobbigt - speciellt när man inte är så haj på datorer...

Vad jag däremot har gjort är att upptäcka att när jag använder express media player (som följer med toshiba - och som används utan att windows är påslagen) - så funkar ljudet perfekt. Slutledning: Det ÄR något program som "stör".

Frågan är således: Finns det något enklare sätt att få reda på vilket program det är som stör än att behöva ominstallera ALLT? Och hur gör jag i så fall?( Kan det vara mediamonkey, WMP 10 eller kanske det inte behöver vara ett mediaprogram?)

 

JÄTTETACKSAM FÖR HJÄLP!

 

Link to comment
Share on other sites

Jobbigt problem. Svårt att diagnostisera men ett litet försök kan man alltid göra.

 

Annat program som stör? På sätt och vis kanske. För att öka ditt kunnande kan jag enkelt beskriva vad som sker vid uppspelning av media.

 

1: Spelaren laddar filen, läser av en formatkod i filen

2: Spelaren fråga Windows, en ActiveX-komponent, om lämplig uppspelare för ljud resp. bild

3: Windows försöker utifrån installerade codecar och filter bygga en kedja som i ena änden läser filen/data och i andra förser programmet med det som önskas. Kedjans komponenter väljs utifrån ett ranking-system, varje codec/filter har en rang och den med högst rang som passar i kedjan väljs.

 

Ibland passar inte alla delar i kedjan fullt med varandra men väljs in ändå, då kan det uppstå problem. (en möjlig orsak med andra ord, inte den givna/självklara)

 

Program, ex.v. VLC, har ibland sina egna codecar, sina egna bibliotek.

Frågor: DivX/Xvid/MPEG - filmer från nätet, kan du spela upp dessa?

Kan du spela MP3?

Vad för program använder du för att spela upp DVD?

Är det bara vid just DVD som det strular?

Uppdaterade drivrutiner för ljudkort/grafikkort/moderkort? Några hårdvarukonflikter?

 

 

Påpekande: Har raderat din gamla tråd, enklare att hålla allt i en.

 

/T

Moderator Multimedia

 

Link to comment
Share on other sites

Gomorron.... och tack för svaret!

 

Svar: Ja, inga problem med filmer, klipp från nätet (nyheter, you tube m.m) - använder real eller wmp oftast. Om detta inkluderar divx/xvid/mpeg vet jag inte pga begränsad kunskap...

MP3 är inga problem.

Har provat WMP, Real, Intervideo Windvd och VLC - samma problem med alla. Bara i express media player, som sagt, det funkar - och den sätter man på utan att windows aktiveras

Ja - det är bara vid dvd uppspelning det strular.

Har uppdaterat ljudkort (Realtek HD audio) och grafikkort (Nvidia) - moderkort vet jag inte vad det är...

Inga hårdvarukonflikter så vitt jag vet - har ej fått några "meddelanden" om det.

 

Har även gått igenom codecs i kontrollpanelen (det fanns ett gäng - jag kan lista dom om du vill) för audio - och alla sägs fungera perfekt...

 

 

 

Link to comment
Share on other sites

Jag vet inte om jag kan hjälpa dig att lösa detta, men jag försöker...

 

Vi kan testa att rippa en DVD till hårddisken, montera ISO-filen med ex.v. Daemon Tools och försöka spela upp den som vanligt.

 

Ta även en titt i Systeminfo-porgrammet, kör msinfo32.exe från startmenyn, om ex.v. ljudkort delar IRQ med annan enhet. Ska inte vara något problem vanligtvis men kanske?

 

Vi kan alltid även testa installera Ffdshow, testar spela upp en DVD och ser att ffdshow audio decoder gör jobbet med ljudet. Video-decodning, som annars är ffdshows starka sida, tar någon annan enhet hand om.

 

 

Edit: Fast inget problem att aktiva ffdshow för DVD även om det i config-dialogen stod 'not working yet'

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2007-04-01 13:08:13 av Monshi]

Link to comment
Share on other sites

Jag är hemskt tacksam för din hjälp!!!

 

Ska beta av dina förslag ett i taget - kan ta en dag eller två beroende på hur mycket tid jag har tillgänglig...

 

Systeminfo och Ffdshow förslagen förstår jag. Men att montera ISO filen med Daemon Tools förstår jag inte - ISO fil? Hur monterar jag?

Som sagt, inte jättekunnig på datorer - men man lär sig.....

 

Än en gång - TACK! Jag återkommer.

 

 

Angående systeminfo: kollade precis ser inget - men jag kan ju lätt missa något... Ska jag lägga ut info om konflikter/delning och IRQ-användning så du kan kolla?

[inlägget ändrat 2007-04-01 21:38:46 av Perry]

 

Ffdshow Laddade ner den från download.com. Rätt? Eller ska det vara någon nyare version - läste nåt om try outs...

Efter installation så spelade jag upp en dvd - ingen skillnad. Ska jag göra några inställningar, aktivera el.l.? Verkar avancerat, så jag vill inte "trycka bort" mig...

[inlägget ändrat 2007-04-02 00:10:46 av Perry]

Link to comment
Share on other sites

ffdshow - kanske skulle lagt upp en källa:

http://www.afterdawn.com/software/video_software/codecs_and_filters/ffdshow.cfm

Brukar vara den nyaste och för det mesta en stabil version.

Men å andra sidan borde ljudstödet finnas där redan så testa först med den du nu har i datorn.

 

Enklaste sättet att se om FFDshow Audio .. används är att ställa in så att det visas i systemfältet (Tray)

 

Öppna config-dialogen för ffdshow audio, klicka tray $ dialog inställningar, markera Visa tray-ikon. Nu när vi ändå är inne i inställningarna kan vi kontrollera om ffdshow tar hand om DVD-ljud, vanligen AC3. Klicka Codec och kontrollera att AC3 är aktiverat och ställt till liba52.

 

ISO-fil...Sök lite här i forumet på ex.v. DVD rip så får du tips hur man gör det, sedan när man har en ISO-fil kan man emulera en DVD-skiva med Daemon tools, http://www.daemon-tools.cc/

Kanske är lite överkurs.

 

 

Systeminfo, IRQ, kontrollera enbart om ljudkortet delar resurs med ex.v. grafikkort, nätverkskort eller liknande. Resten är ointressant. Och ärligt - på en modern dator ska inte brist på interrupts kunna orsaka några problem, den tiden ska vara förbi.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

IRQ: Ingen uppgift om delning. Själva ljudkortet finns inte med alls - men microsoft audio nånting... :-) finns med - antar att det har hand om det.

 

Ffdshow: Trayiconen syns, i dialogen står det att media spelas upp, ac3 är aktiverat - problemet kvarstår...

 

ISO: Känns lite överkurs - och som jag förstår det måste man rippa en skiva innan man ser den - även om det skulle lösa problemet så blir det omständigt att rippa varje gång man vill kolla en dvd...

 

Börjar närma sig en produktåterställning allt mer - eller vad säger du?

 

Link to comment
Share on other sites

Tanken med ISO var att se om felet även uppstår vid uppspelning från disk.

 

men ärligt, som det visar sig i detta fallet är det svårt att hitta fel av denna art. Kan vara hårdvara, mjukvara eller användare (f'låt). Ofta tar det mycket längre tid att åtgärda felet än det skulle ta att helt enkelt installera om hela systemet med program och allt. Men nu är ju din datorn ganska så ny så risken finns ju att felet åter uppstår. Jag menar att du inte hunnit ställa till med så mycket ännu :)

 

Men, en sak till. Ta upp egenskaperna för din ljudenhet och som det finns något där du kan ändra....

 

Kanske ladda hem ett filmklipp med AC3-ljud, ljud motsvarande DVD, från nätet?

Högerklicka ffdshow-audio-ikonen och se den lilla menyn som kommer upp. Högst upp i denna står det vilka filter som används, vad nu det kan ge.

 

 

Nä, jag vet inte, men jag försöker. Kanske någon annan kan bidra med lite mer/annan anfallsvinkel?

 

 

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Förstår att felet (n) är svårt att hitta å uppskattar din hjälp.

 

Ja...användaren (...) kan ju också ha ställt till med nåt - fast om det har med här att göra det vet jag inte - hörs ett träd som faller i skogen om ingen är där.... Väntar lite med återställning - som du säger det kan ju återkomma. Tänkte lämna ner datorn till en pc affär på hörnet så får dom kolla upp den. Känns dock lite jobbigt att lämna ifrån sig datorn till nån man inte känner - hur vet man att dom inte "mixtrar" med den- övernojjig kanske... - men det är inte som att lämna in en bil på verkstan direkt.

Återkommer till tråden med resultatet så vet du vad som har hänt - om det händer nåt...

 

 

Sista fråga (å dum sådan...): Var hittar jag ett filmklipp med AC-3 - googlat å hållt på men går bara vilse - filmklipp är tydligen inte så lätta att ladda ner numera om man inte vet vart man skall leta. Tänkte testa det innan jag lämnar in den.

 

Tack för hjälpen så här långt!!!

 

/P

 

Link to comment
Share on other sites

Sista fråga (å dum sådan...): Var hittar jag ett filmklipp med AC-3 - googlat å hållt på men går bara vilse - filmklipp är tydligen inte så lätta att ladda ner numera om man inte vet vart man skall leta. Tänkte testa det innan jag lämnar in den.

Legal - vet ej riktigt.. Kanske MS och Apples HD-demoklipp? Annars är nog Pirate Bay och någon torrent ett tips.

 

Eller som sagt rippa en DVD och spela den från hårddisken, det kanske är enklast.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Hej - hoppas du är kvar...

 

Laddat ner film - inga problem med ljud - och det är rätt codec.

 

Men...jag upptäckte en sak igår. Problemet har INTE bara med dvd att göra. Köpte en skiva igår - normalt sett brukar jag rippa med en gång om jag ska lyssna i datorn. Men igår tänkte jag bara lyssna - och problemet dök upp där med! Kasst av mig att inte kolla - men kan inte minnas att problemet fanns sist jag lyssnade på en skiva (nån gång när jag köpte datorn). Funderar på om det kan ha att göra med wmp 11 (som microsoft laddade ner som prioriterad uppdatering...). Hade wmp 10 när jag köpte datorn.

 

Så...enklare eller svårare att lösa problemet?

 

P.

 

Link to comment
Share on other sites

mmh, mystiken tätnar. WMP11 borde inte påverka detta men vad vet jag?

 

Nä, jag är helt borta. Ingen aning. men det låter ju nästan som om problemet ligger i DVD-spelaren. Kontrollera egenskaperna för denna, kanske det ger något?

 

Annars får vi ropa och se om någon annan kan komma med nya, friska idéer till denna tråd! HALLÅ - NÅGON!

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

  • 2 weeks later...

låter liknande problem som har, om jag förstår dej rätt. Dvs, din dator är spelar upp ljud dåligt om det spelas upp ifrån enskiva, t ex cd-ljud eller ljudet på en dvd-skiva.

Har du kollat i aktivitetshanteraren samtidigt nån gång? Eller kanske hellre med ett prog som ersätter aktivitetshanteraren, nämligen process explorer.

För när jag gör någon som helst aktivitet med en cd eller dvd så boggar mitt system ner sej svårt. Så jag kollade i process explorer och vad får jag se, jo system interrupts går upp väldigt högt. Jag vet inte vad detta beror på eftersom jag inte hajjar denna del av MS wind*ws XP, men kanske finns det nån konflikt mellan olika interrupts(?)

Om nån med kunskap om detta kunde luska lite så vore man ju tacksam:)

 

 

[bild bifogad 2007-04-25 14:58:57 av barbafant]

940046_thumb.jpg

Link to comment
Share on other sites

Trodde jag var ensam med detta problem. Kanske inte... Har inte testat det du nämner - ska göra det så fort jag får en chans å tid... Var hittar man process explorer? (jag kan goggla det...).

 

Har inte varit här på ett tag men problemet kvarstår. Har lagt ner att försöka lösa det - var trött på alla misslyckade försök. Har även suttit med support och försökt att lösa det (på svenska, dansk-engelska å engelska........). Provade allt möjligt - avinstallationer, uppgraderingar m.m.m.m. - det sista förslaget lät som förut - PRODUKTÅTERSTÄLLNING....... Men jag orkar inte riktigt ta mig för det - all nedladdning av filer man vill spara osv. Har ingen extern hårddisk än så det känns som så mycket jobb - å så mycket som kan gå fel - även om support sa att dom skulle hjälpa mig över telefon......

Har dock fått tag på en kille som ska vara riktigt duktig - han ska komma över å ta en titt nån dag. Om han hittar nåt å löser det så ska jag återkomma och försöka förklara på mitt kassa dator språk hur det gick till. Men jag hoppas inte för mycket.......... Har fortfarande siktet inställt på den där förbannade pr.återställningen.......

 

Men jag ska testa ditt förslag. Tack så mycket!!! Hoppas nån med lite kunskap kommer förbi här och kan ge en hjälpande hand. :)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...