Just nu i M3-nätverket
Jump to content

Hjälp med matris


Anden66

Recommended Posts

Om jag har 10 blad i ett arbete med olika prislistor och vill ladda den prislistan när jag fyller i en cell i en med tex 55000 då vill jag ladda den prislistan så när jag fyller i varornas art nummer skrivs in så ska den hämta priserna från arbetsbladet som står i en specefik cell.

har

=OM($A14>0;LETARAD(TEXTNUM($A14);'55000'!$A$7:$H$288;4;FALSKT);0)

 

i stället för 55000 så vill jag att den letar i bladet som jag skriver i en cell typ A4 och ändrar jag i A4 till ett annat kund nummer så vill jag att den hämtar priser från det bladet. har provat skriva (A4) och allt sånt men får det inte att fungera

Hoppas jag inte har krånglat till det, Tacksam för svar

 

Link to comment
Share on other sites

5500 är alltså (exempel)namnet på ett kalkylblad?

Och

Du vill skapa en adress från texten i cell A4?

Då är det INDIREKT() du vill använda.

 

 

I OO-CALC blir formeln

=OM($A14>0;LETARAD(TEXTNUM($A14);INDIREKT("'"&A4&"'.$A$7:$H$288");4;0);0)

Observera att du måste skriva in enkelfnuttarna ' runt bladnamnet manuellt.

 

Hursomhelst, då borde Excelformeln bli:

=OM($A14>0;LETARAD(TEXTNUM($A14);INDIREKT("'"&A4&"'!$A$7:$H$288");4;FALSKT);0)

 

Naturligtvis på en rad

 

Nåja, kolla om det funkar i excel. Har för mig att indirekt har någon begränsning avseende bladnamn, men jag kommer inte ihåg vad

 

Märkligt att OO valt en egen avgränsare för Bladnamnet (även om det kanske är mer logiskt).

* ed *

Tog bort tokighet

 

[inlägget ändrat 2007-02-28 23:41:53 av MH2]

Link to comment
Share on other sites

En koll i excel visar att enkelfnuttarna inte behövs. Det här borde alltså räcka:

=OM($A14>0;LETARAD(TEXTNUM($A14);INDIREKT(A4&"!$A$7:$H$288");4;FALSKT);0)

 

 

Link to comment
Share on other sites

Fnuttarna behövs i Excel enbart om bladnamn man ger innehåller mellanslag men de gör ingen skada om de finns där även annars. Kan ses som en säkerhet inför den dagen du ändrar bladnamnet till något med mellanslag i.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Ahh, tänkte inte på det problemet :-) Trodde bara det behövdes för att skilja siffernamn från "position". Men natuligtvis måste det vara mellanslag som jävlas mest.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...