Just nu i M3-nätverket
Gå till innehåll
FiEnD

Lägga till en ASP.NET 2.x site i IIS? Funkar ej

Rekommendera Poster

FiEnD

Hej

 

Har provat lägga upp en ASP 2.x - site i windows 2003-burken, men inte fått det att fungera. Den klagar och skriver ut "Server Application Unavailable".

 

Finns det någon steg för steg- guide för hur man lägger upp en ASP 2.x - site korrekt?

Har en del andra siter som ligger uppe som kör både 1.x och 2.x på servern, men dem har sina siter i en virtuell katalog som körs med separata application-pools. T.ex www.domän.se/www eller www.domänen.se/minsite

Dock aldrig www.domänen.se

 

Har sökt på google och försökt hitta hur man ska på ett enkelt sätt lägga upp rättigheter, siter etc men helt fastnat.

 

Någon som kan ge råd, tips eller bra länkar?

 

Tack på förhand.

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mr Andersson

Vet inte om du gjort detta, men högerklicka på din site (eller rättare sagt, den mapp eller virtuella mapp som ska vara rooten för siten), properties, och sen Create under Application settings.

 

Jag förutsätter att du angivit IP-adress oc hostheader korrekt i egenskaperna för siten.

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Hej

 

Jag provade plocka bort den virtuella mappen och lade dit en ny och skapade en ny via "create". Fungerar inte. Samma fel.

 

Japp, det är rätt hostheader mm till siten för jag kommer åt asp-sidorna, men inte aspx. Dem skriver den ut felet på.

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mr Andersson

Låter som ett ISAPI-fel.

 

Kolla under configuration för siten så att det är rätt sökväg till DLL-filen för aspx. I mitt fall är det

 

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Hej

 

Sökvägen till filen stämnde så som du skrev. Den finns där också på denna server. Men vart hittar jag configurationen för siten?

Antar det inte är under ISAPI-filter?

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mr Andersson

Högerklicka på Siten (inte någon undermapp), properties, välj fliken Home directory, klicka på Configuration och kolla så att alla asp.net-saker i listan pekar på samma (rätt) aspnet_isapi.dll

 

Edit: ISAPI-filter och "ISAPI-program" är inte samma sak och används till helt olika saker.

 

Eventuellt kan det vara din application pool som inte är som den ska, tex har det konto du angett där, rätt att läsa aspnet_isapi.dll och har det rätt att läsa dina aspx-filer?

 

 

 

 

[inlägget ändrat 2007-02-02 11:15:15 av Mr Andersson]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Det är rätt aspnet_isapi.dll som den pekar mot japp

c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll

 

Ang kontot, är det kontot som jag anger under directory security som du syftar på?

Den skall ha åtkomst att läsa:

c:\windows\microsoft.net\framework\v2.0.50727?

 

aspx-filerna har den rättigheter både läsa och skriva etc. Allt under den katalogen som siten pekar mot.

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mr Andersson

Eftersom du har .net 2.0 siter som snurrar, så hade jag gått igenom samtliga inställningar och jämfört dem med de som du ha för din site. Något måste skilja, annars hade det fungerat :)

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Har du tittat i applikationsloggen på det klockslag du fick felmeddelandet? Det skulle hjälpa att få lite mer detaljer än "Server Application Unavailable".

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

"Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied. "

 

och

 

"Failed to initialize the AppDomain:/LM/W3SVC/1890798095/Root

 

Exception: System.IO.FileLoadException

Message: Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.

StackTrace: at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)

at System.Activator.CreateInstance(String assemblyName, String typeName)

at System.AppDomain.CreateInstance(String assemblyName, String typeName)

at System.AppDomain.CreateInstance(String assemblyName, String typeName)

at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

 

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Jag har lagt upp siterna precis som jag gjort tidigare, men tydligen har jag missat något. För annars hade det nog fungerat som det skulle.

Problemet också är att om jag har en site som ligger i katalogen

\xxxDit även domänen pekar, så skapar jag en virtuell katalog till den siten så blir adressen t.ex

www.doman.se/virtuellkatalog

 

Det jag försöker styra upp nu är så att man kan lägga aspx-filer i roten och komma åt dem via www.doman.se

:/

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Har du prövat att även ge IUSR_xxx and IWAM_xxx läs och kör-rättigheter på mappen?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

"på mappen", är det mappen där filerna ligger? Eller är det den virtuella mappen, eller mappen där dll-filen ligger? :)

 

Bör nämnas att siten körs inte med IUSR_xxx användaren utan med en egen användare som är skapad för att köra just denna site.

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Mappen där sajtfilerna fysiskt ligger. Har du i övrigt gjort något med IIS sedan du installerade Net Framwork? (ex. patchat eller ominstallerat). Isåfall kan du registrera om med aspnet_regiis.exe -u och därefter aspnet_regiis.exe -i. (alternativt köra en aspnet_regiis.exe -r)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Kan lägga till rättigheter för de två användarna till mappen och dess underobjekt nu få se om det skiljer sig något.

 

Vi har installerat de vanliga patcharna till 2003 som har kommit ut via windows update. Även servicepack .

 

Provar med aspnet_regiis.exe -r

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Fast något sådant kommando hittades inte. Den bad mig kontrollera om jag stavat det rätt. Säker på stavningen på aspnet_regiis.exe -r ?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon
Säker på stavningen på aspnet_regiis.exe -r ?

Japp, men se till att första gå in i mappen där de ligger (ligger i respektive frameworks mapp så gör först en CD C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 )

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Nu är det kört och den har installerat om sig.

Fortfarande samma problem :/

 

"Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied. "

 

Mm..

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
FiEnD

Nu är problemet löst. Det var "network service" som var tvungen att ha rättighet också på mappen för filerna.

 

Mvh Fredrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...