Just nu i M3-nätverket
Jump to content

Vista och router


NOSiR

Recommended Posts

Varför klarar inte Vista av att identifiera min D-Link 604 router? När jag startar Vista, så visar nätverksikonen ett utropstecken, som betyder begränsat nätverk. Eftersom routern är kopplad till ett ADSL-modem, så kommer jag inte ut på nätet. Felsökningsguiden påstår att felet beror på routern och att jag ska koppla ur och in routern under identifieringen. Detta funkar ungefär var 20:e gång. Jag har även försökt att att koppla ur och i modemet.

 

Dels är detta lite knöligt för att starta Internet på, dels är det väl svagt av Microsoft att något som funkat i alla tidigare OS inte funkar med det nyaste.

 

Modemet är uppgraderat med senaste firmware, och efter sökning på nätet verkar det som problemet finns med andra routrar också.

 

Har någon haft samma problem och hittat en lösning?

 

[inlägget ändrat 2007-01-13 11:48:06 av NOSiR]

[bild bifogad 2007-01-13 15:55:04 av NOSiR]

907890_thumb.jpg

Link to comment
Share on other sites

Jag har installerat de senaste drivrutinerna från Asrock. Jag har även kollat drivrutiner hos chipset-tillverkaren ULi, men där finns inga drivrutiner framtagna speciellt för Vista. Och eftersom Asrock påstår att deras MB är "Vista ready". så funderar man vad dom menar med det.

 

Visst kan problemet finnas i nätverkskortet (onboard), men eftersom Vista inte kan identifiera routern, så antar jag att anslutningen till routern är OK.

 

Link to comment
Share on other sites

Jag förstår inte varför operativsystemet ska identifiera en router, det behöver hitta en utrustning i andra änden av nätverkskabeln som kan ge det en IP-adress, någon annan sorts identifiering behövs ju inte.

Ta fram Kommandotolken (jag antar att det finns något sådant även i Vista, kanske något Kör - cmd ?) och skriv:

ipconfig /all

dels när datorn har kontakt med routern och dels när den inte har det. Klistra in resultaten här.

 

Link to comment
Share on other sites

Så här ser IP-config ut före uppkoppling:

 

 

 

Windows IP Configuration

 

Host Name . . . . . . . . . . . . : Sverker-PC

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

 

Ethernet adapter Bluetooth Network Connection:

 

Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)

Physical Address. . . . . . . . . : 00-10-60-D1-06-45

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

 

Ethernet adapter Local Area Connection:

 

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : ULi M526X Ethernet Controller

Physical Address. . . . . . . . . : 00-13-8F-C9-F3-4A

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Link-local IPv6 Address . . . . . : fe80::5918:a84a:3dee:7650%8(Preferred)

Autoconfiguration IPv4 Address. . : 169.254.118.80(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

DHCPv6 IAID . . . . . . . . . . . : 201331599

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

fec0:0:0:ffff::2%1

fec0:0:0:ffff::3%1

NetBIOS over Tcpip. . . . . . . . : Enabled

 

Tunnel adapter Local Area Connection* 6:

 

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : isatap.{BC60F344-0117-4D2C-987E-C1C0A467E

309}

Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

Link-local IPv6 Address . . . . . : fe80::5efe:169.254.118.80%12(Preferred)

Default Gateway . . . . . . . . . :

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

fec0:0:0:ffff::2%1

fec0:0:0:ffff::3%1

NetBIOS over Tcpip. . . . . . . . : Disabled

 

Tunnel adapter Local Area Connection* 7:

 

Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : isatap.{169767BD-E61D-4592-8CF3-E655E1C53

CB3}

Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

 

Eftersom det nu är stört omöjligt att koppla upp, så har jag förstås ingen info om hur det ser ut efter inkoppling. Men jag bifogar ett par skärmdumpar av hur det ser ut under "reparationen" i Vista. Jag har provat alla alternativen.

 

[bild bifogad 2007-01-13 15:53:45 av NOSiR]

[bild bifogad 2007-01-13 15:58:07 av NOSiR]

907982_thumb.jpg

Link to comment
Share on other sites

Oj IPv6, det har jag inte mycket kunskaper om.

 

Datorn har i alla fall inte kunnat komma i kontakt med routern för att få en IP-adress. Hur gör du när du skriver här? Har kabeln mellan datorn och routern varit med i en fungerande uppkoppling?

 

Har du följt det här standardknepet vid nätverksproblem:

Slagit av strömmen på dator, router och modem.

Slagit på strömmen på modemet.

Väntat tills modemet är klart, dvs några minuter.

Slagit på routern och väntat tills den är klar.

Slagit på datorn.

 

Link to comment
Share on other sites

Jag skulle börja med att stänga av IPv6 adressering i Vista. Jag misstänker att det "linkningen" mellan IPv6 och IPv4 som gör att det ser väldigt konstigt ut i din IP konfiguration. Om det inte funkar med att bara stänga av (avinstallera) IPv6 så tycker jag att du skall avinstallera allt som har med nätverket att göra (inkl nätverkskortet) och sedan ominstallera.

 

-nisse

Beauty is in the eye of the beer holder

 

Link to comment
Share on other sites

  • 4 weeks later...

Hej!Hallå det verkar som Vista har svårt att komma ihåg adresserna mellan router och nätverkskort när man startar om datorn jag kom runt problemet med att lägga in fasta ip och dns adresser i stället för att låta Vista hitta det automatiskt men var noga med att tala om för datorn vilket nummer den har te.x Dator 1 192.168.1.2 Dator 2 192.168.1.3 o.s.v titta på bifogad bild.

Pillenisse

 

[bild bifogad 2007-02-08 16:09:26 av Surferx]

916933_thumb.jpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...