Just nu i M3-nätverket
Jump to content

Count if


worship

Recommended Posts

Mitt problem:

 

Har två flikar i excel

 

Flik "Kalkylark", 3 kolumner:

 

Kalle 1 2

Kalle 3 1

Kalle 2 1

Olle 1 2

Olle 3 2

 

Flik "Uträkning" summering, 4 kolumner:

 

Namn Antal 1 Antal 2 Antal

 

Det jag vill beräkna är alltså hur många ettor, tvåor och treor har Kalle i kolumn b och c i fliken "Kalkylark" totalt.

 

Gjort en lösning som ser ut så här:

 

=COUNTIF(Kalkylark!B1:C400; 1)

 

På så sätt får jag ut antalet ettor ur kolumn b och c.

Men jag vill dessutom ha kriteriet att det ska stå "kalle" i kolumn A.

 

Det har jag ännu inte lyckats med....

 

Idéer någon? =)

 

 

Link to comment
Share on other sites

Lite småstruligt med siffror i 2 kolumner Du blir nog tvungen att räkna varje kolumn för sig och addera, Exempel för att räkna antal 1:or

=PRODUKTSUMMA((Kalkylark!A1:A400="kalle")*(Kalkylark!B1:B400=1))+PRODUKTSUMMA((Kalkylark!A1:A400="kalle")*(Kalkylark!C1:C400=1))

 

svenska PRODUKTSUMMA = engelska SUMPRODUCT

 

Alternativ: Kalle i A och En 1:a i B ELLER C

=SUMPRODUCT((Kalkylark!A1:A400="kalle")*((Kalkylark!B1:B400=1)+(Kalkylark!C1:C400=1)>0))

 

En ännu smidigare lösning är att sätta rubriker på dina kolumner och använda Pivotabell. Men då är du tvungen att göra två tabeller, en för kolumn B och en för kolumn C.

 

Hjärnsläpp. Ändrade en liten detalj...

[inlägget ändrat 2007-01-12 16:29:18 av MH2]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...