Just nu i M3-nätverket
Jump to content

phpMyAdmin


Ankungen

Recommended Posts

Jag har en egen server på min dator med eget domän och har skapat några användare under htdocs/users/, bl a "ankungen". Jag har installerat phpMyAdmin under htdocs/. Allt fungerar som det ska, men jag kan inte komma åt phpMyAdmin. Enligt en beskrivning skulle jag skriva in ett alias i httpd.conf:

 

Alias /phpMyAdmin/ "C:/Program/Apache2/htdocs/phpMyAdmin/"
<Directory "C:/Program/Apache2/htdocs/phpMyAdmin">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

 

Hur ska jag göra?

 

Mvh

Susanne

 

Link to comment
Share on other sites

Gör det enklare!

Om du vill ha fler användare logga in på "root" användaren t.ex. och sedan finns det flikar i phpMyAdmin som är just användarkonton.

Där kan man lägga till ta bort ange rättigheter o.s.v.

Testa det!:thumbsup:

 

 

Lycka Till!

 

//MvH Walle

 

Link to comment
Share on other sites

Problemet är att jag inte får upp phpMyAdmin-sidan överhuvudtaget sedan jag skapade mina användare i apache.

 

Link to comment
Share on other sites

Domän: doman.se

Användare 1: ankungen

Användare 2: tbear

Så här har jag skrivit i httpd.conf:

 


Alias /phpMyAdmin/ "C:/Program/Apache2/htdocs/phpMyAdmin/"
<Directory "C:/Program/Apache2/htdocs/phpMyAdmin">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /doman/ "C:/Program/Apache2/htdocs/doman/"
<Directory "C:/Program/Apache2/htdocs/doman">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /ankungen/ "C:/Program/Apache2/htdocs/users/ankungen/"
<Directory "C:/Program/Apache2/htdocs/users/ankungen">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /tbear/ "C:/Program/Apache2/htdocs/users/tbear/"
<Directory "C:/Program/Apache2/htdocs/users/tbear">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>


<VirtualHost *>
ServerName doman.se
ServerAlias www.doman.se
ServerAdmin info@doman.se
DocumentRoot "c:/program/apache2/htdocs/doman"
ErrorLog "logs/localhost-error_log" 
CustomLog logs/localhost-access_log combined
UseCanonicalName off
AddHandler server-parsed .shtml
Options FollowSymLinks +Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
<IfModule mod_ssl.c>
Include conf/ssl.conf
</IfModule>
</VirtualHost>


<VirtualHost *>
ServerName ankungen.doman.se
ServerAlias ankungen.doman.se
ServerAdmin info@doman.se
DocumentRoot "c:/program/apache2/htdocs/users/ankungen"
ErrorLog "logs/localhost-error_log" 
CustomLog logs/localhost-access_log combined
UseCanonicalName off
AddHandler server-parsed .shtml
Options FollowSymLinks +Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
<IfModule mod_ssl.c>
Include conf/ssl.conf
</IfModule>
</VirtualHost>

<VirtualHost *>
ServerName tbear.doman.se
ServerAlias tbear.doman.se
ServerAdmin info@doman.se
DocumentRoot "c:/program/apache2/htdocs/users/tbear"
ErrorLog "logs/localhost-error_log" 
CustomLog logs/localhost-access_log combined
UseCanonicalName off
AddHandler server-parsed .shtml
Options FollowSymLinks +Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
<IfModule mod_ssl.c>
Include conf/ssl.conf
</IfModule>
</VirtualHost>

 

Link to comment
Share on other sites

Jag ändrade inget på mitt.

Jag kör med localhost och det fungerar perfekt!

Då har jag inte ändrat nått sånt där så har jag 2 användare som jag skapade via användaren "root"

 

Lycka Till!

 

//MvH Walle

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...