Just nu i M3-nätverket
Gå till innehåll
Glennta

Länksvårigheter.

Rekommendera Poster

Hej,

 

Jag har ett dokument med två blad.

 

Blad 1 är informationssidan, där alla uppgifter samlas.

 

Blad 2 är blad där informationen hämtas.

I blad två har jag gjort en länk i en cell (cell 24) till ett externt dokument (fil).

 

jag använder följande formel i blad 1 för att hämta informationen i cellen som jag refererar till ovan:

=OM(A4="";"";LETARAD(A4;ARC!$A1:$X$50017;24;0))

 

Vad jag undrar är? Kan ovanstånde formel hämta även länken?

För så som det är nu tar formeln bara med texten i cellen och inte länken.

 

mvh

 

Glenn

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

=OM(A4="";"";HYPERLÄNK(LETARAD(A4;ARC!$A1:$X$50017;24;0)))

 

Borde fixa det åt dig om texten är lika med länken. Om du har ett "vänligt" namn på länken räcker ej det ovan.

 

[Edit:] Om du har ett "vänligt" namn på länken rekommenderar jag dig att ta bort det. Kanske placera det vänliga namnet i angränsande cell eller liknande om det måste finnas. Annars är det krångligt att få fram adressen.

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2006-12-29 10:21:08 av Monshi]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

nja,

 

Så här ser det ut:

 

texten i cellen är Tekniks Info.

Den skall i sin tur hämta ett pdf dokument i en mapp.

 

Länk under.

Chesterton/ARC/Teknisk info/arc890.pdf

 

Hur gör jag då?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det är inte du som skapar arket/sidan du ska hämta länken ifrån? Som sagt är min rekommendation att inte ha det "vänliga" namnet i den cell där du vill hämta länken ifrån.

 

Annars måste vi ta till VBA för att skapa en liten funktion som extraherar adressen ur cellen:

Public Function GetLink(linkCell As Range) As String
   If linkCell.Hyperlinks.Count > 0 Then
       GetLink = linkCell.Hyperlinks.Item(1).Address
   Else
       Err.Raise Number:=2
   End If
End Function

För att nyttja denna måste du ha en referens till cellen, LETARAD duger inte.

 

Skriver om din funktion till:

=OM(A4="";"";getLink(FÖRSKJUTNING(ARC!$A$1;PASSA(A4;ARC!$A1:$X$50017;0)-1;23)))

eller något liknande, osäker på om antalet paranteser är korrekt.

 

Kopiera koden in i en modul i VBA editorn.

 

Som synes - väldigt mycket mer komplicerat än om ingen "vänlig" text finns i cellen du hämtar länken ifrån.

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vänligt namn - den text som visas istället för länken. Kom inte på något bättre uttryck.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...