Just nu i M3-nätverket
Jump to content

Eclipse hittar inte main


rawd

Recommended Posts

Hej!

 

Sitter o färskar upp minnet på gamla kunskaper och testar samtidigt Eclipse. Följde dess enkla introduktion där man avslutar med att skapa HelloWorld.java. Får dock detta felmeddelande:

[log]

java.lang.UnsupportedClassVersionError: HelloWorld (Unsupported major.minor version 49.0)

at java.lang.ClassLoader.defineClass0(Native Method)

at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)

at java.net.URLClassLoader.access$100(URLClassLoader.java:55)

at java.net.URLClassLoader$1.run(URLClassLoader.java:194)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:187)

at java.lang.ClassLoader.loadClass(ClassLoader.java:289)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)

at java.lang.ClassLoader.loadClass(ClassLoader.java:235)

at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

Exception in thread "main" [/log]

i konsolen.

 

Såhär ser koden ut:

 

/**
* 
*/

/**
* @author rawd
*
*/
public class HelloWorld {

/**
 * @param args
 */
public static void main(String[] args) {
	// TODO Automatiskt genererat metodstycke
	System.out.println("Hello world!");

}

}

 

Jag har också sett till att lägga till denna miljövariabel:

PATH = C:\Program\Java SDK 1.4.2\j2sdk1.4.2_12\bin

 

Borde jag ta med en CLASSPATH, eller är det inte så att Eclipse ska klara det själv om man skapat ett eget nytt projekt i en arbetsyta?

 

Link to comment
Share on other sites

Det kan mycket väl stämma. Jag vill egentligen skriva koden för 1.4.2 men har även installerat 1.5 för de hemsidor som anropar Java.

 

Var kan jag i Eclipse i såna fall ändra så att den kompilerar med rätt komplilator?

 

Link to comment
Share on other sites

Eclipse själv har en default-inställning som du når under Window - Preferences - Java - Compiler. Om du vill ställa in något annat än default för ett enstaka projekt så kan du göra det genom att välja Project - Preferences - Java Compiler och kryssa i "Enable project specific settings".

 

 

Link to comment
Share on other sites

Jag hittade faktiskt det igår, men hann inte skriva ett inlägg innan jag gick från datorn. Det man också kan göra är att via samma väg, Fönster > Inställningar > Java > Installerade JRE > Körningsmiljöer se vilka JRE som finns, välja vilka JRE som ska användas o vilket av dem som är default. Tack för hjälpen ändå! :thumbsup:

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...