Just nu i M3-nätverket
Jump to content

Ändra cellers placering på exelblad?


Katitzi

Recommended Posts

Hej!

Jag har ett STORT! exelark fyllt med nogsamt ihopsparad fakta.

Nu är det snart presentationsdax. Jag skulle vilja flytta infon såhär;

Idag ser det ut såhär

 

A B C D E

 

1 A1 B1 C1 D1 E1

 

2 A2 B2 C2 D2 E2

 

...osv ...

 

 

 

Nu skulle jag vilja att det såg ut såhär (på ett nytt blad);

 

A1

B1 D1

 

A2

B2 D2

 

 

A3

B3 D3

 

.... ja, ni förstår kanske...

 

Eftersom det är ett stort material hoppas jag på att det går att automatisera detta på något vis?!

 

hoppas på svar /K

 

Link to comment
Share on other sites

Utgår från att dina tabell, dina celler börjar i A1 likt i exemplet. Säg att dina värden befinner sig på blad1.

 

På ett nytt blad infogar du då formeln:

=FÖRSKJUTNING(Blad1!$A$1;(RAD()-RAD($A$1))/3;0)

i cell A1

i cell A2 infogar du formeln:

=LETARAD($A1;Blad1!$A:$D;KOLUMN()-KOLUMN($A$2)+2)

Anpassa $A:$D så att hela ditt område med celler på blad1 ryms, asch, vi kan skriva:

=LETARAD($A1;Blad1!$A:$IV;KOLUMN()-KOLUMN($A$2)+2)

för att vara på säkra sidan. Anpassa ivartfall bladnamnet.

Kopiera ut denna på rad två så många kolumner som du har värden att hämta, dvs B1 C1 D1 osv.

 

Det ser sedan ut som om du vill ha en rads mellanrum mellan alla poster, därav i formel ett utrycket

RAD()-RAD($A$1))/3

Tag nu och markera rad 1 till 3 och kopiera, dra ned, dessa så långt så att alla dina poster följer med.

 

Sista sak att göra är att göra dina data oberoende av dina gamla, dvs ta bort formlerna.

Markera allt det du nu skapat, kopiera och klistra in special, enbart värden, där du vill ha dina nya uppställning.

 

Klart.

Visst är det elegant?

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Hej och tack!

Den första formlen fungerar fint! Men den andra ...

jag har skrivit om den så att det passar i mitt blad - då tror jag att det blir såhär;

=LETARAD($B8;Blad2!$AH$4;KOLUMN()-KOLUMN($B$8)+2)

B8 är den nya raden som jag skriver in allt på, AH4 är den översta raden i kolumnen där jag vill hämta min fakta. Vad gör jag för fel?

Monshi, du skriver "Anpassa $A:$D så att hela ditt område med celler på blad1 ryms" Jag förstår inte?

mvh K

 

Link to comment
Share on other sites

Din formel ser inte riktigt rätt ut...

 

=LETARAD($B8;Blad2!$AH$4;KOLUMN()-KOLUMN($B$8)+2

B8 - ska var cellen som formel ett finns i (ser rätt ut)

Blad2!$AH$4 - ska vara hela området med värden på, skriv om det som Blad2!A:IV så tas alla kolumner med. Som mitt alternativ 2 i förra inlägget.

KOLUMN()-KOLUMN($B$8)+2 - ser nog rätt ut, ska ge det kolumnummer värdet ska hämtas ifrån. (relativt kolumn A)

 

Med ett tillägg, en miss, blir formeln

=LETARAD($B8;Blad2!A:IV;KOLUMN()-KOLUMN($B$8)+2;FALSKT)

bör stå i cell B9 om jag har greppat ditt tänka upplägg korrekt.

 

Där FALSKT innebär att LETARAD söker efter en exakt träff i kolumn A på blad2.

 

Blir det rätt nu?

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Hej!

Nu testade jag att göra förskjutningsformeln på alla tre värden som jag ville visa och det blev jättebra! Tack så mycket för all hjälp! Du har besparat mig jag vet inte hur många timmars arbete!

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...