Just nu i M3-nätverket
Jump to content

Sökning och jämförelser


Miljarder

Recommended Posts

Tjena,

 

Kan man söka igenom en kolumn och jämföra om den existerar i excel?

 

=IF(A1=EX;GX-C1;”NY!”)

 

Alltså, ta första posten i A1, sök igenom raden E om samma nummer existerar och finns den så ska den ta samma denna radens G-värde minus C1 annars så ska den skriva NY!.

 

Är detta möjligt?

 

Tack för hjälpen och ha det bra!

 

//Tomas

 

Link to comment
Share on other sites

En två-stegs-raket är nog bäst i detta fall fast man kan utan problem skriva ihop det i en cell.

 

Steg 1:

säg att du skiver detta i cell D1

=PASSA(A1;E:E;1)

den returnerar då radnumret inom vektorn (E:E) eller felvärdet #saknas

 

Steg 2:

i annan cell, där värdet ska presenteras:

=OM(ÄRFEL(D1);"Ny";INDEX(G:G;D1;1))

 

Det går som sagt att skriva ihop det i en rad:

=OM(ÄRFEL(PASSA(...);"Ny";INDEX(G:G:PASSA(...);1))

 

Det går att lösa via OM-sats enbart men det blir onödigt komplicerat.

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...