Just nu i M3-nätverket
Jump to content

villkorsstyrd omfuntion i flera led


lbj

Recommended Posts

Jag har inte använt formler i excel tidigare men sitter nu och klurar på att det kan man ju göra i sitt dagliga värv. jag har skrivit en formel som ser ut på följande vis:

 

=OM(F20<1,8);

150*F21;

OM(F20>=1,8OCH<2,3);

160*F21;

OM (F20>=2,3OCH<2,6);

170*F21;

"offert"

 

Som ni kan se är detta bara en formel som jag skrivit för att visa mitt logiska resonemang men den fungerar ju inte i praktiken. Är det någon som kan hjälpa mig att få den anpassad till excel?

 

Hälsar Lena från Åre

 

Link to comment
Share on other sites

Hej ,

 

Översatt rakt av:

=OM(A1<1,8;1*B1;
OM(OCH(A1>=1,8;A1<2,3);2*B1;
OM(OCH(A1>=3;A1<2,6);3*B1;
"offert")))

Gäller bara att hålla rätt på parenteserna.

 

Eftersom det rör sig om sammanhängande intervall kan dock formeln göras lite mer kompakt:

=OM(A1<1,8;1*B1;
OM(A1<2,3;2*B1;
OM(A1<2,6;3*B1;
"offert")))

 

Det finns också en begränsning på antalet nästlade OM-satser (tror att det är max 7 nivåer).

 

mvh

/Johan

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...