Just nu i M3-nätverket
Jump to content

Excel Problem


perrr

Recommended Posts

Hej !

 

Jag har ett lite problem med Excel.

Är inte så vass på Excel så jag skulle va tacksam om någon kunde hjälpa mig.

 

Jag hoppas bilden kommer med i inlägget!

 

Som ni ser så får jag ett ganska kraftigt minus i min uträkning på F10.

På grund av att ruta C10 är blank. Så det jag skulle vilja lösa är att när C10 är blank så ska formeln inte räknas.

 

Tacksam för hjälp!!

 

[bild bifogad 2006-03-31 20:42:42 av perrr]

819377_thumb.jpg

Link to comment
Share on other sites

=om(ärtom(c10);"";dinberäkning)

 

eller

=om(c1="";"";dinberäkning)

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Tack för svaret!

 

Men jag är som sagt inte vass på Excel :(

 

Så kan du skriva lite mer enkelt så kanske jag förstår hur det ska va.

Eller så prova skriva formel rätt på en gång så jag kan bara klistra in den.

Då kanske jag förstår hur man ska göra.

 

Tacksam för svar :thumbsup::thumbsup:

 

Link to comment
Share on other sites

=OM(villkor;SANT;FALSKT)

är grundformen för OM-satsen. Om villkoret värderas till SANT returneras SANT, annars FALSKT.

 

Så ÄrTom(C10) returnerar SANT om C10 är just tom

Ibland kan det vara enklare med kontrollen C10="" som i princip är samma sak som ÄrTom()

 

=OM(ÄrTom(C10);"";(C10-C9)*D10)

klistrar du in i cell F10.

Denna kan du sedan kopiera upp/ned fast i första cellen, F4, fungerar den inte (C3 är ej ett tal).

 

Ta även en titt i Excel utmärkta hjälp samt besök XLDennis eminenta sidor:

http://www.xldennis.se

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Nya problem, kolla in bilden.

 

Hur löser jag problemet i F13.

 

Det blir ju fel om det inte står något i rad B eller C raden

 

Vad ska det stå för formel där?

 

Tacksam för hjälp

 

[bild bifogad 2006-04-09 07:56:11 av perrr]

822101_thumb.jpg

Link to comment
Share on other sites

Andra OM-satsen i formeln kan i den nuvarande uppställningen returena antingen en "tom" text ("") eller ett beräknat värde. Om text returneras blir det ett felvärde som resultat då text och värden inte kan adderas. Jag tror att ett byte, i andar OM-satsen, av "" till 0 löser ditt problem.

 

/T

Åter efter en god vecka i pisterna i Bad Gastein.

 

Link to comment
Share on other sites

En annan följdfråga är:

Vad vill du ha i F11?

Om du vill att den skall vara tom om B11 och/eller C11 är tom så bör formeln vara =OM(ELLER(ÄRTOM(B11);ÄRTOM(C11));"";(C11+B11-C10-B10)*D11).

 

/Pär B

 

Link to comment
Share on other sites

Super bra!! :)

 

Otroligt va hjälpsamma människor det finns på det här forumet!!

 

Tusen tack!!

 

För slaget som Monshi gav mig blev det som jag använde men tack ändå PerboMan :thumbsup::thumbsup:

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...