Just nu i M3-nätverket
Jump to content

USB-enheter syns ej i utforskaren


Magnifyer

Recommended Posts

Ansluter mina USB-minnen till datorn men utforskaren hittar inte dom (ens efter flera minuters väntan och uppdatering av visningen). När jag ska göra "säker borttagning" via ikonen i aktivitetsfältet visas dom med enhetsbokstav och allt. Kan även öppna enheterna via "logical Disk manager" för där visas dom.

Vad har hänt? Har aldrig råkat ut för detta innan!

 

Tack på förhand alla hjälpsamma

 

 

Link to comment
Share on other sites

Kan vara en konflikt av enhetsbokstäver.

 

En vanligt usbminne som du använder och stoppar in i ett usb-uttag, använder nästan alltid som standard bokstaven H.

 

Om du har en annan enhet som också använder H kan det bli så att ditt usb-minne inte syns som en egen enhet .

 

Byt bokstav på någon enhet, så kommer du troligen att kunna se ditt usb-minne som en egen enhet igen.

 

 

 

 

 

 

// Gästen

 

Sopa alltid rent framför egen dörr

 

[inlägget ändrat 2006-03-31 22:35:45 av //gästen]

Link to comment
Share on other sites

Tyvärr funkar inte det heller. :-(

 

Min USB-hårddisk funkar som den ska och heter (J:) Jag har HDD och partitioner från A-H och DVD-brännaren är (I:)

 

När jag så ansluter min "USB-Pine" borde den bli (K:) men blir inte det i utforskaren. Heter det i "Logical Disk Manager"

 

Provade att byta enhetsbeteckning på den där men der hjälpte inte.

 

Link to comment
Share on other sites

Magnifyer skrev:

 

Jag har HDD och partitioner från A-H och DVD-brännaren är (I:)

 

Har du verkligen partionerat din hårddisk i 8 partioner varav två av dem är A & B (egendomligt)?

 

Jag har ett vagt minne av ett USB-minne som jag hade för några år sedan som bara kunde få enhetsbokstäverna A eller B, kan det vara problemet i ditt fall?

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

Jag har 4 hdd i datorn (1,2Tb). A är som vanligt 1,44" diskett och B används inte

C: är system partitionen.

 

Det konstiga, och vanliga, är att det har fungerat tills problemfritt tills igår.

Då har USB-pinnen fått beteckningen (J:)

 

Link to comment
Share on other sites

Jag har 4 hdd i datorn (1,2Tb). A är som vanligt 1,44" diskett och B används inte

C: är system partitionen.

 

Jag missförstod dig, trodde att du hade en hårddisk med 8 partioner. Har du provat minnet i någon annan dator?

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

Har samma problem som du.

Jar har också till o med J i maskin och USB ska bli K, men det dyker inte upp.

Har 2 olika minnen och de funkar på annan dator.

Jag har 2 HDD och jag har testat att boota från den andra som var är min gamla. Och se då går det. Jag tror att problemet ligger i XP, kanske i Registret. Jag kör ju olika XP på de båda HDD.

Jag har en Maxtor extern disk med USB och den är det inga problem med och den får K.

Nästa sak jag konstaterat. Gick in Kontrollpanel, prestanda o underhåll, adm verktyg, datorhant, diskhantering.

Där är USBminnet synligt, där kan jag sätta bokstav på den och också se vad det innehåller.

Men i utforskaren syns inget.

Hur lösa?

 

Link to comment
Share on other sites

Min externa HDD syns också som den ska. Det är för övrigt också en maxtor.

Vi har alltså samma problem. Nu återstår det bara att någon hjälpsam expert har ett bra svar på det också.

Peppar, peppar! Alla problem som jag har haft uppe härhar någon snäll person alltid kunnat lösa åt mig. Jag är förhoppningsfull.

 

Link to comment
Share on other sites

Har inte hunnit prova då jag är på jobbet ännu.

Om jag ser dom där vad gör det för skillnad? Kan jag göra något med Tweak UI för att visa dom i utforskaren?

 

Link to comment
Share on other sites

Var ska man se USB-minnet?

 

Under diskenheter.

 

Jag tycker att du skall ta dig en ordentlig titt i enhetshanteraren genom att visa dolda och frånkopplade enhter. För säkerhets skull sätt först en systemåterställningspunkt.

 

Från "Start" > "Kör" skriv cmd. I kommandofönstret skriver du:

set DEVMGR_SHOW_DETAILS=1 (Retur)

set DEVMGR_SHOW_NONPRESENT_DEVICES=1 (Retur)

start devmgmt.msc (Retur)

Från "Visa" menyn väljer du "Visa dolda enheter".

 

Titta först under "Disk drives", finns det spår av USB-pinnen? Plocka bort allt som inte har med dina hårddiskar att göra.

 

Blädra ned till "Universal Serial Bus controllers" och ta bort alla (har du USB tangentbord och mus så tappar du kontakten men det är ingen fara det funkar efter en omstart). Starta om datorn och låt den hitta dina USB-portar på nytt. När den är klar med det så stoppar du i minnespinnen.

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

TweakUI. Menar du under My comp/drives? Där syns bara vilka bokstäver som är använda, inte vad som finns där. Och jag kan se att USB-m inte finns med eftersom K inte är upptagen.

 

I enhetshanteraren syns USB-minnet som "USB-masslagringsenhet"

 

Innan jag gör ngt dumt behöver jag en förklaring.

Hur sätter man en systemåterställningspunkt?

 

Vad är det man gör med kommandona under CMD?

 

Ja jag har Logitech trådlösa TB o mus som är USB-anslutna.

 

Som sagt var, jag kan en del om PC men är ingen stjärna så därför skulle jag vilja att du är lite mer tydlig i det du skriver.

 

Dina tips verkar helt klart bra, men jag vill inte göra ngt misstag.

 

H/Anders

 

Link to comment
Share on other sites

Hej Anders

Datakillen är inte här idag så jag kunde inte kolla med honom men hittade en "gammal" tråd.

 

//eforum.idg.se/viewmsg.asp?EntriesId=803748#803777

 

weyland

Om du kikar i datorhanteraren, diskhantering - dyker minnet upp där? Du kanske behöver ge den en enhetsbokstav i diskhanteraren (eng: admin tools->computer management->disk manager) för att få upp den som en enhetsbokstav.... händer vanligtvis om minnet vill använda en bokstav som redan är upptagen av något annat och kan då "fungera" på vissa datorer och inte på andra.

 

//gästen

Har hittat lösningen på detta problem.

Felet bestod i att tydligen använder usb-portarna enbart en specifik enhetsbokstav som standard, i alla fall hos mig.

 

Så när denna standard bokstav var upptagen, så blev det en krock, och felet uppstod.

Så det blev att göra en ändring ungefär som Weyland var inne på.

Att usb-portarna får använda denna bokstav ifred.

 

Får lyfta på mössan Weyland, ditt tips fick rätt hjärncell att vakna till.

 

Milla

 

Den som uppfann arbetet måste inte ha haft någonting att göra.

 

Link to comment
Share on other sites

Innan jag gör ngt dumt behöver jag en förklaring.

Hur sätter man en systemåterställningspunkt?

 

Från "Start" välj "Kör" och skriv %SystemRoot%\System32\restore\rstrui.exe

(Går givetvis att göra från "hjälp" ikonen i startmenyn oxså men det är lättare att beskriva så här)

 

Vad är det man gör med kommandona under CMD?

 

 

set DEVMGR_SHOW_DETAILS=1 (Retur)

Gör att enhetshanteraren (Device Manager) visar mer information.

 

set DEVMGR_SHOW_NONPRESENT_DEVICES=1

Gör att enhetshanteraren även visar information om enheter som varit anslutna men som inte längre är det, de enheterna blir "gråmarkerade".

 

start devmgmt.msc

Startar enhetshanteraren.

 

Det här är garanterat ofarligt, nästa gång som du startar enhetshanteraren så är den precis som vanligt. Eftersom jag själv alltid vill se alla enheter så har jag skapat mig en .bat fil genom att klistra in följande i "Anteckningar" och sparat filen som vadduvill.bat

 

[log]set DEVMGR_SHOW_DETAILS=1

set DEVMGR_SHOW_NONPRESENT_DEVICES=1

start devmgmt.msc[/log]

 

Genom att klicka på filen så startar enhetshanteraren med de inställningar som jag vill ha.

 

 

Orsaken till att jag tyckte att du skulle sätta en systemåterställningspunkt var att om du blir för "klåfingrig" när du avinstallerar så kan det i värsta fall bli problem och det är det bra att ha en systemåterställninspunkt. Det som jag föreslog är så nära ofarligt man kan komma. Vill du vara riktigt säker så kan du välja att bara avinstallera enheter som är gråmarkerade (ej anslutna) men jag är lite osäker på om det räcker i ditt fall.

 

När man väljer att avinstallera en drivrutin till hårdvara så tas inte drivrutinen bort utan det är bara "kopplingen" till drivrutinen i registry som tas bort. Eftersom USB-portar och minnespinnar är "Plug and Play" så hittar XP dem efter omstart och använder den befintliga drivrutinen.

 

Det som du skall akta dig för att plocka bort är t ex "Video Codecs" (ej hårdvara) som inte kommer att hittas automatiskt i de flesta fall.

 

 

Ja jag har Logitech trådlösa TB o mus som är USB-anslutna.

 

Du kommer att tappa kontaken med dem, se till så att du inte har några osparade öppna dokument och tryck på reset knappen på datorn. Efter omstart så funkar de igen. De är naturligtvis tillbaka i enhetshanteran så ta inte bort dem en gång till när du fortsätter med rensningen (inte farligt på något sätt men du kommer aldrig att bli klar med rensningen).

 

Som sagt var, jag kan en del om PC men är ingen stjärna så därför skulle jag vilja att du är lite mer tydlig i det du skriver.

 

Människan i allmänhet är lat och jag i synnerhet:) I år har jag skrivit 912 inlägg på eforum (jag är långt ifrån värst, klicka på "Statistik" i höger kolumnen så ser du att Cecilia har skrivit 2010 vilket blir över 20 om dagen, jag blir trött bara jag tänker på det) vilket gör att jag inte orkar och hinner att skriva romaner varje gång. I synnerhet om frågan varit uppe tidigare på eforum. Men visst förstår jag din synpunkt och hoppas att det här svaret har varit lite mer begripligt.

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

I mitt brev ovan så har jag faktiskt skrivit att jag testat det som Weyland skrev. Så det hjälpte inte.

 

Jag tycker jag har letat igenom alla inlägg på IDG och testat dem som verkar intressanta, utan att det hjälpt.

 

Link to comment
Share on other sites

Hej Magnifyer!

 

Det råkar inte vara så att du har en registerinställning vid namn "NoDrives"

 

(Starta regedit via start kör, markera "den här datorn" högst upp. Tryck F3

samt skriv in: nodrives i sökfältet, tryck enter...

 

Om värdet hittas.

 

Ändra det DECIMALA värdet till 0 (noll) eller enligt lista på:

http://www.winguides.com/registry/display.php/148/

 

Lycka till!

 

 

/Thomas

Ladda ner professionella väl genomtänkta installationsanvisningar som ger hög säkerhet mot virus & angrepp, stabil drift samt optimal prestanda på: http://www.winguider.se Finns för Win2000 Pro & för XP Pro (3 olika versioner) Ej för XP home

 

Link to comment
Share on other sites

[Hej Magnifyer!

 

Det råkar inte vara så att du har en registerinställning vid namn "NoDrives"

 

/Thomas]

 

Hjälpte inte för mig, ingen träff på "nodrives"

 

Link to comment
Share on other sites

Hjälpte inte för mig, ingen träff på "nodrives"

 

Inte ett dugg förvånande för det har man inte om man inte själv har laggt till nyckeln.

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

Jag har en liten "fusklapp" som en notes i Outlook:)

[log]

Eforum

UltimateBoot

http://ftp.sweclockers.com/index.php?action=list&dir=Fels%F6kning/Ultimate%20Boot%20CD&order=name&srt=yes

MemTest

http://www.memtest86.com/

SpyBoot

http://fileforum.betanews.com/detail/Spybot_Search_and_Destroy/1043809773/1

Ad-Aware SE Personal Edition 1.06

http://www.lavasoft.de/

HijackThis v1.99

http://www.merijn.org/files/hijackthis.zip

Everest från 2005 (everesthome220.exe) som du hittar här

ftp://ftp.sweclockers.com/pub/System%F6vervakning/everesthome220.exe

 

http://ftp.sweclockers.com/index.php?action=list&dir=System%F6vervakning&order=name&srt=yes

http://www.lavalys.com/products/overview.php?pid=1&lang=en

Prime95

http://www.mersenne.org/freesoft.htm

 

Drive Cleaner

http://www.drivercleaner.net/

 

Grafikkort är bra att testa med 3Dmark

http://www.futuremark.com/download/?3dmark03.shtml

 

Dåliga kondingar

http://www.badcaps.net/

_________________________________________________________________________________________

 

Bli ägare

http://support.microsoft.com/default.aspx?scid=kb;sv;308421

Pagefile storlek

http://support.microsoft.com/kb/314482/

Fildelning i XP

http://support.microsoft.com/default.aspx?scid=kb;sv;304040

Installera om XP över befintlig

http://support.microsoft.com/default.aspx?scid=kb;en-us;315341

CD-ROM- eller DVD-ROM-enhet saknas efter installation av Windows XP

http://support.microsoft.com/default.aspx?scid=kb;sv;320553

Telejack (olika typer)

http://tekniken.se/dsl/doc/tele22se.html

 

Systemåterställning från "promt" (F8)

Tryck F8 innan XP startar och välj "Felsäkertläge med kommandotolk" och skriv in %SystemRoot%\System32\restore\rstrui.exe följ instruktionerna (självklart så väljer du att "backa" till en tidpunkt då datorn fungerade).

 

Från "Start" välj "Kör" och skriv %SystemRoot%\System32\restore\rstrui.exe

(Går givetvis att göra från "hjälp" ikonen i startmenyn oxså men det är lättare att beskriva så här)

 

Ta bort USB / dolda enheter.

Från "Start" > "Kör" skriv cmd. I kommandofönstret skriver du:

set DEVMGR_SHOW_DETAILS=1 (Retur)

set DEVMGR_SHOW_NONPRESENT_DEVICES=1 (Retur)

start devmgmt.msc (Retur)

Från "Visa" menyn väljer du "Visa dolda enheter".

Bläddra ned till "Universal Serial Bus controllers". Avinstallera samtliga, ta ur ditt USB nätverkskort och starta om datorn. Låt datorn hitta dina USB-portar, när den är klar med det så sätter du i nätverkskortet.

 

Standardåtgärd vid icke startande dator

1) Dra ut sladdden till datorn.

2) Ta loss alla minnesmoduler och sättt tillbaka dem.

3) Ta loss alla kablar och sätt tillbaka dem igen.

4) Ta loss alla PCI-kort och grafikkortet, sätt tillbaka dem igen.

5) Ta loss batteriet, vänta några minuter och sätt tillbaka det igen. (eller gör en reset enligt instruktionen till moderkortet/daton).[/log]

 

Så där ja, nu behöver jag inte skriva några fler inlägg

 

:)

 

-nisse

Ambivalent?

Well, yes and no.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...