Just nu i M3-nätverket
Jump to content

XFree86 4.0 problem...


Christer8

Recommended Posts

Tjao.

 

Installerade Linux RH6.1 på min maskin. Med 6.1 finns inga drivrutiner för mitt GeForce grafikkort så jag tog ned ny version av XFree86...

 

när jag kör sh xinstall.sh -check får jag följande:

 

Linux version 2.2.12-20 architecture 'i586'

Obj format is 'ELF' libc version is 6.1

 

Ok, så jag laddade ner 'FreeBSD-2.2.x' vilket borde vara rätt för min version, eller?

 

Nåja, när jag kör sh xinstall.sh får jag meddelandet att extract.exe inte är korrekt och att jag skall ta ner rätt version av xfree86...provade även att ta ner 'NetBSD-current-ELF' men det gav samma resultat...jag laddade ner filerna med CuteFtp så det borde inte ställa till med något konstigt...

 

hmm, nu är jag konfunderad...är det bara jag som är dum eller??

Link to comment
Share on other sites

Per Larsson

Uhmmm.. Vi kan börja med att reda ut vissa fundamentala begrepp. Linux är Linux. Punkt. Du kör linux, version 2.2.12 (RedHat-build 20). FreeBSD är ett helt annat operativsystem (från BSD-familjen). Visserligen finns det en viss kompabilitet mellan systemen via iBCS (Intel Binary Compatibility Standard), förutsatt att man kör båda på en Intelmaskin.

För att installera med hjälp av RPM så gör föjande:

 

1. Ladda ner RPM 3.0.5 från ftp.rpm.org

2. Ladda ner alla XFree-paket från ftp://ftp.sunet.se/pub/Linux/distributions/redhat/rawhide/SRPMS/SRPMS/

3. Kompilera dem med "rpm --rebuild"

4. Installera med "rpm -U"

5. Konfigurera.

 

/per

[inlägget ändrat 2000-07-19 22:02:13 av Per Larsson]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...