Just nu i M3-nätverket
Jump to content

Vilkorssummering?


mrright

Recommended Posts

Har två kolumner och i kolumn a1:a500 skall ett visst värde uppfyllas för att summering skall ske i b1:b500 och summering skall endast ske på de rader i kolumn b där vilkoren i kolumn a är uppfyllda...någon som pleeease kan hjälpa mig??? Eller så förtydligar jag min frågeställning....

 

/Mrright

 

Link to comment
Share on other sites

Testa Excels OCH() formel.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Ja, SUMMA.OM har jag aldrig blivit riktigt vän med, den verkar ha sina begränsningar.

 

En enkel (?) matrisformel löser dock dina problem enkelt:

{ =SUMMA(OM((B1:B7="a")*(C1:C7="b");A1:A7;0)) }

 

Måsvingarna ska du inte skriva in, dessa infogar Excel när du matar in det som en matrisformel. Avsluta inmatningen med CTRL+SHIFT+ENTER

 

b1:b7 och c1:c7 är de områden du vill kontrollera, a1:a7 det område du vill villkorssummera. Om du ej matar in det som en matrisformel blir resultatet i summan av alla celler i området.

 

Edit:

OM-satsen kan man skippa:

{ =SUMMA((B1:B7="a")*(C1:C7="b")*A1:A7) }

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2005-11-02 11:00:27 av Monshi]

Link to comment
Share on other sites

Ett onödigt inlägg, men:

Summa.om går inte att använda i det här fallet.

En matrisformeln med SUMMA är absolut enklast.

 

Vill du slippa måsvingarna och de andra konstigheterna i matrisformeln så kan du använda produktsumma istället (vilket i princip är samma sak som en matrisformel, men du slipper måsvingar och andra otäckheter :)

 

Gör som Monshi gjorde i den senaste matrisformel och utnyttja att

Falskt=0

Sant=1

 

=PRODUKTSUMMA((C2:C32>"A")*(C2:C32<"C")*H2:D32)

 

Om något av vilkoren är falskt så blir hela "raden"=0

Annars blir det (1)*(1)*(talet).

 

Dvs Precis samma sak som Monshis matrisformeln men med en vanlig formel.

 

 

 

Link to comment
Share on other sites

Försökte få till en Produktsumma-formel, men fick inte ihop den utav någon anledning...

 

Nåja, nu fungerar det dock, men samma området som tidigare:

=PRODUKTSUMMA((B1:B7="A")*(C1:C7="b")*A1:A7)

 

 

Skillnad mot MHs formel, abslouta jämförelse, inte större/mindre än.

 

Undrar vad jag gjorde fel tidigare?

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...