Just nu i M3-nätverket
Gå till innehåll
hermanviklund

Problem med flera enheter

Rekommendera Poster

hermanviklund

Nåt är konstigt med min dator. När jag kopplar ur USB-lagringsenheter, tex mp3 spelare så kommer det upp en blue screen och sen startar datorn om. Hinner inte läsa vad som står. Det händer också samma sak när jag försöker skapa enheter med Daemon tools. En enhet går bra men om jag försöker skapa fler så kommer den blåa skärmen. Med vissa USB-enheter, en digitalkamera, så kom blue screenen inte när jag kopplade in den utan när jag gick in i utforskaren. Använder Windows XP Home edition, på en bärbar HP dator.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Tunna

Blåmarkera "Den här datorn" på skrivbordet, klicka med höger musknapp och välj "Egenskaper".

 

Under fliken Avancerat så finns en ruta för "Startup and Recovery", klicka på knappen Settings (inställningar).

 

Under "System Failure" finns en ruta för "Automatically restart", kryssa ur det valet så kommer datorn att stanna vid blåskärmen och du har en chans att läsa och skriva upp vad det står för felmeddelande, kanske det kan tala om vad du har för fel.

Tunna/

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Hmm...mycket märkligt. Det räckte till och med med att kryssa ur den för att det skulle funka...ja, det var nog inte det men problemet har i alla fall försvunnit nu. Tack i alla fall för tipset. Nu vet jag vad jag ska göra nästa gång det händer i alla fall!

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Nej, tydligen hjälpte det inte för det kom tillbaks idag. Men nu har jag i alla fall skrivit av vad det står.

Det står:

 

"Ett fel uppstod och Windows har stängts av för att förebygga problem med din dator.

 

NO_MORE_IRP_STACK_LOCATION

 

sen står det lite om att man ska kontrollera program- och maskinvara

 

Inaktivera alternativ för BIOS-minnet som exempelvis caching eller shadowing"

 

Jag har kollat i enhetshanteraren om det är någon maskinvara som krånglar men jag hittar inget fel där.

 

Hur man inaktiverar caching eller shadowing har jag ingen aning om och jag vet inte heller vad dom gör.

 

Hjälp?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Har du mycket enheter i övrigt inkopplade? Om inget annat hjälper kan du ställa upp värdet för I/O-stacken direkt i systemregistret. Se dock till att göra en backup av systemregistret först (skapa även en återställningspunkt för säkerhets skull).

 

1. Gå in i Start->Run och skriv in regedit

2. I registereditorn markerar du först My Computer och väljer menyvalet Registry->Export Registry File. Se till att All är markerat längst ned under Export Range. Välj mapp att spara backupen av registret i.

3. Öppna nu "trädet" till följande mapp:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

4. I det högra fönstret, dubbelklicka på posten IRPstackSize och ändra det till ett högre värde (ex. 15, dock max 20)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Har du Norton/Symantec antivirus?

I så fall sök på NO_MORE_IRP_STACK_LOCATION här:

http://www.symantec.com/techsupp/consumer.html

 

Annars så står det en del om felet på dessa sidor:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/w2kmsgs/1168.asp (visserligen Windows 2000, men det brukar inte ändra sig mycket)

http://www.techsupportforum.com/showthread.php?s=&threadid=3986

http://aumha.org/win5/kbestop.php

 

Med tanke på vad som står i sista länken så kanske du ska testa minnet i datorn. Det gör man lämpligen med programmet memtest86. Man hämtar det antingen här:

http://www.memtest86.com/

eller här tillsammans med andra testprogram mm:

http://www.ultimatebootcd.com/

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Tack så mycket för hjälpen, det verkar vara bra länkar.

Men mitt nästa problem är att det inte finns en post med irpstacksize.

 

Kan det till och med vara så att det är problemet? Kan man lägga till den på nåt sätt?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon
Kan man lägga till den på nåt sätt?

Japp.

- Högerklicka på noden Parameters och välj New->DWORD Value

- Döp det nya värdet till IRPStackSize (var noga med versaler och gemener, det måste se exakt ut som jag skrivit) och tryck enter.

- Dubbelklicka och ange värdet enligt mitt tidigare inlägg.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Illa. Det verkar inte funka. Var det förresten max 20 hex eller max 20 dec?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

Max 20 decimalt enligt Microsoft.

Jag misstänkte att det kanske inte skulle ha någon effekt, då jag precis läste på Symantec att WinXP dynamiskt skall ställa om detta värde om så behövs. Vad det annars kan bero på vet jag inte.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Ok. Tack för hjälpen. Eftersom det inte funkade tänkte jag kanske testa det där med BIOS grejen och caching eller shadowing. Hur gör man det?

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

På ena länken hittade jag detta. Det verkar vara ungefär samma sak som jag har men jag förstår inte riktigt vad han ger för tips i slutet. Han säger döp om den där filen. Till vad som helst?

 

Vet du hur man hittar Service Settingen som man ska sätta till 4?

och vad är det för upperfilter man ska ta bort?

 

Ok, här kommer inlägget:

 

 

"This worked form me....not sure if it will for you...if you having problems with HP USB devices then this is a start...G/L

 

RICH:)

 

PROBLEM:

= Customer bought a brand new HP PSC2210 All-in-one printer. As soon as he attaches the USB device to his XP machine, he gets a bugcheck No_more_IRP_Stack_locations. Stop 0x0000035.

 

Customer has the machine dual booted with ME and the device works fine under ME.

 

MORE INFORMATION:

=Environment: Windows XP SP1

------------------------------------------------

 

GOAL: = To be able to use the HP all-in-one device on Windows XP Pro.

 

Hello Rich,

 

Thank you for contacting Microsoft Support. I am the Support Professional who will be working with you on this case. You can reach me using the contact information below and referencing the case ID.

 

As we discussed, the issue you're experiencing is a STOP 0x00000035. We will work to resolve this specific issue through the course of the case. If I have misunderstood your concern please let me know. Once we resolve this issue, verification will be provided through email. This will allow us to make absolutely sure we have completed the agreed upon incident.

 

FYI, for more information on what constitutes a support incident, please see: http://support.microsoft.com/Direct...ry/policies.asp

 

Best Regards,

Lowell Allen III

Microsoft Enterprise Support - Windows 2000 Server Setup Team

 

*** PHONE LOG 12-Dec-2002 17:53:38 Central Standard Time lowella Action Type:Incoming call

 

Rich has a hp psc 2110 all-in-one print device.

 

When he plugs in the USB device he gets a STOP 0x00000035 error. No_more_IRP_Stack_locations.

 

We have collected a memory.dmp file and he is sending it to the FTP server.

 

I will call Rich back after reviewing the dump file.

 

*** Log # 5

 

 

*** RESEARCH LOG 12-Dec-2002 19:37:31 Central Standard Time lowella Action Type:Research

 

Rob looked at dump and found a filter driver ...

 

We renamed the HPUSBFD.SYS file - found in system32 folder

 

Set the Service level to 4 ( disabled )- was a registery setting dont remeber where

 

and removed the upperfilter driver from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{36FC9E60-C465-11CF-8056-444553540000}

 

and rebooted connected device it recognized device correctly"

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
hermanviklund

Har förresten inte den filen insåg jag nu. Men det andra kanske, kan det hjälpa?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

HPUSBFD.SYS lär väl antagligen en fil som hör ihop med den där HP-skrivaren de håller på med. Annars så gällde det nog bara att byta namn till vad som helst, bara för att förhindra Windows att använda den efter en omstart av datorn. Det stod inget filnamn längst ner på din blåa skärm?

 

Är det samma felmeddelande på alla blåskärmar?

 

Du får kolla om du har den där registerposten de skriver om och så testa. Du lär ju knappast förstöra något genom att ta bort den i så fall.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...