Just nu i M3-nätverket
Gå till innehåll
webbaccess.net

Ställa in IISen??

Rekommendera Poster

jag har köpt en domän på Loopia.se och har pekat den mot min server men problemet är att när jag skriver webbaccess.net så kommer jag inte till sidan jag har konfigruerat till webbaccess.net

 

Finns det någon som kan hjälpa mig??

 

MVH Peter

 

EDIT Har Win 2003 SBS om det kan hjälpa något

[inlägget ändrat 2005-08-18 22:33:56 av eddippidde]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om du hanterar fler än en domän på IIS:en så ka du använda host-headers för att styra besökarna rätt.

Kolla denna guide om du inte vet hur man gör:

http://www.visualwin.com/host-header

 

 

 

/Cluster

------------------------------------------------------------

Ditt vetande är värdelöst om inte andra vet att du vet

-----------> http://eforum.kicks-ass.net <------------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

webbaccess.net resolvar till 194.9.94.245 och Loopia.

Problemet ligger alltså inte i dina inställningar på din IIS utan dina inställningar på Loopia.

 

 

 

/Cluster

------------------------------------------------------------

Ditt vetande är värdelöst om inte andra vet att du vet

-----------> http://eforum.kicks-ass.net <------------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Den resolveade rätt igår (annan tråd) och då fanns problemet. Min gissning är att han ställt om det så att det är loopia som skickar vidare till http://webbaccess.dyndns.org/ (som verkar fungera).

 

Det är lite svårt att skjuta på ett rörligt mål, han borde (imho) låta det vara som det är när det inte fungerar så att folk kan se vad IIS:en svarar när det inte fungerar.

 

Edit: Om man fuskar sig fram till att requesta http://webbaccess.net från hans dator (som dyndns pekar ut) så ser man att det verkar vara en behörighetsgrej:

spinner:~t>telnet webbaccess.dyndns.org 80
Trying 81.225.172.221...
Connected to webbaccess.dyndns.org (81.225.172.221).
Escape character is '^]'.
GET / HTTP/1.0
HOST:webbaccess.net

HTTP/1.1 401 Unauthorized
Content-Length: 1601
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
X-Powered-By: ASP.NET
Date: Fri, 19 Aug 2005 06:00:20 GMT
Connection: close

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Du har inte behörighet att visa den här sidan.</TITLE>
...

 

Om man gör samma sak och begär hosten www.webbaccess.net (alltså med www) från servern på 81.225.172.221 så kommer man HELT RÄTT.

[inlägget ändrat 2005-08-19 08:03:37 av fhe]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Om man gör samma sak och begär hosten www.webbaccess.net (alltså med www) från servern på 81.225.172.221 så kommer man HELT RÄTT.

Alltså eddippidde,

 

Jag patchade just min egen dns så att www.webbaccess.net pekar på 81.225.172.221 och allt (inklusive IIS:en) fungerar klockrent. Om du gör om första steget i min beskrivning i förra tråden för att peka domänen på din IP istället för att göra en forward till dyndns så kan jag nästan garantera dig att det kommer det att fungera (om det inte gör det så föreslår jag att du inte gör några ändringar alls förrän du har frågat här vad det är som är fel).

 

Ett alternativ (om du verkligen har en dynamisk IP) är att inte peka på IP-adressen utan på ditt dyndns-namn, gör då som i bifogad bild (tänk på att det vanligtvis tar ett par timmar innan det slår igenom, det är ingen idé att ändra under den tiden), genom att göra så behöver du inte uppdatera din IP hos loopia om den ändras.

 

Hos loopia ingår en dyndns-tjänst som fungerar bra, men det är bäst att ta en sak i taget så vänta med den tills du ser att allt fungerar.

 

 

 

[bild bifogad 2005-08-19 09:12:55 av fhe]

740163_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag tror dig.

Allt jag säger är att din webbserver fungerar nu, den gör rätt och hanterar www.webbaccess.net precis som du vill ha det.

Allt som saknas är att du pekar domänen www.webbaccess.net så att den på det ena eller andra sättet hamnar på 81.225.172.221, sen slipper det stå dyndns i dina URL:ar, vilket man får anta var en av de grejjer du ville från början.

 

Ändra inget med webbservern, ändra bara hos loopia så att de inte skickar dig till dyndns.org utan till din webbserver.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

har ändrat tillbaka till "rätt" inställningar som det angavs av fhe i förra tråden....

 

så nu ska dem på loopia bara uppdatera den där...

 

men när jag ställer in IISen är det bara till att sätta hostheadern på webbaccess.net??

 

se bifogad bild

 

[bild bifogad 2005-08-19 09:28:59 av eddippidde]

740169_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
så nu ska dem på loopia bara uppdatera den där..

Sidospår men: Loopia uppdaterar den så fort du sparar, det som tar tid är att få uppdateringen att gå vidare till alla andra dns:er i världen, den telia-dns som du använder tror redan att den vet vilken IP-adress som gäller. Därför finns det en slags "bäst före"-stämpel knuten till adressen, när den har passerats kommer Telia att fråga loopia om aktuell adress och då märker du om det fungerar.

 

men när jag ställer in IISen är det bara till att sätta hostheadern på webbaccess.net??

Lyssna på mig:

Din IIS ÄR helt korrekt inställd för att hantera www.webbaccess.net, du behöver inte ändra någonting på webbservern (och framförallt är det jättedumt att ändra två saker innan man har sett att den första fungerar, går det fel vet du inte vilken ändring som gjorde att det gick fel)

 

När du ser att allt fungerar kan du börja bekymra dig om att ställa in den så att det fungerar även om du surfar till http://webbaccess.net/ (utan www). Tekniskt sätt är det en annan domän och det enklaste är att helt enkelt låta loopia göra en forward till den första (som i steg två av min förklaring i förra tråden).

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
okej jag får just nu att domänen är parkering på loopia

Eftersom dina DNS:er inte är uppdaterade än (som sagt), ta det lugnt, det går inte att stressa sig igenom saker som per design SKA ta flera timmar.

 

Tittar man i loopias dns:er ser det helt rätt ut:

 

c:\>nslookup
> server ns3.loopia.se
Default server: ns3.loopia.se
Address: 194.9.94.245#53
> www.webbaccess.net
Server:         ns3.loopia.se
Address:        194.9.94.245#53

Name:   www.webbaccess.net
Address: 81.225.172.221

Så fort bäst-före-tiden har gått ut så kommer telias dns:er att uppdateras och då kommer det att bli rätt för dig med. Det är inget du kan påverka.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jag har en egen DNS adress i nätverket

Inte för att jag förstår om du menar att du har en egen DNS eller om du menar något annat men det spelar ingen roll om det finns tre eller 17 DNS:er i nätverket. De flesta DNS:er frågar uppåt om det är en domän den inte själv hanterar.

 

sen om jag skriver http://webbaccess.net i IE just nu

Vet inte om uppdateringen har slagit igenom för dig än men hos mig kommer jag nu rätt om jag surfar till http://www.webbaccess.net/ så det kommer nog att fungera snart för dig med.

 

Surfar jag till http://webbaccess.net/ så gör den (precis som jag föreslog dig) en forward till http://www.webbaccess.net/, dvs allt fungerar.

 

Om du har en dynamisk IP så föreslår jag verkligen att du gör som jag beskrev med bilden ovan (dvs sätta en sk CNAME-record till ditt dyndns-namn), då slipper du uppdatera hos loopia och vänta flera timmar varje gång du får ny IP.

Fast vänta med det tills du ser att allt fungerar även för dig (eller kanske ännu enklare, vänta tills du får en ny IP och måste ändra ändå).

 

Edit: Testa att skriv in URL:en här så får du se att det fungerar:

http://www.the-cloak.com/Cloaked/

[inlägget ändrat 2005-08-19 10:32:32 av fhe]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

har du kommit till sidan "Välkommen till detta nätverks intarnät??

 

om du har kommit dit så är det fel i IISen (tror jag)

 

du ska komma till en helt annan sida...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
har du kommit till sidan "Välkommen till detta nätverks intarnät??

Ja

om du har kommit dit så är det fel i IISen (tror jag)

du ska komma till en helt annan sida...

Ok, då är det din IIS som är felkonfigurerad. Ägna dig då åt den och strunta i loopia tills vidare eftersom allt är rätt där.

 

Här finns en guide:

http://support.microsoft.com/?id=324287

 

Ovanstående är förvisso anpassad för Engelsk Windows men det borde vara ungefär samma steg fast översatt.

 

 

[inlägget ändrat 2005-08-19 11:03:34 av fhe]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
har lagt upp så att det är samma sida men på 2 olika sidor

 

http://webbaccess.net'>http://webbaccess.net'>http://webbaccess.net'>http://webbaccess.net

http://eddip.dyndns.org

Men eftersom du inte har lagt upp det på http://www.webbaccess.net'>http://www.webbaccess.net/'>http://www.webbaccess.net/ som är där man hamnar om man surfar till http://webbaccess.net så får man bara "Bad Request (Invalid Hostname)" när man försöker surfa till http://webbaccess.net

 

Lägg upp http://www.webbaccess.net också (eller byt helt enkelt namn på hosten webbaccess.net) så kommer det att fungera med både http://webbaccess.net och http://www.webbaccess.net

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har ingen IIS och vet inte, det ser rätt ut men du gör kanske bäst i att vänta på Clusters svar.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...