Just nu i M3-nätverket
Jump to content

Skumma problem med XP och ZoneAlarm


AF.e

Recommended Posts

Hejsan.

 

Jag gjorde en angelägen revolution för några veckor sedan och avinstallerade alla Symantecs produkter från datorn. Skönt att vara av med Norton.

 

Istället kör jag nu ZoneAlarms hela suite (v 5.5). Det mesta fungerar bättre (snabbare) med ZoneAlarm, men jag har haft vissa problem med fjärrskrivbordet och Outlook.

 

För att få fjärrskrivbordet att fungera öppnade jag tcp-port 3389. Port 80 är även öppen efter som jag använder min dator som webbserver. Jag behöll dock säkerhetsreglaget på "High" för Internet-zone (jag har sett många råd om att sänka det).

 

Innan jag öppnade port 3389 manuellt fungerade fjärrskrivbordet inte alls. Efter att jag öppnat porten går det bra att ansluta, och oftast fungerar fjärrskrivbordet som det ska. Med jämna mellanrum bryts dock anslutningen. När det väl har hänt en gång kommer problemet tillbaka direkt och fjärrskrivbordet fryser strax efter inloggning (ca 10 sekunder). Jag har testat att logga in 6-7 gånger och problemet återkommer varje gång. Det verkar vara ZoneAlarm som är boven, för om man skyndar sig att stänga av ZoneAlarm under dessa 10 sekunder så försvinner problemet.

 

Det konstiga är att om man sedan startar ZoneAlarm igen efter ett par timmar, eller överlag bara lämnar datorn ifred några timmar så fungerar fjärrskrivbordet igen även med ZoneAlarm igång. Jag kan inte hitta något system i när felet uppkommer.

 

Någon som har erfarit liknande problem och har en magisk lösning?

 

Problemet med Outlook verkar vara kopplat till ZoneAlarms insticksprogram eftersom felet dök upp först efter att ZoneAlarm installerats. Även detta uppträder sporadiskt och till synes utan system. Rätt var det är börjar Outlookfönster ploppa upp och försvinna igen. Man hinner se dem blinka till nere i aktivitetsraden, men man kan aldrig se vad fönstret egentligen innehåller.

 

Om man trycker Ctrl-Alt-Del och kollar in tjänsterna så visar det sig att Windows av sig själv startar upp dubbletter av två tjänster. Jag har tyvärr glömt bort vad dessa heter, men båda verkar, att döma av namnet, ha att göra med insticksmoduler till Outlook. Tjänsterna startas upp i par, och efter ca 2 sekunder startas de upp igen. Detta fortsätter om och om igen, till synes utan slut. Enda lösningen är att starta om datorn, eller att logga ut. Felet kan uppträda utan att Outlook är igång, men har alldrig uppträtt utan att Outlook varit igång sedan datorn startades.

 

Jag bytte ut Norton samtidigt på två datorer (min stationära, och min bärbara) och detta Outlook-fel förekommer på båda två.

 

Jag gissade att det kunde vara något spår i registret från Norton och jag hittade nycklar som ledde till Nortons motsvarande insticksmodul inne i Outlookmapparna i HKLM. Jag raderade dessa nycklar, men felet uppträder fortfarande.

 

Jag hoppas att ni orkat igenom hela denna uppsats, och har energi nog för att föreslå lösningar. Jag vet inte var jag ska fortsätta felsöka.

 

Båda problemen uppträder enbart då och då, och därför är det svårt att laga dem.

 

Väntar på lite experttips.

 

Tack.

 

Link to comment
Share on other sites

Jag får säkert ingen poäng för det här ;-)

fast du ger ju inga ;-)

 

OK seriöst jag skulle ominstallera Windows och jag kan ju lite grann, men det skulle vara för jobbigt att leta reda på allt som kan vara fel i det här fallet - men vad vet jag? ;-)

---

Who am I?

 

Link to comment
Share on other sites

En sak som kan vara värd att testa är att lägga till programmet mstsc.exe i ZoneAlarms Program settings list och ge programmet "Allow Server" och "Allow Connect" för både Local och Internet.

(Det finns iof säkert risker förknippat med detta)

 

Själv kör jag RDP på annan port än standard dels för att minska risken för otillbörliga anslutningar men framförallt för att kuna köra fjärrskrivbort till alla mina burkar. Eftersom jag satt olika portar på alla mina maskiner ger det mig möjligheten att fjärransluta till dem individuellt trots att alla sitter bakom samma router/på samma IP.

 

Ändra port för RDP: http://support.microsoft.com/default.aspx?scid=kb;en-us;306759

Om du byter port så glöm inte att mappa upp porten (portforward till rätt maskin) i eventuell router samt öppna porten i brandväggen.

 

 

/Cluster

------------------------------------------------------------

Ditt vetande är värdelöst om inte andra vet att du vet

-----------> http://eforum.kicks-ass.net <------------

 

[inlägget ändrat 2005-07-28 10:36:42 av Cluster]

Link to comment
Share on other sites

Installera om Windows känns som en onödigt radikal lösning. Gjorde en helt ren installation, inklusive formatering av C, för bara ett år sedan. Dessutom uppför sig datorn som den ska förutom just dessa två problem.

 

Den stationära körde tidigare NIS 2004 PRO (7.0) och den bärbara körde NIS 2005. Symantects borttagningsverktyg verkar bara finnas fram till NIS 2003 och fristående NAV 2004. Det finns visserligen en länk till ett dokument som heter nåt i stil med "Removing NIS 2004 when Add/Remove programs does'nt work". Denna länk genererar dock bara ett felmeddelande från sajten.

 

Mstsc.exe har fått fulla rättigheter i både trusted och internet zone.

 

Nu idag släpptes dock en uppgradering av Zone Alarm Security Suite (till v6.0). Har inte hunnit utforska och testa det till fullo, men det verkar ha en del nya finesser. Bland annat har det något som kallas SmartDefense som kollar efter olika typer av aktiviteter som programmen utför. Man kan med andra ord tillåta Mstsc att göra vad i helsike det vill, men förhindra till exempel messenger från att göra annat än vad ett im-program borde.

 

Som sagt har jag uppdaterat Zone Alarm idag, och jag hoppas på att detta löser problemen utan att jag behöver lista ut vad som egentligen gick fel. Återkommer om det fortfarande strular.

 

Tack för tips och råd.

 

Link to comment
Share on other sites

Link to comment
Share on other sites

  • 2 months later...

Okej. Nu har jag äntligen blivit av med problemet. Uppdateringen gjorde inte susen.

 

Jag körde förut G6 FTP Server av version 2.1 som har några år på nacken. Det verkar som om det fanns någon typ av konflikt mellan G6 och ZoneAlarm. Jag hade som sagt problem med att trayen betedde sig underligt samt att fjärrskrivbordet strulade. Ftpservern fungerade fint, även om krypteringen av lösenord till mina användare av någonanledning slutade fungera när ZoneAlarm installerades.

 

För två veckor sedan uppdaterade jag nu min version av G6. Döm av min förvåning när alla problem med ZoneAlarm försvann. Tidigare kunde volymkontrollen försvinna från trayen. Alla sådana problem är nu väck och fjärrskrivbordet fungerar klockrent (använder det just nu).

 

Jag har läst om andra på internet som haft samma problem med trayen och det trode ju vara samma orsak. Min gamla version av G6 var inte skriven för NT/XP utan i första hand gamla Win 9x av olika versioner. Jag är ingen expert, men jag antar att dessa program använder trayen annorlunda vilket ställer till problem för ZoneAlarm.

 

Vad orsaken till fjärrskrivbordets strulande berodde på har jag fortfarande ingen aning om, men nu är problemet i alla fall väck.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...