Just nu i M3-nätverket
Jump to content

Fel vid boot från GRUB (Error 25)


squarehead

Recommended Posts

Jag har precis installerat debian-31r0a-i386-binary-1 på en gammal Pentium 75 MHz med 40 MB RAM. Det sista installationsprogrammet gjorde var att lägga in multiboot-programmet GRUB. Tyvärr går det inte så bra att boota efter installationen. Följande visas på skärmen...

 

GRUB Loading stage1.5


GRUB loading, please wait...
Error 25

 

Det dröjer kanske 20 sekunder innan andra raden dyker upp och ytterligare nån eller ett par minuter innan "Error 25" visas. Lysdioden för hårddiskaktivitet lyser konstant ända tills felmeddelandet kommer upp.

 

Nån idé om vad som kan vara fel och hur jag rättar till det? Det andra operativsystemet, som sedan tidigare ligger installerat på den första primära partitionen (FAT32), är Windows 98 SE.

 

[inlägget ändrat 2005-07-21 17:16:31 av Daniel Thornberg]

Link to comment
Share on other sites

Det absolut enklaste sättet kan vara att göra om installationen.

Sedan föredrar jag LILO som bootmanager för GRUB har givit mig problem.

 

Link to comment
Share on other sites

Ska först scanna igenom hela hårddisken med SpinRite för att se om det faktiskt finns några fysiska fel. Kollar upp LILO sen..

 

Link to comment
Share on other sites

Men fördelen med Grub är att om nåt är fel med konfigen kan man ändå boota manuellt med kommandogränssnittet. Om nåt är fel på Lilo så är man körd...

 

Iaf, det verkar som att fel 25 kan bero på allt ifrån nåt hårdvaruproblem till en felaktig konfiguration. Testa t ex att posta filen /boot/grub/menu.lst (om du kan komma åt den t ex från nån räddningdiskett...)

 

Annars kan du som sagt testa att boota manuellt, antingen från kommandogränssnittet (tryck c vid grubmenyn) eller genom att ändra i de alternativ som finns (tryck e).

 

Kommandona för att boota borde vara nåt liknande:

root (hd0,1) # = hda2, 2:a partitionen på 1:a HD:n
kernel /boot/vmlinuz root=/dev/hda2  # se till att ange samma partition som ovan (men med annan syntax...)
initrd /boot/initrd # behövs bara om man använder initrd, vilket jag tror standardkärnan i Debian brukar göra
boot

Grub stöder tab-komplettering, så om du är osäker på t ex nåt av filnamnen är det bara att trycka tab ett par gånger.

 

Link to comment
Share on other sites

Jag kommer inte in i GRUB och har aldrig sett hur gränssnittet ser ut. Det börjar laddas och sen är det stopp.

 

SpinRite upptäckte förresten inga fel på hårddisken.

 

Fick psykbryt, laddade en startdiskett för Win98 och skrev FDISK /MBR, sedan FDISK för att gå in och välja FAT32 partitionen som aktiv. Därefter startade Windows 98 igen. Skönt att något funkar. Har visserligen inget värdefullt sparat på disken, men ändå.

 

Tänkte jag skulle följa ditt tips och dra ut GRUBs menu.lst från Linux-installationen. Körde igång tomsrtbt, som jag tror ofta används som räddningsdiskett i såna här sammanhang. Före och efter inloggning, dvs medan jag använder tomsrtbt får jag ett nytt spännande fel!

 

eth0: RTL8139 Interrupt line blocked, status ffff.
eth0: PCI Bus error 2900007. (upprepas exakt 21 ggr)
eth0: Too much work at interrupt, IntrStatus=0xffdf.

Det här återupprepas med nån minuts intervall. Mellan varje felutskrift kan jag, om jag är snabb, skriva kommandon och använda systemet som vanligt.

 

När jag ser RTL8139 för det tankarna till nätverkskortet... Är jag på rätt spår då? Ser ut som att datorn har vunnit dagens batalj. Men får jag bara vila upp mig lite så är jag snart där och rotar igen. :)

 

Edit: Lyckades plocka fram menu.lst till slut. Här är den...

 

[log]# menu.lst - See: grub(8), info grub, update-grub(8)

# grub-install(8), grub-floppy(8),

# grub-md5-crypt, /usr/share/doc/grub

# and /usr/share/doc/grub-doc/.

 

## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

default 0

 

## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout 5

 

# Pretty colours

color cyan/blue white/blue

 

## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line) and entries protected by the

# command 'lock'

# e.g. password topsecret

# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret

 

#

# examples

#

# title Windows 95/98/NT/2000

# root (hd0,0)

# makeactive

# chainloader +1

#

# title Linux

# root (hd0,1)

# kernel /vmlinuz root=/dev/hda2 ro

#

 

#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

 

### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below

 

## DO NOT UNCOMMENT THEM, Just edit them to your needs

 

## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specifiv kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

# kopt=root=/dev/hda2 ro

 

## default grub root device

## e.g. groot=(hd0,0)

# groot=(hd0,1)

 

## should update-grub create alternative automagic boot options

## e.g. alternative=true

## alternative=false

# alternative=true

 

## should update-grub lock alternative automagic boot options

## e.g. lockalternative=true

## lockalternative=false

# lockalternative=false

 

## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot options

## altoptions=(recovery mode) single

# altoptions=(recovery mode) single

 

## controls how many kernels should be put into the menu.lst

## only counts the first occurence of a kernel, not the

## alternative kernel options

## e.g. howmany=all

## howmany=7

# howmany=all

 

## should update-grub create memtest86 boot option

## e.g. memtest86=true

## memtest86=false

# memtest86=true

 

## ## End Default Options ##

 

title Debian GNU/Linux, kernel 2.4.27-2-386

root (hd0,1)

kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda2 ro

initrd /boot/initrd.img-2.4.27-2-386

savedefault

boot

 

title Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)

root (hd0,1)

kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda2 ro single

initrd /boot/initrd.img-2.4.27-2-386

savedefault

boot

 

### END DEBIAN AUTOMAGIC KERNELS LIST

 

# This is a divider, added to separate the menu items below from the Debian

# ones.

title Other operating systems:

root

 

 

# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/hda1

title Windows 95/98/Me

root (hd0,0)

savedefault

makeactive

chainloader +1[/log]

Edit (050722): Lite mer info om hur disken är uppdelad. Jag följde rekommendationerna från Debians installationsprogram, så det är inte jag som har bestämt storlek på de olika partitionerna.

 

hda1   primary   3.2 GB     fat32
hda2   primary   255.0 MB   ext3   /
hda5   logical   2.0 GB     ext3   /usr
hda6   logical   888.3 MB   ext3   /var
hda7   logical   115.1 MB   swap   swap
hda8   logical   156.2 MB   ext3   /tmp
hda9   logical   1.9 GB     ext3   /home

 

[inlägget ändrat 2005-07-21 22:32:36 av Daniel Thornberg]

[inlägget ändrat 2005-07-21 22:46:43 av Daniel Thornberg]

[inlägget ändrat 2005-07-22 11:54:45 av Daniel Thornberg]

Link to comment
Share on other sites

Efter att ha flashat med ett par olika BIOS-versioner, raderat CMOS.. and god knows what.. kom jag på att man kanske ska terminera en IDE-kabel genom att sätta en ensam IDE-enhet på den yttersta kontakten. Det verkar iaf ha hjälpt i det här fallet. För nu går GRUB igång utan minsta protest och allt är frid och fröjd. Äntligen har jag en fungerande Linux-installation och kan börja experimentera lite mer seriöst.

 

Edit 050726: Okej, fel av mig igen. Det fungerade några ggr, sen tog det stopp. Det verkar ha varit hårddisken det var fel på hela tiden. Bytte till en äldre disk och nu har det fungerat under många omstarter.

 

[inlägget ändrat 2005-07-26 19:56:13 av Daniel Thornberg]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...