Just nu i M3-nätverket
Jump to content

Förstår inte vad som är fel


Wepe

Recommended Posts

Hej hopp!

 

Ska spara en redigerad medlemssida men får felmeddelandet:

Microsoft JET Database Engine error '80040e10'

No value given for one or more required parameters.

/redigera.asp, line 143

 

Förstår inte vad som är fel. Har använt samma kod på ett flertal ställen och det har alltid funkat.

SQL = [GRÅ]"UPDATE medlem SET Efternamn = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Efternamn"[/GRÅ])&[GRÅ]"',"[/GRÅ]

[color="#0000ff"]If[/color] [b]Request[/b].Form([GRÅ]"Losen2"[/GRÅ]) <> [GRÅ]""[/GRÅ] [color="#0000ff"]Then[/color]
SQL = SQL & [GRÅ]"Losen = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Losen2"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
[color="#0000ff"]End[/color] [color="#0000ff"]If[/color]

SQL = SQL & [GRÅ]"Ar1 = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Ar1"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Ar2 = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Ar2"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Email = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Email"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Telefon = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Telefon"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Mobil = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Mobil"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Ovriga = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Ovriga"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Vvv = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Vvv"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Bostad = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Boende"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Gornu = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Gornu"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Framtid = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Framtid"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Dejtade = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Dejtade"[/GRÅ]) &[GRÅ]"',"[/GRÅ]
SQL = SQL & [GRÅ]"Kontaktmed = '"[/GRÅ]& [b]Request[/b].Form([GRÅ]"Kontaktmed"[/GRÅ]) &[GRÅ]"'"[/GRÅ]
SQL = SQL & [GRÅ]"WHERE ID ="[/GRÅ]& [b]Request[/b].Querystring([GRÅ]"ID"[/GRÅ])

Connect.[color="#0000ff"]Execute[/color](SQL)

 

Någon som kan se nåt fel?

 

Link to comment
Share on other sites

Anjuna Moon

Kanske Request.Querystring("ID") inte fått något värde? Hursomhelst är det lättast att lösa själv genom att debugga din query. Skriv ut strängen SQL så ser du ju direkt om det är en giltig fråga eller om några värden saknas. Därefter felstegar du baklänges.

 

Link to comment
Share on other sites

Jomen så är det... Upptäckte så klart felet det första jag gjorde efter att jag skrivit inlägget. Tack iaf.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...