Just nu i M3-nätverket
Gå till innehåll
BrumBulan

Problem med databaskopplingen

Rekommendera Poster

Det är bra att du lägger dom i olika lättare att hålla koll på dom när man stiger till hundra filer eller mer.

Lycka till. NU ska jag se om jag har något vatten i kranen.

 

/Du kan alltid nå mig via skolans växel.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Skåningen skrev:

Hejsan jag har för mig det är

"/" och inte "\"

Och sen har du glömt en viktig sak så det är det som har gjort att det inte fungerar.

efter

koden ska du ha med

& ";"

 

 

Connect.Open "driver={Microsoft Access Driver (*.mdb)};dbq="& Server.MapPath("\joel\idg\databas\adressbok.mdb")

 

är felaktig du ska ha

 

Connect.Open "driver={Microsoft Access Driver (*.mdb)};dbq="& Server.MapPath("/joel/idg/databas/adressbok.mdb") & ";"

 

Hej Skåningen,

lite fundersam blev jag nu. Jag använder ovanstående modell för alla databaskopplingar och den fungerar felfritt.

Att man anv "\" antar jag är för att det faktiskt är den egna hårddisken man relaterar till - ingen websida.

Att man skall ha med

& [GRÅ]";"[/GRÅ]

har jag aldrig märkt. Om du tittar på t.ex. http://www.idg.se/webstudio/pub/article.asp?id=116 så ser du där att Connect-raden inte avslutas med semikolon.

 

Observera att jag på intet sätt försöker antyda att du har fel. Jag är en verklig novis på området och kodar mest asp+access för egna småprojekt.

Blev mest fundersam som sagt..

 

 

Edit: ovanstående kod som jag angav fungerar ju bevisligen då den är tagen från ett fungerande exempel på mitt webhotell.

[inlägget ändrat 2005-05-31 14:18:29 av Joel Sundberg]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...