Just nu i M3-nätverket
Gå till innehåll
Christoph

IIS och intranät

Rekommendera Poster

Christoph

Hej,

 

jag har följande problem med IIS:

 

Jag har en server med IIS6 igång, där jag satt upp två hemsidor. Den ena sidan, default site, når jag via http://servernamn, det är inget problem som helst. Det jag vill komma fram till är andra sidan, som jag vill att den skall kunna nås via http://intranet.

 

Det finns ingen dator som heter intranet, men jag förstod att det på något sätt är möjligt att fixa med http-headers, men jag får det inte på grej. WINS är kanske något som också borde tas hänsyn till?

 

Någon som kan det här?

 

Hälsningar,

 

Christoph

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mr Andersson
Det finns ingen dator som heter intranet

 

Då blir det jobbigt...

 

 

men jag förstod att det på något sätt är möjligt att fixa med http-headers

 

Korrekt, men först måste det ju finnas en dator med namnet.

 

Lägg in den i DNS, allstå en A pekare till den IP som servern har.

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Hej,

 

jag tror inte att det är ett måste att ha en dator vid namnet intranet, det är antagligen ett DNS-problem. Du har inte heller någon dator vid namnet www.idg.se, kan dock ändå nå deras hemsida, tack vare DNS.

 

Lägg in den i DNS, allstå en A pekare till den IP som servern har.
Kan du förklara detta lite närmare, hur man gör och varför? Tack!

 

Hälsningar,

 

Christoph

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
dune
Kan du förklara detta lite närmare, hur man gör och varför? Tack!
Det vi pratar om är namn-uppslagning. Alltså att alla datorer i ditt intranät skall förstå vilket ip-nummer som intranat skall peka mot. Det finns ett antal olika sätt du kan uppnå detta i windows.

 

Det första är hosts-filen som finns någonstans i windows-katalogen, exakt vart beror lite på vilken version av windows. Där i kan du helt enkelt skriva:

192.168.0.55 intranat

om nu IIS-servern har det interna ip-numret 192.168.0.55. Detta får du göra på samtliga datorer som skall komma åt IIS-servern.

 

Det andra sättet att åstakomma detta är att ha en dns-server i nätverket där du lägger till en zon som heter intranat och lägger till en A-pekare (pekar en adress mot ett ip-nummer). I server-versionerna av windows finns DNS inbyggt i systemet och borde bara vara att starta igång, och sedan se till att alla datorer i lanet använder den datorn som DNS.

 

 

.dune.

----------------------------------------------

- "I find this a nice feature but it is not according to the documentation.

Or is it a BUG?"

- "Let´s call it an accidental feature. :-)"

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Hej,

 

jag gjorde som du skrev i ditt andra förslag, dock utan framgång. http://intranet hittar inget...

 

Christoph

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fhe
jag gjorde som du skrev i ditt andra förslag, dock utan framgång. http://intranet hittar inget...

Ett rätt vanligt fel är att man uppdaterar host.sam-filen istället för host-filen. Om man (som windows gör om man inte ställer om den) döljer filtillägg så ser filerna identiska ut i explorern.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Tack för svaret.

 

Jag la in det i detta forum, eftersom det handlar om en Windows 2003-server.

 

Christoph

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Jupps, detta var jag medveten om - dock fortfarande inget :(

 

Är det av hjälp för någon så kan jag ta lite screenshots om hur läget är. Detta är gjort hittills:

 

Servern heter ATFSRV1 och går att nå via http://atfsrv1. IP-nummret är 10.0.5.2. På servern är en domän igång (DNS Forward Lookup Zones) som heter x1.aland.local, där det bl a finns ett inlägg atfsrv1 HOST (A) som pekar mot 10.0.5.2.

 

Jag la till en till sådan domän som heter intranet, med SOA atfsrv1.x1.aland.local, NS atfsrv1.x1.aland.local och Host (A) 10.0.5.2

 

Sedan la jag till intranet atfsrv1 x1.aland.local till hosts-filen.

 

IIS: la till en hemsida intranet, som väntar på host-headern intranet

[inlägget ändrat 2005-03-15 13:17:32 av Christoph]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Reefer

Heh ok, jag svarar inläggsvis på huvudsidan och kollar inte så noga vilket forum dom ligger i ;)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cluster
Christoph skrev:

jag gjorde som du skrev i ditt andra förslag, dock utan framgång.

Menar du då DNS-förslaget? om du testade hosts-filslösningen så måste du göra detta på ALLA datorer som skall hitta "intranat", dessutom så måste du använda hostheaders för att skilja på de förfrågningar som ska returnera default resp. intranätssidorna.

 

OT:

Reefer skrev:

Heh ok, jag svarar inläggsvis på huvudsidan och kollar inte så noga vilket forum dom ligger i ;)

Men frågan gällde väl ändå IIS 6... ;-)

 

 

 

/Cluster

------------------------------------------------------

"Den som försummar att dricka ur erfarenhetens källa

kommer troligen att dö av törst i okunnighetens öken."

------> http://eforum.kicks-ass.net <------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Jag testade både och. Direkt på servern kommer jag nu åt http://intranet, men inte från någon annan dator.

 

EDIT: funkar nu när jag startade om datorn, där jag la till raden till HOSTS-filen. Men hur får jag igång det utan att lägga till raden till hosts-filen?

[inlägget ändrat 2005-03-15 13:26:02 av Christoph]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fhe
EDIT: funkar nu när jag startade om datorn, där jag la till raden till HOSTS-filen. Men hur får jag igång det utan att lägga till raden till hosts-filen?

Vill du inte ändra varenda dators host-fil så får du helt enkelt lägga till namnet i den DNS som datorerna använder. That's it.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Hur gör man det, vet du? Ja la ju till "intranet" i en Forward Lookup Zone-tråd.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fhe

Har aldrig administrerat en DNS på en Windows2003 Server, har ingen aning om hur du gör.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Christoph

Någon som vet hur man gör?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Jojja

 

To add an alias (CNAME) resource record to a zone

Using the Windows interface

 

Open DNS.

In the console tree, right-click the applicable forward lookup zone, and then click New Alias.

 

In the Alias name text box, type the alias name.

 

In the Fully qualified domain name (FQDN) for target host text box, type the fully qualified domain name of the DNS host computer for which this alias is to be used.

As an option, you can click Browse to search the DNS namespace for hosts in this domain that have host (A) records already defined.

 

Click OK to add the new record to the zone.

 

http://www.microsoft.com/resources/documentation/WindowsServ/2003/standard/proddocs/en-us/Default.asp?url=/resources/documentation/WindowsServ/2003/standard/proddocs/en-us/sag_DNS_pro_AddAlias.asp

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Reefer
/Cluster

 

Men frågan gällde väl ändå IIS 6... ;-)

 

Inläggsvis betyder i min ordbok per inlägg

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cluster
Inläggsvis betyder i min ordbok per inlägg
I min med. Så vilket inlägg var det du svarade på?

 

/Cluster

------------------------------------------------------

"Den som försummar att dricka ur erfarenhetens källa

kommer troligen att dö av törst i okunnighetens öken."

------> http://eforum.kicks-ass.net <------

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Johan Sandqvist

Jag tror problemet är att du gjorde lite fel när du la till nya DNS informationen. Om dina datorer är med i ett nätverk där domänen heter x1.aland.local så skall du skapa din 'intranat' DNS adress i den domänen, inte en ny domän som du gjorde. Lägg istället till adressen 'intranat' i DNS-zonen 'x1.aland.local'. Se till att din IIS6 server har en website konfigurerad som svarar på port 80 och header 'intranat'.

 

Lycka till!

 

// Johan

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...