Just nu i M3-nätverket
Jump to content

Problem med en <textarea>


Graystone

Recommended Posts

Hej

 

Nu har jag problem igen....

 

Denna gång med att värden från en sql-databas inte skrivs ut korrekt i en <textarea>. Jag vet att jag får rätt värde från databasen, utan konstiga tecken. Det skrivs ut helt korrekt om jag använder response.write, men när jag skriver ut innehållet i textarean så får jag en massa mellanslag i början.

 

Textarean har 3 rader och 20 kolumner om det har någon betydelse.

 

Tack på förhand.

 

/Sanna

 

Link to comment
Share on other sites

Den ser ut så här:

 

<textarea id=Atgard name=tarAtgard tabindex=23 style=[GRÅ]"HEIGHT: 50px; WIDTH: 250px"[/GRÅ] rows=[GRÅ]"3"[/GRÅ] cols=[GRÅ]"20"[/GRÅ]>[MÄRK]<%[/MÄRK]=rs4([GRÅ]"Annan"[/GRÅ])[MÄRK]%>[/MÄRK] </TEXTAREA>

 

Link to comment
Share on other sites

Magnus Ahlkvist

Och du är HELT säker på att det är rätt i databasen? När du skriver ut med Response.Write, och sedan kollar i HTML-koden som produceras, ser det då rätt ut?

Det ser rätt ut på skärmen i alla lägen, men kan ändå vara "fel" i HTML-filen, eftersom browsern tolkar flera mellanslag som bara ett mellanslag.

--

Snäll ibland. Rättvis nästan jämt. Elak för det mesta.

 

Link to comment
Share on other sites

Tja, helt säker är jag ju inte, men jag kan inte se några skräptecken i databasen (SQL Server) och de brukar ju synas som fyrkanter.

 

<pre><%response.Write("Annan=&lt;" & rs4("Annan") & "&gt;<br>")%> </pre>

 

i koden ger följande i html

 

Annan=&lt;test&gt;<br>

 

Lade till <> för att få värdet omslutet av något så att jag inte missade ev tecken i slutet.

 

Men det verkar ev som att det kan vara tabbar och inte mellanslag som ligger före i textarean, de kanske inte syns på något vis?

 

 

 

Link to comment
Share on other sites

Magnus Ahlkvist

Även tabbar borde synas inom dina pre-taggar, så det är det nog inte.

Om det är mellanslag i databasfältet så visas de inte som skräptecken, men däremot borde mellanslagen synas när du öppnar tabellen i Enterprise Manager eller Query Analyzer.

Vet faktiskt inte vad felet kan tänkas bero på.

 

--

Snäll ibland. Rättvis nästan jämt. Elak för det mesta.

 

Link to comment
Share on other sites

Jösses Amalia, jag gjorde en exakt kopia av textarean och där visas texten som den ska. Suck, sådana här fel gillar jag inte, men nu funkar det i alla fall.

 

Tack för ditt engagemang!

 

Link to comment
Share on other sites

Magnus Ahlkvist

Very strange indeed :)

Bra att det löste sig dock.

--

Snäll ibland. Rättvis nästan jämt. Elak för det mesta.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...