Just nu i M3-nätverket
Jump to content

Problem med SSH och/eller SSHD


Prophecy

Recommended Posts

Jag har efter att ha provat med tre olika distar lyckats installera Linux för första gången. Jag kör nu Ubuntu som hittills har fungerat klockrent. Problemet är att jag inte lyckas få igång en ssh-server ordentligt. Jag har kört apt-get install ssh för att ladda ner den och det verkade fungera.

Om jag kör ssh localhost så lyckas jag ansluta, men inte om jag ansluter från en annan windows-dator i nätverket. Jag har provat att ssh:a från en unix-dator, men samma problem uppstår, jag får ett meddelande som säger:

 

 

warning: Authentication failed.

Disconnected; no more authentication methods available (No further authentication methods available.).

 

Vad ska jag göra?

 

/Johan

 

Link to comment
Share on other sites

Vad ska jag göra?
Kika i sshd.conf eller pam.d beroende på hur ditt system ser ut. Förmodligen är det nyckelbaserad authentisering som sshd-servern vill ha.

 

 

.dune.

----------------------------------------------

- "I find this a nice feature but it is not according to the documentation.

Or is it a BUG?"

- "Let´s call it an accidental feature. :-)"

 

Link to comment
Share on other sites

Min sshd_config ser ut så här, jag vet inte vad som är korrekt.

 

# Authentication:

LoginGraceTime 600

PermitRootLogin yes

StrictModes yes

 

RSAAuthentication yes

PubkeyAuthentication yes

#AuthorizedKeysFile %h/.ssh/authorized_keys

 

# Don't read the user's ~/.rhosts and ~/.shosts files

IgnoreRhosts yes

# For this to work you will also need host keys in /etc/ssh_known_hosts

RhostsRSAAuthentication no

# similar for protocol version 2

HostbasedAuthentication no

# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication

#IgnoreUserKnownHosts yes

 

# To enable empty passwords, change to yes (NOT RECOMMENDED)

PermitEmptyPasswords no

 

# Change to no to disable s/key passwords

#ChallengeResponseAuthentication yes

 

# Change to yes to enable tunnelled clear text passwords

PasswordAuthentication no

 

 

/Johan

 

Link to comment
Share on other sites

Du har ett par val. Antingen så använder du dig av nycklar eller av lösenord. Vi tar det lätta först:

 

Vill du använda dig av lösenord så ändrar du PasswordAuthentication till 'yes'.

 

Vill du använda dig av nycklar så måste du generera en nyckel med ssh-keygen och sedan lägga in den publika nyckeln i ~/.ssh/authorized_keys och ladda den privata nyckeln på din workstation som du vill ansluta ifrån.

 

Jobbar du från windows så finns puttys motsvarighet till ssh-keygen på samma sida.

 

 

.dune.

----------------------------------------------

- "I find this a nice feature but it is not according to the documentation.

Or is it a BUG?"

- "Let´s call it an accidental feature. :-)"

 

Link to comment
Share on other sites

Jag skulle börja med att titta i /var/log/messages och se vad den säger när det misslyckas.

Får du inte ut något vettigt av det så kan det kanske vara värt att lägga in en "LogLevel DEBUG" i config-filen och se om man får ut något mer om vad som händer.

 

PermitRootLogin yes

Ovanstående bör du kanske fundera på, det är i allmänhet bara en onödig risk.

 

Edit: Det första man blir blind på är ögonen, såg inte "PasswordAuthentication no"

[inlägget ändrat 2005-01-18 17:09:00 av fhe]

Link to comment
Share on other sites

Nu fungerar det, tack för det! *poäng*

 

En annan fråga, det finns ju en inbyggd vnc-klient, men det verkar inte finnas någon vnc-server, kan man installera det med apt-get? Vart hittar man de tillgängliga apt-get paketen?

 

/Johan

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...