Just nu i M3-nätverket
Jump to content

Mac och nätvärk


mhe

Recommended Posts

Upgraderade ett nätverk (3 Mac 2 NT, några skrivare) tidigare var det 10mbit BNC, nu är det switchat 10/100, saken är den att jag får ingen fart att tala om, runt 1.2mb/s (aldrig över, normalt sett mindre) hemma där jag kör PC (W98)får jag mellan 2.7mbs > 5mbs. T.om P133/64MB/linux servern levererar 5mbs... Vad har

 

ni för överföringshastigheter är min fråga? Och kan man finjustera nånting?

 

Korten är Farallon, maskinerna är PPC 300Mhz, 604E Processor.

 

/mhe

Link to comment
Share on other sites

Alltså, det som upgraderades var på en firma, det jag skrev i slutet var mitt nätverk hemma, där är det linux som är server, på jobbet vare NT som va server.

 

/mhe

Link to comment
Share on other sites

 

 

 

hi! :-}

 

svårt att svara på det direkt vilken typ av switch använder du? En varjant (av många)som skulle kunna göra sussen är en sådan med "non blocking arcitektur" och "autosense" separat för varje port. Då kan du undvika att flaskhalsarna påverkar hela nätverket.

Om din switch inte har dessa, behöver du kolla nätverkskort i alla enheter (tipps skrivare) och hitta flaskhalsen. (kort med 10baseT) För den "switchar ner" hela nätverket till sin egen hastighet.

 

Link to comment
Share on other sites

Vilken typ av switch, det är 10/100 autosensing Netgear från dustin, 8 ports, är absolut inget fel på den, går mkt snabbare hemma med samma switch.

 

Nånting i Macarna är fel, kort? Farallon från MacWarehouse, Macarna är 300Mhz 604E med snabba SCSI diskar, får 1200kbs hur ja än gör.

 

Vad får folk för hastigheter på sina Mac 100mbit nätverk?

 

 

Link to comment
Share on other sites

hi! :-}

Misstänker kort i macen (hemma har du kanske bara 10/100 kort) kolla om ngn av de kan användas i macen (tillverkarenshem sida) och testa. Här gäller piller göra. Föresten kör du ren TCP/IP eller med apple share? -vilket är långsammare oavsätt korten

Link to comment
Share on other sites

Alla kort är upgraderade till 100mbit (Farallon), är inte det som är felet. Och jag har provat både att föra över filer med FTP, och med AppleShare, ingen skillnad.

Link to comment
Share on other sites

Henrik K Olofgörs

Det är knappast korten, har aldrig haft problem med farallon (omöjligt är det dock inte).

Ladda hem något diagnostikverktyg och låt dem börja pinga ihjäl varandra. Jag var med och problemsköt ett nätverk (blandat Mac/PC på ett ekonomiföretag) för ett tag sedan, och vi kunde genom att pinga från NT och via ett ethernet-tool för Mac (kommer tyvärr inte ihåg namnet) nåla ner problemet till en trubblande switch och en NT-burk med fel protokollinställningar.

Link to comment
Share on other sites

Switchen är det inga som helst fel på, har haft den hemma och använt den, fått 5-7MB/s. NT burkarna kan jag ju rycka ur switchen, dom sköter ändå inga direkta Mac beroende services (nån utdelning bara) så jag tror inte att det är det heller.

 

Men alla är 110% säkra på att en 300Mhz 604E PPC med sys 8.1 och SCSI diskar ska ge mer än 1.2MB/s? Så man inte sitter och trampar vatten.

Nån nätverks konsult (är inte alla det?) påstod att system bussen (FSB) skulle ha nåt enormt med just den här saken att göra och att det skulle vara därför, detta verkar för mig väldigt främmande eftersom en 133Mhz gammal Pentium ger mig 5MB/s.

 

/mhe

Link to comment
Share on other sites

Henrik K Olofgörs

Som sagt, låt dem pinga ihjäl varandra. Vi kan diskutera tänkbara scenarier hur mycket som helst, men du behöver ju en lösning, eller hur?

Och ja, 1.2Mb/sek är alldeles för lågt, på tok för lågt. Det sitter en flaskhals någonstans, alternativt protokollstrypning eller (katastrof) inkompatibilitet.

Link to comment
Share on other sites

Eftersom detta är rena grekiskan för mig ville jag tipsa om en bra länk som har MASSOR med info om Mac och PC i nätverk. Kan nästan garantera att problemet som ni pratar om finns omnämnt:

http://www.macwindows.com/

 

Lycka till!

 

 

/Petra

Link to comment
Share on other sites

det handlar knappas om problem ivanlig mening endast kapacitet, farlon har många olika kort med olika kapasitet. Gäller kanske att bytta uppsig.

 

 

hi! :-}

Link to comment
Share on other sites

Normalt så har varken scsi, dators prestanda normalt med dataöverföringen över nätet att göra ändast indirekt. Nästan allt ren överföring data layer och nätvetks layer i OSI modellen har med NIC´s prestanda i förhållande till alla noder på väggen till mottagarens nic normalt är alla datorers inre kommunikation mycket snabbare än nätverkskortet, du kan alltså ha en pentium 100MHz snabbare till en annan likadan bara om du har en vass kort till fast ethernet/ egen cache/ egen prosessor osv det finns hur komplicerade kort som hälst. Tyvärr så är inte macar kända att ha vassa sådana inbyggda from början farlon eller ej alla tillverkare har uppsjö av kort i olika pris klasser upp till 3/4tusen styck.

 

hi! :-}

Link to comment
Share on other sites

Har du kollat de väldigt praktiska omständigheterna?

 

Det finns ingen nätadapter som kan ge för låg spänning till switch/hubb eller liknande? Bara någon liten försämring kan ge oförklarliga tillstånd?

Har du testat de tre macarna i nätverket var för sig? dvs bara en inkopplad åt gången?

 

Det finns inga kablar som kan ha blivit fel?

 

 

Kan tyckas enkelt, men inte så sällan är det ju sådana idiotproblem som ställer till det.

 

 

Thomas

Link to comment
Share on other sites

Först och främst: jitex:

"alla tillverkare har uppsjö av kort i olika pris klasser upp till 3/4tusen styck."

 

Jo det måhända att dom har billigare/dyrare kort, men ofta skiljer det inte så mkt i hastighet utan diverse andra saker t.ex kryptering eller övervakning/avbelastning av CPU, också givetvis märke/status kostnaden för t.ex 3Com. Jag provade lite mer hemma nu. Det gjorde en väldig skilnad att använda UDMA, fick som max 6.5MB/s, på ett D-Link 500TX, 250 spänn eller så.

 

Nåväl.

 

Provade lite mer på jobbet också, jackade ut alla eventuella stör moment, endast 2 mac inkopplade, samma speed 1.2MBs~

 

Thomas:

Jag har kollat så mkt jag hunnit, spänningen tror jag nog är rätt, annars skulle nog allt möjligt strula, kablarna litar jag på dom är rätt, dom är ju maskinproducerade (köpt från dustin).

Allt verkar rätt.. Är övertygad till 99% att det är NÅNting i Macen, Mjukvara/Hårdvara som gör problemet, men har ingen aning exakt vad det kan vara.

 

Det finns inga andra TCP/IP drivrutiner? Behöver kanske nytt system?

Det finns ingen möjlighet att boota på t.ex MacOSX (från CD) och bara göra en test därifrån.. jag vet inte...

 

Help me out here ;)

 

/mhe

Link to comment
Share on other sites

 

 

 

hi! :-}

Skillnader kan vara större än du tror. Har testat två olika 10/100 kort med eller utan cache tex eller med eller utan bios på kortet det göt väsentlig skillnad och stor del av brodkasting kan undvikas vilket gör nätverket piggare. Men det tror jag inte är svåret här.

 

några tipps är:

är alla kort hemma 10/100baseT ?

är alla kablar kat 5 TP ?

har switch autosensing separat på varje port?

 

(om på jobbet är alla kort 10/100 så växlar switchen till den högsta möjliga på alla portar samtidigt därför får du rätt hastighet utan problem, om du har hemma ett kort som är enbart 10baseT så växlar switchen till den hastighet för hela nätverket -om den inte har separat autosensing för varje port)

 

Om den har utosensing på varje port får du snabb överföring till de noder som är snabba och långsam till den noden som är långsam. Alltså olika hastigheter i olika delar av nätverket.

 

Angående kablarna för att förbättra hastigheten i snabba nätverk måste utp kat 5 100Mhz kabel eller högre användas i hela nätverket bäst är att ha samma hastighet på alla kablar. Det vet man oftast vi köp tillfälle om det inte står på kabeln. Det skiller inte mycket mellan tillverkare.

Hoppas det löste något.

 

Vill du prata mer vällkommen på ICQ.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...