Just nu i M3-nätverket
Jump to content

Accessdatabas över ett nätverk


carina-e

Recommended Posts

Jag har byggt en databas i access som jag nu vill lägga i ett nätverk. En lösning är att skapa runtime-applikation som installeras lokalt på varje dator i nätverket. Jag har skapat detta med hjälp av Packaging Wizard som finns i Office XP Developer. Problemet som nu uppstått är att jag har separerat tabeller med resten (formulär, frågor och VB-kod) genom att använda Länkhanteraren som finns i Access. Denna är hårdlänkad och länkar till en databasfil som ligger lokalt på min dator. När jag då installerar runtime-app. på varje dator går det visserligen att öppna databasen men utan tabeller eftersom länken inte längre fungerar. Hur gör jag för att komma åt och redigera datat inom paketet? Något som också är viktigt är att jag ska kunna modifiera data och tabeller och vad jag förstår kan man inte göra detta från en runtime-applikation. Finns det någon annan lösning för att få det att fungera? Kan man skapa en nätverksinstallation utan runtime?

 

Det bästa vore om jag direkt kunde lägga databasfilerna på en nätverksplats men problemet är att jag då får felmeddelandet:

Filen ligger utanför intranätet eller på en plats som inte är tillförlitlig. Filen öppnas inte med Microsoft Access på grund av eventuella säkerhetsproblem. Om du vill öppna filen kopierar du den till den lokala datorn eller till en nätverksplats som går att komma åt.

Kan någon ge mig ett tips på hur jag löser detta med runtime eller gärna med en alternativ lösning, utan runtime?

 

Tack på förhand!

 

/Carina

 

 

[inlägget ändrat 2004-10-29 13:40:54 av carina-e]

Link to comment
Share on other sites

Länken kan du hantera programmässigt. Finns exempel i modelldatabasen som kommer med Access.

Denna kod kör lämpligast vid öppning av databasen då huvudformuläret öppnas. Du har en event i formuläret som anropar kodsnutten.

 

Samma grej fungerar både med runtime och utan runtime.

 

Varför du får felmeddelandet med nätverksplatsen kan jag inte tipsa dig om - tyvärr. Har inte stött på ett dyligt problem tidigare.

 

Kan det vara att du lagt databasen på en webserver eller något dyligt.

 

Har du databasen på servern och i intern bruk borde du inte få dylika meddelanden. Har själv gjort dylika applikationer utan problem.

 

Hur startar du upp applikatioen?

I paketeraren kan du ange start parametrarna för applikationen. Är de ok?

Kolla vad du har för inställningar när du gör paketet som med developer versionen. Är alla sökvägar ok?

BI

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...