Just nu i M3-nätverket
Jump to content

Internet försvann med DI-704P


PAK

Recommended Posts

Mitt problem känns på intet vis unikt men hur jag än letat har jag inte kunnat en lösning...

 

Jag har under lång tid haft istream (Bostream) och 1 dator ansluten till internet via Speedtouch 510 (1 anslutning...). Och aldrig haft problem!

 

Nu tänkte jag koppla in 3 datorer lokalt i ett LAN, vilka samtliga skall kunna komma åt internet, varför jag köpte en D-Link DI-704D. Efter inkoppling av 510:an på WAN-porten och datorerna på LAN-portarna, ser lamporna ut att fungera på både 510:an och 704D. Men jag kan inte pinga 510:an från någon dator, än mindre komma ut på internet...

 

Finns det någon som haft samma problem och kan tala om hur han/hon gjorde? Eller kanske tipsa om nån länk jag missat...!?

 

 

Link to comment
Share on other sites

Nu kommer det en massa antaganden eftersom jag inte har någon del av din utrustning.

 

Du skriver att du skall pinga ditt ADSL-modem. Om du har kunnat pinga den tidigare, med en dator ansluten, så betyder det att modemet måste ha en ip-adress, och mao fungera som en router.

 

Vilken ip-adress fick du tidigare (med en dator)? Om den var i adressrymden 192.168.0.X så kommer det inte att fungera, eftersom det är exakt de adresserna som DLinken delar ut.

 

Jag ser tre alternativ (om ADSL-modemet har NAT-funktionalitet):

 

1. Sälj tillbaka 704:an och köp en vanlig billig switch.

2. Konfigurera om 510:an till att köra bridged mode. --> 704:an blir då din NAT-router

3. Byt adressrymd som 704:an delar ut (anv. t.ex 10.0.0.X , eller ett annat C-nät i 192.168.X.X intervallet.)

 

 

==Coleburn==

 

--------------------

"It takes a lot of knowledge to

really mess something up!"

 

Link to comment
Share on other sites

Jo, du har rätt i ditt antagande att modemet fungerar som en router. Tidigare fick den IP-adressen 192.168.0.254 och via DHCP delades sedan IP-adressen ut till datorn, 192.168.0.1.

 

Och du har också rätt i ditt antagande att DI-704P delar ut adresser i samma C-nät, 192.168.0.X.

 

Det var ytterst intressant det du skrev att detta inte var tillåtet. Och detta gäller då även om modemets DHCP kopplas bort så att DI-704P får sköta utdelningen av IP-adresser?

 

Angående dina 3 alternativ, så är tyvärr inte alt 1 möjligt längre, utan alt 3 får bli det som används.

 

Äntligen har jag fått en ren felaktighet utpekad, vilket kan jobbas vidare med! (Tyvärr var det inte så enkelt som att enbart byta C-nät på DI-704P och sen funkade allt...)

 

Link to comment
Share on other sites

Det var ytterst intressant det du skrev att detta inte var tillåtet. Och detta gäller då även om modemets DHCP kopplas bort så att DI-704P får sköta utdelningen av IP-adresser?

 

Detta är exakt vad alt. 2 innebär. Att koppla bort all DHCP på 510:an (både DHCP klient, och DCHP server) innebär att den bara signar på ATM kanalen, och bryggar (bridged mode), vidare all iptrafik. 704:an kommer mao att få sin yttre adress tilldelad direkt av din ISP, på samma sätt som 510:an får i dagsläget.

 

Ställ m.a.o in 510:an i bridged mode, så kommer allt att funka!

 

 

==Coleburn==

 

--------------------

"It takes a lot of knowledge to

really mess something up!"

 

Link to comment
Share on other sites

OK, alt 2 får det tydligen bli då...

 

Jag antar att "bridged mode" betyder att även DNS skall kopplas bort (tillsammans med DHCP-klienten/servern).

 

Skall det "bryggade" modemet då anslutas till WAN-porten på DI-704P? Kommer DI-704P då verkligan att se modemet, så det kan få en IP-adress?

 

Kan du tipsa om var jag hittar info om hur man ställer 510:an i bridged mode?

 

Du skall ha tack för din hjälp hittills!!!

 

[inlägget ändrat 2004-08-10 19:51:22 av PAK]

Link to comment
Share on other sites

Problemet löst genom att ST510 fick subnät 192.168.0.X medan DI-704P fick 192.168.1.Y. Dessutom sattes WAN-sidan på DI-704P till Dynamisk IP-Adress istf PPPoE som jag hade innan. Och sedan fungerade det perfekt!

 

Men stort tack till Coleburn som fick mig på rätt spår!!!

 

Link to comment
Share on other sites

Bra att du fick det fixat, även om det inte är ett perfekt upplägg att köra dubbla adressöversättningar efter varandra.

 

Som svar på frågan i ditt förra inlägg:

Om du kör 510:an bryggad, så betyder det att den inte syns alls. Enkelt sagt så kopplar den endast upp en fysisk förbindelse mellan din internetleverantör och din 704. 704:an får alltså WAN-adressen direkt från leverantörn, och delar sedan ut privata adresser på LAN-sidan.

 

 

==Coleburn==

 

--------------------

"It takes a lot of knowledge to

really mess something up!"

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...