Just nu i M3-nätverket
Gå till innehåll

Christian Eriksson

Medlem
  • Antal inlägg

    86
  • Gick med

  • Senaste besök

Om Christian Eriksson

  • Medlemstitel
    Användare
  1. Vad menar du med förinstallationsverktyg? Fdisk och format eller?
  2. Jag kör remote shell (rsh) från UNIX mot Windows. Från UNIX-maskinen kör jag "rsh <host> -l <user> command.com /k set". Problemet är att jag inte får tillbaka utdatat från dos-kommandot till UNIX. Läste därför hjälpen till command.com (command /?) där syntaxen är som följer: COMMAND [[enhet:]sökväg] [enhet] [/E:nnnnn] [/L:nnnn] [/u:nnn] [/P] [/MSG] [/LOW] [/Y [/[CK] kommando]] Hoppet står nu till argument nr 2 [enhet] som beskrivs: "Anger den enhet som ska användas för indata och utdata". Hur styr jag utdatat till UNIX? PS. Jag har en Inetd-demon (Maestro-NFS) installerad på windows som svarar på rsh-kommandot från UNIX. DS. [inlägget ändrat 2000-09-04 13:37:31 av Christian Eriksson] [inlägget ändrat 2000-09-04 13:38:49 av Christian Eriksson]
  3. Ett alternativ till DOS fdisk är gdisk från symantec. Finns att hämta på http://shop.symantec.com/cgi-bin/trialware/Core/Core.pl?REGION=na&LANGUAGE=english&PFT=908229474&INDEX=1&KDATA=910624210-1951637316 Med gdisk kan du göra två saker som inte går med DOS fdisk: 1. Skapa fler än en primär DOS-partition 2. Gömma partitioner (status: hidden) ".... bootar om med DOS startdiskett så bör jag väl kunna skapa en primär FAT32 partition efter /boot". Borde gå tycker jag! Har du provat nu? Du kan skapa en extended DOS partition där du kan lägga /swap, /home, /usr, /usr/local samt logisk FAT32 för Win98 4 GB. På så vis borde du klara dig inom 4-partitionsgränsen.
  4. OK! Kan du kanske beskriva hur du använder tar för att backa en hel disk! Backar du alltså filsystem för filsystem?
  5. Meningen är att jag ska kunna backa hela diskar, med flera olika system på (ex. Windows 95, Linux), med ett kommando. Om jag har förstått det hela rätt så kan jag väl inte använda tar med en device-fil som andra argument (ex. tar cvf /dev/npt0 /dev/hdb). Rätta mig om jag har fel!
  6. Disk /dev/hda: 255 heads, 63 sectors, 525 cylinders Units = cylinders of 16065 * 512 bytes Device Boot Start End Blocks Id System /dev/hda1 1 58 465853+ 16 Hidden FAT16 /dev/hda2 * 225 269 361462+ 83 Linux /dev/hda3 270 525 2056320 5 Extended /dev/hda4 59 224 1333395 6 FAT16 /dev/hda5 270 346 618471 83 Linux /dev/hda6 347 385 313236 83 Linux /dev/hda7 386 393 64228+ 82 Linux swap /dev/hda8 394 525 1060258+ 6 FAT16 Det jag tycker är ologiskt är att "devicen" (hdaX) inte får ordningsnummer (X) efter vilken ordning partitionerna ligger i cylindermässigt. Har dock inte läst någon dokumentation som beskriver det här på ett tag! Kanske finns det någon förklaring där.
  7. Hej! Jag har testat lite backuper i helgen. Bl a backade jag min (primary slave) drive från RedHat 6.0 med dd [root@dator1 /root]# dd if=/dev/hdb of=/dev/npt0 2504880+0 records in 2504880+0 records out Sedan återtog (recover) jag en annan backup (windows95-system) till min "primary slave"-disk, med en helt annan metod än dd, och det gick bra. Jag flyttade disken till primary master och körde lite windows 95 för att se att allt fungerade. Därefter ville jag ha tillbaka det ursprungliga systemet (Solaris 7) till disken. Försökte därför med [root@dator1 /root]# dd if=/dev/pt0 of=/dev/hdb 0+0 records in 0+0 records out (Jag hade flyttat tillbaks disken till primary slave igen!) Som ni ser så misslyckades det hela. Är det kört eller kan någon hjälpa mig här? Min bandstation är en HP Colorado 14GBe ansluten till paralellporten.
  8. Från kommandot dmesg "greppar" jag ut avsnittet Partition Check: hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 > hda4 hdb: hdb1 I windows 95 kollar jag partitionstabellen för hårddisk 1 med gdisk: Disk Partitions Cylinders Heads Sectors Mbytes 1 8 8940 15 63 4125.1 Partition Status Type Volume Label Mbytes System Usage 1 H PRI DOS MS-DOS6_20 454.9 FAT16 11% C: 2 PRI DOS WINDOWS95 1302.1 FAT16 32% 3 A LINUX 353.0 EXT2FS 9% 4 EXT DOS 2008.1 49% 5 LINUX 604.0 EXT2FS 15% 6 LINUX 305.9 EXT2FS 7% 7 LINUX SWAP 62.7 2% D: 8 LOG DOS WINDOWS95 1035.4 FAT16 25% Jag har alltså linux root-partition på partition 3. Borde vara hda3 om man jämför med Partition Check från dmesg. Ändå ser lilo.conf ut så här: boot = /dev/hda2 ..... image=/boot/vmlinuz-2.2.5-15 label=linux root=/dev/hda2 read-only other = /dev/hda1 label=MsDos6.22 table=/dev/hda other = /dev/hda4 label = Windows95 table=/dev/hda .... Jag får det inte att hänga ihop mellan dmesg och lilo.conf. Tycker det borde vara boot=/dev/hda3, root=/dev/hda3 för label=linux och other=/dev/hda2 för label=Windows95 i lilo.conf. Jag kör RH 6.0 och har lilo installerat i den aktiva partitionen.
  9. Det finns många paket med "kernel" i namnet på distributions-CDn. Är det paketet som heter något med "kernel-source", i mitt fall kernel-source-2.2.5-15.i386.rpm, som jag ska installera?
  10. Är ny på området kompilera kärnan! Passar på att fråga en detalj i den här tråden. Vad ska finnas under /usr/src/linux för att "make xconfig" resp. "make menuconfig" ska fungera? Jag har endast biblioteket include och filen README.kernel-sources på den platsen. Är det tillräckligt? (Undrar beroende på den lite svårtolkade varningstexten i README.kernel-sources!)
  11. Hallå! Har problem med modemuppkopplingen (PPP) under Red Hat 6.0. Det går jämförelsevis mycket snabbare att surfa med windows 95 gentemot RH 6.0 för närvarande på samma dator. Måste bero på att jag har några felaktiga inställningar någonstans i linux. Jag har "linespeed" satt till 115200 och "Modem Port" till /dev/modem i Network Configurator (ganska osmidigt verktyg!). Kanske jag bör ändra något vad gäller serieporten? Var gjorde man det nu igen? Tacksam för hjälp!
  12. Jaha, då var jag fel ute här! Har inte KDE installerat överhuvudtaget. Får kika efter det på RedHat 5.2-CDn istället. Behövs det en uppgraderings-installation av linux eller räcker det med att lägga till ett paket för att få en ny fönsterhanterare?
  13. Hallå! Är det någon som har installerat KDE från StarOffice(5.1)-CD:n? Det verkar nämligen ligga något install-skript för KDE på den men jag har misslyckats med att köra det. Tydligen ger jag fel argument till skriptet! Någon som vet vilka värden som ska skickas med?
  14. Dumt att jag skrev det där med uppdatera manuellt när jag inte har någon "färdig" "Device-sektion" för mitt nuvarande grafikkort och inte vet vilken information jag ska ange i en sådan. Kan någon kanske säga något om hur Xservern (XF86_Mach64 i mitt fall) använder sig av "Device"-sektionen i XF86Config-filen. Undrar för att i nuläget ser den jag använder ut som bifogat längre ned. Där anges ett helt annat grafikkort än det jag använder. Har jag sämre grafikprestanda i o m detta? # Device configured by xf86config: Section "Device" Identifier "2 the Max MAXColor S3 Trio64V+" VendorName "Unknown" BoardName "Unknown" #VideoRam 1024 # Use Option "nolinear" if the server doesn't start up correctly # (this avoids the linear framebuffer probe). If that fails try # option "nomemaccess". # # Refer to /usr/X11R6/lib/doc/README.S3, and the XF86_S3 man page. # Insert Clocks lines here if appropriate EndSection
  15. Nu börjar det likna något! Kör för närvarande med ett pixeldjup på 16 bitar med upplösningen 800x600. Frågan är om jag inte körde på 8 bitar tidigare. Hade ingen "DefaultColorDepth" angiven och då togs nog värde från min första subsection som anger Depth till 8. För drivern "accel" har jag fyra subsectioner (med depth 8, 16, 24 och 32 i den ordningen). Provade även med DefaultColorDepth 24 men då accepterade inte Xservern upplösningen 800x600 utan valde en virtuell skärm på 600x480. Är det viktigt att den "Screen Section" som används pekar ut rätt Device. I den sektion som används står fortfarande mitt förra grafikkort angivet. Uppdaterar jag det manuellt eller ska jag köra något kommando? Kanske "Xconfigurator --expert"! Så här ser använd "Screen section" ut för närvarande: Section "Screen" Driver "accel" Device "2 the Max MAXColor S3 Trio64V+" Monitor "Daewoo" DefaultColorDepth 16 Subsection "Display" Depth 8 Modes "800x600" "640x480" "640x400" ViewPort 0 0 EndSubsection Subsection "Display" Depth 16 Modes "800x600" "640x480" "640x400" ViewPort 0 0 EndSubsection Subsection "Display" Depth 24 Modes "800x600" "640x480" "640x400" ViewPort 0 0 EndSubsection Subsection "Display" Depth 32 Modes "640x400" ViewPort 0 0 EndSubsection Till sist: tack för hjälpen!
×
×
  • Skapa nytt...