Just nu i M3-nätverket
Gå till innehåll

short

Medlem
  • Antal inlägg

    136
  • Gick med

  • Senaste besök

Allt postat av short

  1. Ska jag försöka avinstallera Officepaketet och sedan installera det igen? Reparationsalternativet verkar inte ge önskad effekt.
  2. Nej till höger har du fältlistan vilket INTE jag får fram. Jag får bara fram den ruta du har längst till vänster.
  3. Jag hade tidigare Office XP Standard. Det jag har nu är inte en starter-version. Jag gör precis som du men när Pivottabellen skapas kommer det inte fram någon Fältlista och det går heller inte att klicka på visa Fältlista.
  4. Sist jag gjorde en pivottabell hade jag en annan version av Excel. Nu har jag "Office Hem och Student 2010". När jag ska skapa en Pivottabell kommer inte fältlistan fram och den går heller inte att klicka i under visa uppe till höger i rubriken. Innebär detta att jag inte kan göra Pivottabeller med min version eller går det att fixa till?
  5. Det är svårt med beskrivningar. Alltså ett viktigt påpekande är att felet bara uppträder när man får ett mail med arbetsboken. När man öppnar arbetsboken så är makrona inaktiverade. När man aktiverar makrona så PANG då kommer felet. Trycker man på avslutar så kan man arbeta i arbetsboken och om man sparar den och öppnar den igen så går allt bra utan felrapporter (man behöver då inte aktivera makrona eftersom de redan är aktiverade).
  6. Lägger jag in "ActiveWorkbook.Unprotect Lösen, True" i början får jag felmeddelandet "Fel antal argument eller felaktig egenskapstilldelning"
  7. Ja boken är låst när koden startas. Jag har låskommandot för att försäkra mig om detta (det finns kanske bättre sätt) Alla blad där .activate anges är synliga
  8. Gör jag så kommer felmeddelandet på .activate istället. Det verkar som om det ursprungliga felmeddelandet kommer på Sheets("Utskrift").Protect Lösen Tar man bort denna instruktion kommer felmeddelandet på de efterföljande select-satserna. Felmeddelandet kommer för övrigt endast då man aktiverar makron i en arbetsbok som sänts med mail. När man en gång öppnat det och tryckt på fortsätt samt sparat arbetsboken i datorn kan man öppna arbetsboken utan några felmeddelandet. Väldigt konstigt tycker jag.
  9. Private Sub Workbook_Open() Dim Flik As String Dim r As Integer Dim Reg As String Application.ScreenUpdating = False Worksheets("Start").ScrollArea = "a1:s34" Worksheets("Innehåll").ScrollArea = "a1:r1000" Worksheets("Personuppgiftsansvarig").ScrollArea = "a1:q33" Sheets("Start").Protect Lösen Sheets("Personuppgiftsansvarig").Protect Lösen Sheets("Innehåll").Protect Lösen Sheets("Manual").Protect Lösen Sheets("Utskrift").Protect Lösen ActiveWorkbook.Protect Lösen, True Sheets("Start").Select Range("A1").Select Application.ScreenUpdating = True End Sub Jag får felmeddelandet "Objektvariabel eller With-blockvariabel har inte angetts" när jag öppnar arbetsbok med ovanstående kod. Varför?? Trycker jag sedan på avsluta kan jag köra programmet utan problem.
  10. Riktigt smart!! Jag gjorde ett Userform med bl a ett textfält där jag skriver meddelandet. Jag styr sedan användaren genom att enabled skiftar på knapparna så att användarnas åtgärderna kommer i rätt ordning. Excel har sina egendomligheter och det är en skön konst att gå runt svårigheterna.
  11. CDO verkar ju smart under förutsättning att alla mail skickas från en erfaren användare. Man ska ju ange servern i koden. I min tillämpning är det många mindre erfarna användare som inte ens vet att det finns ett program och aldrig skulle klara av att skriva in ett servernamn. Då blir det nog lättare att klicka på det blinkande fönstret så att MsgBoxen kommer upp.
  12. Windows Live Mail 2011. Programmet både startar och sänder mailet. Problemet ligger när denna operation är klar. Ska testa CDO i kväll. Ska också testa det befintliga programmet på min frus dator då för att se om felet ligger i min dator.
  13. Tyvärr är det fortfarande en gåta trots noggrann läsning. Koden fastnar direkt efter sendmail, symbolen nedtill i datorfönstret börjar blicka och koden kommer igång först efter manuell klick. Lägga in wait, select, activate hjälper inte. SendMail kräver inget svar utan de argument som krävs har jag lämnat (till och ämne).
  14. Jag har redan försökt. Jag har skrivit ett jättekort program som bifogas. Sub nn() Namn = ActiveWorkbook.Name Application.Dialogs(xlDialogSendMail).Show arg1:=Till, arg2:=Ämne Workbooks(Namn).Activate MsgBox "Hallå" End Sub Även här kommer inte MsgBox fram innan man klickat på sidan. Jag har försökt med att köra select på sidan eller på en range på sidan men inget hjälper.
  15. Det verkar vara send.mail instruktionen som ställer till det Jag har prövat bara den och MsgBox och då kommer inte MsgBox fram
  16. Jag har ett program som slutar så här: Application.ScreenUpdating = True MsgBox ("Körningen klar!") MsgBoxen kommer dock inte fram innan man klickat på sidan. Jag har försökt med fördröjning mm men inget fungerar. Finns det något ja kan göra för att MsgBoxen ska komma fram utan att man klickar på sidan? Jag har tidigare i programmet skapat en ny arbetsbok och använt Application.Dialogs(xlDialogSendMail).Show arg1:=Till, arg2:=Ämne men kontrollen har gått tillbaka till den aktuella arbetsboken.
  17. Så vitt jag kan förstå kan man skriva ut ett UserForm med kommandot PrintForm. Jag får dock inte ut hela formuläret utan bara den sista biten. Jag har ett ganska stort UserForm. Finns det något sätt att få ut alltsammans?
  18. Till slut hittade jag något som fungerar. Det visade sig att TextBox1.FontSize=10 var ett slag i luften för fontstorleken var inte ändrad i egenskaperna bara för ögat. När jag satte TextBox1.Enabled=False och sedan True fungerade det utan att texten blev liten. Två frågor kvarstår: 1.Jag har ingen TextBox bland mina formulärkontroller. Finns det? 2. Är ActiveX lika instabila om de läggs på en UserForm
  19. Ja nu har jag prövat med allt men inget hjälper. Till sist skapade jag ett nytt dokument med textboxar i Excel 365 (inte 2013 som jag tidigare skrev). Programmet är en Trialversion som man får gratis för att pröva en tid. Resultatet blev där detsamma dvs texten förvandlades ibland till mikroskrift. Beror detta månne på att det är en Trialversion eller är det en bugg i programmet. Jag har faktiskt hittat en äkta bugg i Excel tidigare och då blev det fart på Microsoft.
  20. I versionen Excel 97 2003 så hade jag formulärtextrutor. Det var ett av de första programmen jag gjorde. Senare har jag helt gått över till ActiveX kontroller. Jag bytte helt enkelt ut några provrutor till ActiveX TextBoxar och då får jag inte problemet när jag senare kör i Excel 2013. Nu ska jag ändra alla textrutor vilket tar någon dag och så får vi se om det dyker upp några andra problem
  21. Mitt försök att lägga in litet kod som återställde Font-storleken fungerade inte. Jag funderar på att följa ditt råd och flytta över sidorna och koden från Excel 97 2003 till Excel 2013. Om man sedan kör en arbetsbok 2013 Excel på en äldre version så får vi se om det fungerar. Jag har ju inte använt några nya tricks som finns i Excel 2013. Har du någon erfarenhet om liknande "bakåtkörning"?
  22. Tyvärr är det mycket jobb att skriva om och dessutom vill jag helst att samma version ska fungera oberoende av vilken version av Excel användaren har. Som ett första försök ska jag testa med detta Private Sub TextBox1_GotFocus() ActiveSheet.TextBox1.FontSize = 15 End Sub Kanske inte snyggt men vad gör man....
×
×
  • Skapa nytt...