Just nu i M3-nätverket
Gå till innehåll

MvS

Medlem
  • Antal inlägg

    134
  • Gick med

  • Senaste besök

Allt postat av MvS

  1. Tack Monshi! Jag rör mig just nu i ett okänt rum och försöker höja mitt kunskapstak bit för bit! Eftersom jag har jobbat en del med Access där man helt enkelt pekar en kontrolls egenskap mot ett fält i en tabell så måste jag skruva om lite i tänket här. Vad använder jag för variabeltyp om jag tex vill söka en textsträng (typ "Verksamhetsnamn" eller "Efternamn") i stället för heltal (Integer) i Dim? Hur koppla resp textfält i userform mot VBA-koden? Är det bara copy/paste från ditt exempel fast med utbytta kontrollnamn? (Jag antar att det sker i kodrutan för formuläret) Hur kan jag anropa formuläret i själva Exceltabellen, dels om jag har en knapp ("Koppla makro...", eller??), dels om jag vill det öppnar automatiskt? //Magnus
  2. Tack för svar Monshi! Eftersom jag inte är en hejare på VBA förstår jag inte riktigt hur jag skall göra. Men jag har lagt "Function GetValue..." i Blad 1:s objekts kodruta i VBA editorn och "Put Value..." i en egen modul (Modul 1). Hur kopplar jag sedan userform till koden och formuläret till en sökknapp på själva Excelarket? Det finns inget alternativ då jag försöker koppla makro till knappen... //Magnus
  3. Goddag därute i forumet! Har ett litet projekt som jag behöver hjälp med. Jag har skapat ett medlemsregister i Excel för en förening. Medlemsuppgifterna har jag importerat från ett annat webbaserat program som kommer att upphöra inom kort. Problemet är att Excel-arket blir så stort med många kolumner från importen och jag skulle behöva presentera utdrag ur detta vi en userform i VBA. Jag har kommit så långt att jag designat formuläret (se bild) Jag har tidigare jobbat en hel del i MS Access och designat formulär men då via designverktyg där. Jag har förstått att jag måste koppla VBA-kod till formuläret, men hur gör jag det? Min tabell på Excelfliken är designat så att kolumnerna står som fält och raderna som poster (precis som i access). Finns där någon vänlig och kunnig person som kan tipsa mig om någon VBA kod så att man kan söka i tex "Verksamhetsnamn" och sedan få övriga fält ifyllda från den posten? Med hopp om svar! //Magnus
  4. Har nu testat att ladda ner Sysresccd och hittar inget på denna iso som kunde vara relevant på mitt problem! Har Googlat Foremost och Photorec men de verkar handla om file-recovery, inte återställning av filsystem som sådant... Jag "har" ju alla filerna kvar men de ligger på en partition som är unallocated. Det bara måste finnas någon enklare lösning att återställa ett förlorat filsystem utan att man formaterar om disken och därmed förlorar alla data, eller...? //Magnus
  5. Tack för tipset "Flitig"- Jag skall testa det! //Magnus
  6. Cecilia! Glömde fråga ifall du tror att "Minitool..." i den köpta versionen skulle fixa mitt problem enligt ditt förmenande? //Magnus
  7. Hej Cecilia! Tack för svar! Den hittar bara gamla partitioner i den snabbsökning jag gjorde. Problemet är att det liksom blir lite Moment 22 över det hela; partitionen är oformaterad och kan därför inte visa data - formaterar jag så förlorar jag data. Så här ser den i alla fall ut i "Minitool Partition Recovery": //Magnus
  8. Ett enda ofokuserat knapptryck tog det...! Har en LaCie 2Tb extern HD som jag använder för BU. Härom dagen skulle jag skapa en räddningsdisk åt Paragon som jag använder som BU-program och var inte helt uppmärksam utan missade att ändra sökväg för startmediet så att den pekade på min LaCie HD i stället. Upptäckte precis efter jag satt igång det hela men då var det försent! Filsystemet på min LaCie hade tagits bort! Jag har Googlat och sökt runt på snart sagt alla tänkbara lösningar, laddat ner flera program som påstås kunna lösa problemet men går bet på en lika enkel som billig lösning! Program som jag testat är: Data Recovery Mini Tool Partition... PC Inspector File Recovery Testdisc 7.0 Recuva Flera av verktygen kostar en massa pengar för att göra jobbet och det känns försmädligt att behöva punga ut med flera hundralappar för ett program som jag sannolikt behöver en endaste gång och som jag i förväg inte vet kan lösa problemet 100%! Gratisvarianterna verkar inte fungera på detta problem eller så har de begränsningar i kapacitet. Dilemmat är att alla filer ju finns kvar på LaCie-disken och det är inget fysiskt fel på hårdvaran, det är bara det att eftersom allt ligger som "Raw" och att det inte finns ett filsystem så jag kan accessa dem! Blir uppmanad att formatera LaCie-disken men jag vill inte förlora alla viktiga filer och det handlar om ca 1,4 Tb så jag kan heller inte skapa någon större partition "på sidan om" och rädda data den vägen! Finns det någon enkel metod att lösa detta på eller sitter jag med lång näsa och tvingas förinta flera års BU? Någon som har tips? //Magnus
  9. Tack alla för svar! Jag löste det hela genom att göra en ren installation av Windows 7! //Magnus
  10. Hej C. Jag har som sagt prövat all tänkbara kopplingsvarianter utan framgång. Om jag ändrar mina IPv4 inställningar i burkarna till fixa IP-adresser och anger routerns IP så bryts bara internetförbindelsen. I routern har jag då angett korrekt IP samt markerat för dynamisk förhandling mot modemet. Jag har gjort så i andra nätverk jag tidigare jobbat med och då har det funkat. Har kommit så långt i mina funderingar att detta kanske handlar om någon dold inställning i registret eller så som hindrar min stationära att öppna upp mot nätverket. Jag hade f.ö. en stor krasch igår där jag fick återställa allt från en tidigare backup. Månde jag fått med någon gammal inställning som blockerar... //M
  11. Hej Thomas och tack för ditt svar! Jag har prövat båda varianterna och även provat olika providerordning: (Modem - Router - Switch - Noder/Modem - Switch - Router - Noder) men jag misstänker att felet sitter djupt i nätverksinställningarna på min stationära... Se mitt svar till Cecilia! //Magnus
  12. Den IP-adressen varierar ju eftersom det handlar om automatisk tilldelning, eller? Helst vill jag tilldela alla tre enheterna fasta IP och sedan låta routern kommunicera med Comhem-modemet med automatisk tilldelning och dela ut till de tre enheterna med fasta IP! Som det är nu verkar datorerna ignorera router-funktionen och bara använda den som switch mot modemet! Det är min stationära burks nätverksinställningar som verkar krångla med att inte tillåta ändring i hemgruppen jag skapat! Den sparar inte inställningen om jag försöker att ändra i "Avancerade delningsinställningar"! //Magnus
  13. Hej Cecilia! Tack för svar. Jag försöker tilldela dem ip-nummer (192.168.1.2 osv.) via nätverkskortets egenskaper men eftersom Comhem tillämpar automatisk tilldelning så slutar bredbandsuppkopplingen då att fungera! Har bara Googles DNS-servrar fast definierade i IPv4 (8.8.8.8 resp 8.8.4.4)! //Magnus
  14. Hej någon nätverkskunnig därute! Jag har ett problem att få mitt hemmanätverk att fungera! Har en burk med W7 stationärt LAN-kopplad, en LapTop W8.1 WLAN-kopplad. Jag kan accessa internet på både LAN och WLAN men när jag vill sy ihop alla enheterna i ett hemmanätverk så fungerar inte det! Har prövat att surfa runt och hitta svar men går bet! I min stationära dator med W7 kan jag inte ändra "Aktivera Nätverksidentifiering" av någon anledning. Varje gång jag försöker ändra till aktiv så sparas inte inställningen. Har skapat en hemgrupp i denna (stationära) men kan heller inte konfigurera denna eller ta bort hemgruppen. Min utrustning är följande: Hårdvara Stationär dator med Windows 7 LAN-kopplad LapTop med Windows 8.1 WLAN-kopplad Skrivare Canon MP640 LAN Bredband via Comhem med deras kabelmodem (automatisk IP) Switch med LAN-portar WLAN-router D-Link (Go DSL N-150) Kablad mot switchen Mjukvara Zone-Alarm brandvägg + AV på stationära datorn Avast AV + Windowsbrandvägg på LapTop IoBit Advanced System Care som jag kör regelmässigt på den stationära Så här har jag kopplat Tror jag hamnat i ett läge där det är en eller flera huvudparametrar som inte är rätt inställda spå jag har hållit på och skruvat både här och där men misstänker att jag med mina begränsade kunskaper i nätverkshantering har strulat till det ännu mer! -Anybody...?
  15. OK! Har listat ut att det inte verkar att fungera i Excel med att kontroller döljs och tas fram tillsammans med rader! Finns det i så fall någon i communityn som vet om det går att ordna så att man kan alternativmarkera i 5 celler på rad? Alltså motsvarande som att ha fem radio-knappar fast man har celler i stället där man bara kan markera en cell med tex "X" i en rad om fem celler. Känns som att det borde kunna gå med en villkorsformel (OM) på något sätt...
  16. Hej någon därute! Jag har skapat en enkät med radio-knappar som alternativval. Innehållet i B-kolumnen (Fråga 1, Fråga 2 osv) på enkätbladet (målbladet) styrs från ett länkat kalkylblad (källblad) och jag vill att bara de kolumner som används skall synas så att när jag på källbladet fyller i tex 10 frågor skall bara de tio raderna också synas på målbladet! Max antal rader idag är 61 (från rad 9 till rad 69 i kolumn. Dessutom måste radio-knapparna döljas samtidigt med raden och allt sedan automatiskt visas igen då en fråga skrivs in! Har Googlat på frågan men hittar ingen bra lösning och är dessutom dålig på VBA-syntax... - Anybody?
  17. Monshi! Det funkar! Makrot heter "DoljRader" i stället för "DöljRader"! Två små prickar fel! Önskar dig en riktigt bra fortsättning på det nya året! //Magnus
  18. Tack Monshi för snabbt svar! Det fungerar dock inte utan jag får upp denna dialog i stället: Har du några funderingar om det? //Magnus
  19. Hej Monshi! Behöver kod för att starta ett makro vid visst cellvärde och hittade detta gamla inlägg! Har modifierat och prövat din kod och kan till min belåtelse se att den fungerar! Vad jag dock är ute efter är att mitt makro skall kunna ta fram resp. dölja rader beroende på om en given cell har ett värde som över- eller understiger 100. Om cellkriteriet uppfylls så skall raderna visas, annars döljas. Hur mekar man ihop det? Så här har jag gjort: Private Sub Worksheet_Change(ByVal Target As Range) Application.EnableEvents = False If Target.Count <> 1 Then Exit Sub If Not Application.Intersect(Target, Me.Range("L3")) Is Nothing Then TaFramRader <---------- Här är makrot för att visa raderna MsgBox "Fyll i skalan!" End If Application.EnableEvents = True End Sub Makrot för att dölja raderna heter: DoljRader Jag vore dig mycket tacksam om du kan hjälpa mig med detta! //Magnus
  20. Tack för din hjälp! Fantastiskt att du gör det! God Jul på dig! //Magnus
  21. Hej Monshi och tack för snabbt svar! Har prövat den men det verkar inte fungera... Ser spontant ut för mig som lekman att exemplet är kopplat till någon databas av något slag. Jag har f.ö. prövat att lägga in Application.DisplayAlerts = False utan att det förändrar något! Jag kan leva med den röda stängningsknappen men vill ha bort möjligheten för användaren att spara utöver med hjälp av den funktion som du tidigare hjälp mig med! Som du ser har jag lagt till Application.Quit vilket påbörjar stängning av arbetsboken men sedan dyker frågan om jag vill spara ändringar upp igen... Det är den dialogrutan jag vill ha bort! Tacksam för svar! //Magnus
  22. Hej! Har en bra fil med en ypperlig "spara"-funktion som makro kopplat till en knapp i filen. Men jag skulle vilja ta det ett steg längre med VBA och det är två funktioner jag är nyfiken på om det går att göra: Kan man med en relativt enkel VBA-kod göra så att arbetsboken öppnar UTAN Minimerings-, Maximerings- och Stängningsknapparna uppe i övre högra hörnet av fönstret? Vill i stället ha ett stängningsmakro kopplat till min "Spara" knapp! Sedan vill jag ta bort den dialogruta som frågar "Vill du spara ändringar som du gjorde i ..." när man stänger! Finns där någon vänlig själ som kan bistå mig i detta? //Magnus
  23. Monshi! Hittade felet i min fil! Det var arbetsbladen som blivit omkastade och därför blev det fel referens! Nu fungerar det perfekt!!! Jag kan bara säga att du med din hjälp gjort min dag! Än en gång stort tack! //Magnus
  24. Hej igen! Var nog lite snabb där... Det fungerade i din "Bok1.xlsm" men när jag överförde det till min fil så är det inte rätt! Visserligen öppnas dialogrutan "Spara som" men det är helt tomt i filnamnsrutan och i filtypsrutan visas Excel 98 - 2003(.xls)! Den läser helt enkelt inte av min cell C10 eller följer instruktionen i skriptet i övrigt... //Magnus
  25. Monshi! Det funkar! Stooor tack för din hjälp! Världen känns lite bättre nu! Hälsningar //Magnus
×
×
  • Skapa nytt...