Just nu i M3-nätverket
Gå till innehåll

KIVA_62

Medlem
  • Antal inlägg

    15
  • Gick med

  • Senaste besök

Om KIVA_62

  • Medlemstitel
    Användare
  • Födelsedag 1962-09-09

Kontaktinformation

  • Hemsida
    http://www.go2web.se

Profil

  • Kön
    Man
  • Ort
    Stockholm
  • Intressen
    Jag arbetar med webbutveckling, databasdesign och Internetmarknadsföring.
    Jag har en hemsida där jag marknadsför mitt företag som erbjuder hemsida webbhotell och Internetmarknadsföring.

Senaste profilbesöken

Blocket med senaste besökare är inaktiverat och visas inte för andra besökare.

  1. KIVA_62

    Uppdaterad Server kan inte skapa Object

    Hej, Tack för ett snabbt och tydligt svar. Kanske ska nämna att i min lokala IIS så funkar allt bra. Som jag nämnde så ligger sedan hela siten på webbhotel och jag tvivlar på att jag kan komma åt att ändra inställningar på servern, men jag ska gå in på kontrollpanelen och se om jag kan ändra några rättigheter m.m. Men tror inte jag kommer åt Windowsloggen, men ska kolla även detta.
  2. Hej, En sida som försöker skapa objekt för att göra krypteringsnyckel fungerar helt plötsligt inte. Detta verkar bara gälla de sidor med klassisk ASP Jag har inte gjort några ändringar och jag misstänker att någon uppdatering (Patch) har körts på servrarna som bara påverkar klassisk ASP sidor. Servern hostas extern och tyvärr får jag inte mycket hjälp från dem, då alla som kan lite om detta är på semester. Felmeddelande är: Microsoft VBScript runtime error '800a01ad' ActiveX component can't create object /filnamn.asp, line 153 (även line 154 när jag testade) Då jag misstänkte att det berodde på att krypterings metoden SHA1 som är rätt föråldrad hade släkts ner på servern, testade jag en sida som är gjort i ASP.NET (C#) med samma kryptering på samma server. Men där fungerade det bra. Googlade på felnumret och får följande resultat från Microsoft; verkar vara någon inställning med rättigheter I IIS ? https://support.microsoft.com/en-us/help/201740/cannot-create-object-error-when-browsing-asp-pages Någon som vet hur man åtgärdar det och vad betyder "The IUSR_computer and IWAM_computer account must be granted read permissions to the <drive letter> .... osv"n ??? Ev. Kan jag använda någon annat sätt att skapa en krypteringsnyckel som funkar både i klassisk ASP och i ASP.NET ? Så här ser min kod ut: 149 Function sha1(instr) 150 151 Dim asc, enc, bytes, outstr, pos 152 'Borrow some objects from .NET (supported from 1.1 onwards) 153 Set asc = Server.CreateObject("System.Text.UTF8Encoding") 154 Set enc = Server.CreateObject("System.Security.Cryptography.SHA1CryptoServiceProvider") 155 156 'Convert the string to a byte array and hash it 157 bytes = asc.GetBytes_4(instr) 158 bytes = enc.ComputeHash_2((bytes)) 159 160 outstr = "" 161 162 'Convert the byte array to a hex string 163 For pos = 1 To Lenb(bytes) 164 outstr = outstr & LCase(Right("0" & Hex(Ascb(Midb(bytes, pos, 1))), 2)) 165 Next 166 sha1 = outstr 167 Set enc = Nothing 168 Set asc = Nothing 169 170 End Function
  3. Tack Jari, Jag får prova det, är inte så bevandrad när det gäller indexering, ser att det finns något som heter Spatial index och vanlig index/key. Misstänker att det kan öka prestandan men undrar om det verkligen har med felet att göra då det gick relativt bra innan flytten av db. Nu kan man få vänta på svar upp till 30 sek och ibland blir det "Time Out". En tanke slog mig att efter att vi flyttat databasen, som från början är gjord i Diagramläge så ficka vi manuellt lägga in räknare. Men jag missade att man kanske borde ha kollat det senaste ID och börjat räknaren efter det värdet?
  4. Hej, Har gjort en flytt av databas från en MS SQL Server till en MS SQLExpress 2014. Vi har en webbshop som pratar med databasen men periodvis så går det väldigt segt. Sen brukar det lossna igen när våra server hostare har kört patch-uppdateringar visar det sig. Vi analys av loggar m.m. visar det sig att det har någonting med "Missing index" att göras. Jag har speciellt två tabeller som är kopplade till varandra shopOrder --> shopOrderPoster Jag har inte indexerat någonting men däremot så har jag ju ett id i varje tabell som räknar upp med 1. . När de gjorde flytten fick jag manuellt gå och lägga in alla sådana (Identity Seed) , då det inte gick att göra en ren flytt utan de körde script. Nu upptäckte jag att "Primär nyckeln" som ska räknas upp med en i shopOrder för varje ny post ibland hoppar upp 1000 i räkningen, senast i samband med att det började gå normalt igen. Är det någon som vet vad felet kan bero på ?
  5. KIVA_62

    Regular Expression i .NET Web Pages

    Kanon !!! Funkar perfekt! Tack för hjälpen! Damerna på kundtjänst blir glada nu :-)
  6. KIVA_62

    Regular Expression i .NET Web Pages

    Haha .. jag är hemska tacksam för ditt tålamod och det börjar likna något nu. Du kan säkert ta patent på detta, måste ju finnas ett stort behov då alla webbshoppar som riktar sig till företag inte kan leverera varor till en boxadress. En liten hake bara ... testade med Boxgatan 2, (som ju är en okey leveransadress) och den blir "True". Vet inte hur många gator det finns som börjar på Box i Sverige, antar det är liten chans ... försöker även själv lägga in att efter bokstäverna i BOX kollar om det är ett mellanslag eller en siffra, är osäker ändå om det blir vattentätt, då man kan ge sig tusan på att någon kund skriver "Box gatan 2" vilket då borde generera "True" Tack för hjälpen i alla fall!
  7. KIVA_62

    Regular Expression i .NET Web Pages

    Ja det funkar, upptäckte dock att även "BIL 123" returnerar True. Verkar som det räcker med att sätta första bokstaven till "B" Regex.IsMatch("BIL 123", @"^[boxBOX].+\d")
  8. KIVA_62

    Regular Expression i .NET Web Pages

    Tack för det, testade med nedan, och resultatet blev att allt tolkades som Box adress förutom just om man skriver "Box [siffra]" *Haha* Så på något sätt så måste jag få en omvänd koll, som ... if(adress != boxadress). Sen vet jag inte hur man löser Case Sensitive i detta fall. Validation.Add("foretagAdress", Validator.Regex(@"^box.\d{1,5}", "- Du kan inte ange en Boxadress"), Validator.StringLength(80, 4, "- Ej giltig adress") ); Jag har hittat en färdig RegEx för validering av epost som ser ut så här Validation.Add("epost", Validator.Regex(@"^[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,4}$", "- Ej giltig e-postadress"), Validator.Required("- E-post adress saknas") );
  9. KIVA_62

    Regular Expression i .NET Web Pages

    Någon här som är duktig på Reguljära utryck? Jag använder mig av .NET web pages färdiga funktion för validering och skulle behöva kontrollera med "Regex" om en adress från ett formulär är en Boxadress, D.v.s. de tre första bokstäverna bildar ordet "Box" ( ej Case Sensitive ) och det fjärde tecknet (när man rensat ev. mellanslag) är en siffra. Jag är rätt ny på detta, så jag skulle även vara tacksam för en bra svensk tutorial för Regujära utryck?
  10. Sitter och kodar

  11. Har kört fast :| Jag har gjort en SMS funktion i ASP, där jag i ett TEXTAREA fält kan skriva SMS och skicka till olika grupper. Allt funkar, men om man gör radbrytningar i textfältet så visas %D%A i SMS'et. Jag har provat att tvätta texten med Javascript men det verkar inte funka, då ASCI koden är \n för radbrytning??? Är det någon som har en enkel lösning på detta?
  12. -Ja jag fick grönt på alla förkrav.. där installationsprogrammet kör en kontroll. Tack för hjälpen ... vad jag förstår så ska det vara möjligt i alla fall att installera SQL Express på XP Home Edition, jag ska försöka igen med att ladda hem den senaste .NET Framwork 3.5 och provar att installer igen. Jag tror det kan ha med de inställningar jag gjorde, där man ska välja inloggning både fär datorn och SQL !? Kan hända det blev fel då jag inte hade någon inloggning (lösenord) på windows. Provar igen
  13. Hej, Jag är nygammal SQL kodare, senast jag använde SQl var det version MS SQL Server 7 Jag sitter nu med en XP Home edition och skulle vilja installera MS SQL Server. Jag har inte hittat några System krav på Express varianten och skulle behöva både själva databas hanteraren och Management verktyget, meg fick det inte att funka!? Måste jag ha XP Proffessionel ? Kim
  14. KIVA_62

    Får inte min Swing test att fungera!

    Hej, Ja, ledsen var lite otydlig .... jag sparade filen HelloWorldSwing.java kompilerade i kommandotolken med [javac HelloWorldSwing.java] Utan några felmeddelanden Sen provade jag att köra den nyskapade filen "HelloWorldSwing.class" med kommadot [java HelloWorldSwing] och fick dessa felmeddelanden. Har även provat att kolla att rätta objektpaketen är installerade i datorn (awt och swing) genom att provköra filer som finns i (idg)Webbstudios javaskola, och dom filerna funkade bra !? Skumt för mig :-) Tack för att du tar dig tid !
  15. KIVA_62

    Får inte min Swing test att fungera!

    Felmeddelandet ser ut så här ... Exception in thread "main" java.lang.NoClassDefFoundError: HelloWorl Caused by: java.lang.ClassNotFoundException: HelloWorld at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source)
×