Just nu i M3-nätverket
Gå till innehåll

MH_resurrected

Medlem
  • Antal inlägg

    733
  • Gick med

  • Senaste besök

  • Vunnit antal dagar

    16

Allt postat av MH_resurrected

  1. MH_resurrected

    Räkna tid så länge värdet ökar

    om du matar in det här som matrisformel så får du reda på radnumret för den första cellen i A-kolumnen som följs av ett mindre värde (exemplet kollar bara de 19 första) =MIN(OM(A2:A20<A1:A19;RAD(A1:A19))) eller, första raden där nästa rad minskar med minst 5 steg =MIN(OM((A1:A19-A2:A20)>=5;RAD(A1:A19))) OBS! Matrisformler (ctrl+shift+enter) Alternativ matrisformel. Kan vara smidigt om du inte börjar på rad 1 =PASSA(1;((A5:A19-A6:A20)>0)*1;0) =PASSA(1;((A5:A19-A6:A20)>=5)*1;0) Om du vill slippa matisformler måste det bli något slags specialare. t.ex: =MÄNGD(15;6;RAD(A1:A19)/(A2:A20<A1:A19);1) =MÄNGD(15;6;RAD(A1:A19)/((A1:A19-A2:A20)>=5);1)
  2. MH_resurrected

    Smart TV

    Jag har en halvny smart-tv (samsung xxx) och en chromecast (från tidigare tv). Den stora fördelen med smart-tv'n är att du styr allt med en fjärrkontroll - Smidigt. Nackdelen är att som tidigare sagts att apparna kan vara usla för vissa kombinationen av tjänst/Tv. På min TV är kombinationen SVT play + samsung-tv sjukt instabilt. Då är det enklast att koppla över till chromecasten och använda SVT's app på en gammal android-mobil som får leka fjärrkontroll (det går förmodligen att casta direkt till tv'n men chromecasten är tillräckligt smidig). Troligtvis är det smartast att lägga pengarna på bästa möjliga bild på TV'n och köra smartfunktionen separat på något sätt. Smartfunkionen körs ju på en inbyggd dator som kommer att vara omodern lång innan du blir missnöjd med resten av TV'n och då är det väldigt smidigt att bara lägga några 100-lappar på en nya Chromecast/apple TV istället för att köpa en ny TV. Å andra sidan kan du göra som jag. Kör funktioner från Smart-tv'n så länge det går och kör det som inte funkar via extern puck eller låda. En enda fjärrkontroll är extremt smidigt. Det jag ogillar med Chromecast är att det inte går att köra Ethernetkabel (längre). Det fanns en adapter för vissa modeller men den verkar vara helt borttagen nu: https://store.google.com/?srp=/product/ethernet_adapter_for_chromecast Och naturligtvis att det är google (Storebror ser dig ännu mer).
  3. MH_resurrected

    I stället för MS Office

    Ber frågeställaren om ursäkt. Fullständig OT: Vi umgås uppenbarligen inte med samma människor :-)
  4. MH_resurrected

    Jämna ut värden i tabellkolumn

    Så du vill ha ett slags dynamiskt glidande medelvärde? Problemet är hur din regel skall se ut. i Ditt exempel gör du något slags specialare när det kommer 2 st 0,25:or efter varandra. Det gör det mycket svårare. Dessutom tycker jag att det är ologiskt (kommer det 2 0,25:or efter en massa 0:or så borde det betyda en puckel som skall synas). Så, låt oss göra det enkelt. om värdet i cellen är>0 OCH föregående värde > 0 så används värdet =OM(OM(OCH(B1>0;B2>0);B2);B2) Så fort det kommer en 0:a skall Om vi står i cell C2 så anger den här formeln nästa rad (inklusive den egna raden) som har ett värde som överstiger 0 =MIN(OM(B2:B$100>0;RAD(B2:B$100))) (inmatat som matrisformel, dvs med Ctrl+shift+enter) eller så här om du vill slippa matrisformeln ("Mängd" är en hållare för andra funktioner men man kan styra beteendet lite grand. I det här fallet är funktionen 15 (minsta) och vi ber den ignorera felmedelanden (6)) =MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1) på samma sätt ger det här den närmast föregående som är o-tom =MÄNGD(14;6;RAD($B$2:B2)/($B$2:B2>0);1) Och det här ger antal mätningar som skall ingå i serien (första 0a t.om första >0 =MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1)-MÄNGD(14;6;RAD($B$1:B1)/($B$1:B1>0);1) om du delar 0,25 med detta tal borde det bli rätt: Slå ihop med villkoret: =OM(OCH(B29>0;B30>0);B30;0,25/(MÄNGD(15;6;RAD(B30:B$100)/(B30:B$100>0);1)-MÄNGD(14;6;RAD($B$1:B29)/($B$1:B29>0);1))) Om du vill hantera att det ibland blir 0,5 eller liknande efter en serie 0:or så kan du hämta nästa värde istället för att köra 0,25 =INDIREKT("B"&MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1)) sammanslaget: =OM(OCH(B1>0;B2>0);B2;INDIREKT("B"&MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1))/(MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1)-MÄNGD(14;6;RAD($B$1:B1)/($B$1:B1>0);1))) Och för att få in 0:or på slutet =OMFEL(OM(OCH(B1>0;B2>0);B2;INDIREKT("B"&MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1))/(MÄNGD(15;6;RAD(B2:B$100)/(B2:B$100>0);1)-MÄNGD(14;6;RAD($B$1:B1)/($B$1:B1>0);1)));0) "Ryckigare" än ditt exempe. Men om du specialbehandla 2 0,25 or som följer så får du tänka ut logiken.
  5. MH_resurrected

    Jämna ut värden i tabellkolumn

    Enklast: Samma figur som tidigare - dubbelklicka på linjen och välj Linjestil-utjämnad linje Blir lite "mjukare" men kanske inte som du vill. Rullande medelvärden - manuellt (5 perioder) Skapa nya data. Rullande medelvärden I kolumn C. Cell c5, skriv in formeln =MEDEL(A2:A6) kopiera ner till slutet Skapa ett nytt diagram baserat på B och C -kolumnen Glidande medelvärden med hjälp av trendlinjer Markera ditt diagram, gå till diagramverktyg ->Layout->Trendlinjer-> fler alternativ->glidande medelvärden för X perioder Dölj originalserien genom att dubbelklicka på linjen och välja linjefärg- Ingen Obs Du förlorar alltid några observationer i ändarna (början och slutet) när du kör glidande medel Se bifogad kopia av ditt dokument för några exempel Kopia av Vågresultat.xlsx
  6. Strunta i det eller kör med M&M's sista förslag. Problem: 1. Du måste redan ha en bild när du skriver in =pdf i formelfältet för att länka ikonen till en cellavbildning. Du kan inte skriva in adressen direkt i en cell (då får du värdet i cellen, inte bilden). Så om du har 1000 filnamn måste du klistra in 1000 bilder och fixa adressen på något sätt. 2 En länkad bild kan bara länkas med en direkt adress eller ett namngivet område. Så du kan inte ha en formel som hittar bilden för filändelsen. Det krävs en namngiven formel FÖR VARJE bild du skapar. dvs inte 13 namngivna områden utan en per rad (1000?) Här har du ett pedagogiskt exempel (onödigt många namngivna områden. behövs bara ett (kolla kommentarerna)). Men det handlar bara om EN ikon/flagga som skall visas och det är i den typen av situationer som det funkar hyggligt. https://www.youtube.com/watch?v=wlW2UKml9CY
  7. MH_resurrected

    Långa tal!

    Hej. Excel klarar bara någonting i stil med 15 siffror (googla excel 15 digit). Sen trunkeras värdet. Du kan fortfarande skriva in det om cellen är formaterad text (Ctrl+ 1, talformat, text). Eller om du börjar cellen med text-tecknet ' . Men om du vill räknar med talet så kommer det att trunkeras. https://support.microsoft.com/sv-se/help/2643223/long-numbers-are-displayed-incorrectly-in-excel https://support.microsoft.com/sv-se/help/78113/floating-point-arithmetic-may-give-inaccurate-results-in-excel
  8. MH_resurrected

    Invertera markering i Word

    Ja. Det är märkligt att det inte finns. I windows utforskare kan man exempelvis välja ett antal filer/mappar och sedan gå till redigera ->invertera. Så windows-delen av Microsoft har ju insett att det kan vara bra att ha. I Word skulle det framför allt vara bra om man vill undanta vissa delar av dokumentet från en stor förändring. Word har ju inget bra sätt att välja bort delar av en markering om man skulle välja allt och sedan försöka ta bort t.ex stycke 3 och 5 ur markeringen. <blekröd=edit>
  9. MH_resurrected

    Sammanställa olika excelblad i ett

    Jag tror inte att jag förstår vad du menar. Men om du har samma rubriker på alla kolumner så kan du testa pivottabell med flera konsolideringsområden. ALT+D+P Men det är ganska svårbegripligt. https://support.office.com/sv-se/article/konsolidera-flera-kalkylblad-till-en-pivottabell-3ae257d2-ca94-49ff-a481-e9fc8adeeeb5 Du kan även kolla om DATA->dataverktyg->konsolidera innehåller något du kan använda https://support.office.com/sv-se/article/konsolidera-data-i-flera-kalkylblad-007ce8f4-2fae-4fea-9ee5-a0b2c9e36d9b Kolla även powerQuery https://www.excelbrevet.se/power-query-excel/
  10. MH_resurrected

    Invertera markering i Word

    Jag är ganska säker på att det inte går. Kommandot borde ligga under Start->redigering->Markera-> Men där hittar jag inget (inga googleträffar heller). Å andra sidan är jag nästan säker på att jag läste om snabbkommandot för inverterad markering i en IDG-artikel nyss (anders R om jag skall gissa ). Någonting om okända snabbkommandon. bland annat tog han upp "ctrl+mellanslag" för att återställa formateringen för en markering. Men jag lyckas inte söka fram den. GRRR Näpp. Det var den här jag tänkte på och där står det inget: https://pcforalla.idg.se/2.1054/1.713728/microsoft-word-tips
  11. MH_resurrected

    LÖST Arrayfomel med Medel

    Märkligt nog fungerar det om du gör samma sak (lägg till ett villkor). Det här är den Inre-/andra delen av din maxformel med min istället: =MIN(OM((REST(RAD(J10:J130)-RAD($J$10);8)=0)*(J10:J130<>"");J10:J130)) {Matrisformel} Man kan ju tro att OM-satsen skulle leverera falskt (0) när villkoret inte är uppfyllt. Men matrisformler lever i sin egen magiska värld... Den här är mer logisk, men då måste du lära dig Mängd() också. =MÄNGD(15;6;(J10:J130)/((REST(RAD(J10:J130)-RAD($J$10);8)=0)*(J10:J130<>""));1)
  12. MH_resurrected

    LÖST Arrayfomel med Medel

    Lägga in ett villkor till (att det inte får vara tomt)? =MEDEL(OM((REST(RAD(J9:J97)-RAD(J9);8)=0)*(J9:J97<>"");J9:J97;""))
  13. MH_resurrected

    SummaOmF och wildcards

    Ja/nja ... JA I sökrutan (H2) med text kan du skriva in det direkt. Det här skulle t.ex hitta allt som börjar med grönt grön* medan det här hittar både grön och röd *rö* och det här hittar bara de gröna (? kräver att det står ett tecken) ?rö* Om du alltid vill kolla om texten i H2 finns någonstans så kan du alltid klistra in jokrarna i formeln med hjälp av sammanfoga. =SAMMANFOGA("*";H2;"*") eller "*"&H2&"*" =SUMMA.OMF(D3:D16;B3:B16;"*"&H2&"*";C3:C16;H3) Nja eftersom c-kolumnen och H3 är tal så blir det knepigare att söka med wildcards (t.ex *2 för att hitta både 2 och 12). Om det skall funka måste du omvandla allt till text och jag tror inte att det går med antal.omf() Men du kan exempelvis skriva in >0 i cell H3 om du vill hitta alla gröna oavsett vilken siffra som står i grupptillhörighet (men det måste stå en siffra).
  14. MH_resurrected

    Excel Avmarkera en cell

    Ja, Excelbrevet är lite skumt. Men de kanske menar 365 (eftersom han pratar om månadsvisa uppgraderingar). Jag måste erkänna att det är så mycket som kallas office idag så man blir rätt förvirrad med Webb/lokalt/prenumeration/engångsköp/skrivbords onedrive/office.com/tjollavip och hans mormor. https://products.office.com/sv-se/microsoft-office-for-home-and-school-faq När det gäller "MakeUseOf " tolkar jag det som "latest 365" och sedan en allmän "läs allt annat vi skrivit om excel"-länk.: Men det är inte glasklart. Sen tror jag att en del skribenter är med i olika slags beta-program och testar kommande funktioner utan att veta i vilken version de hamnar. Men, men.
  15. MH_resurrected

    Formel i annat blad

    Tre delar. 1. klistra ihop adressen med flikanamnet. T.ex genom att använda SAMMANFOGA() eller ADRESS() =SAMMANFOGA($A$1;"!E$24:E$10056") Obs utrops-tecknet ! som skall ligga mellan fliknamn och celladress Om du är lat kan du strunta i sammanfoga och köra &-tecknet: $A$1&"!E24:E10056" 2. Få excel att förstå att det är en adress och inte vilken sammanfogad text som helst. Det gör du med INDIREKT() =INDIREKT(SAMMANFOGA($A$1;"!E$24:E$10056")) Eftersom det bara pekar på ett område så får du ett felmeddelande, men det är en giltig adress. Kolla t.ex med: =summa(INDIREKT(SAMMANFOGA($A$1;"!E$24:E$10056"))) 3. Klistra ihop med din formel. =SUMMA.OM(INDIREKT(SAMMANFOGA($A$1;"!E$24:E$10056"));"t-lagret";FÖRSKJUTNING(INDIREKT(SAMMANFOGA($A$1;"!E$24:E$10056"));-3;0)) PS, fundera på om din ursprungsformel blir lättare att förstå om du kör en passa/index =INDEX(INDIREKT($A$1&"!E:E");PASSA("t-lagret";INDIREKT($A$1&"!E:E");0)-3) /DS
  16. MH_resurrected

    Excel Avmarkera en cell

    excel 2019 eller 365 enligt microsoft https://support.office.com/en-us/article/deselect-a-selection-d1b56f30-7d63-4a64-8f0b-da4958204b52
  17. MH_resurrected

    Val av data att visa

    Kräver nog VBA/makro om det skall vara smidigt. men... Du kan göra tabellerna osynliga genom att göra texten vit och stänga av bakgrundsfärgen med villkorsstyrd formatering. Men så vitt jag vet går det inte att dölja "på riktigt", exempelvis genom att dölja kolumnerna. exempel "osynligt": Antag att du skriver tab1, tab2 eller tab1 i cell X1 (eller skapar en rullista med hjälp av dataverifiering). Markera kolumn A:H och gå till Villkorsstyrd formatering->ny..->bestäm..formel =$X$1<>"tab1" Knappen [Format] -> Tecken->färg: vit (du kan även ändra bakgrundsfärgen på den fliken) Markera kolumn I:P och gå till Villkorsstyrd formatering->ny..->bestäm..formel =$X$1<>"tab2" Knappen [Format] -> Tecken->färg: vit Markera kolumn O:W och gå till Villkorsstyrd formatering->ny..->bestäm..formel =$X$1<>"tab3" Knappen [Format] -> Tecken->färg: vit Nu syns bara den tabell som är vald även om övriga ligger kvar. exempel "kopiera": En annan variant är att ha tabellerna på ett annat blad och sedan hämta fram rätt data med hjälp av en formel (då visar du data men kan inte ändra i tabellerna) exempel om dina rådatatabeller finns i blad1 och du vill hämta till blad2. Skriv in den här formeln i cell A1 och kopiera ett lämpligt antal rader/kolumner =OM($X$1="tab1";Blad1!A1;OM($X$1="tab2";Blad1!I1;OM($X$1="tab3";Blad1!Q1;""))) Då andras data beroende på vad som står i X1. Det trista är att tomma celler kopieras som 0. det kan du exempelvis hantera genom att omvandlad det du kopierar till text =OM($X$1="tab1";""&Blad1!A1;OM($X$1="tab2";""&Blad1!I1;OM($X$1="tab3";""&Blad1!Q1;""))) eller krångla till det ordentligt och kolla om källan är tom innan du kopierar =OM(ÄRTOM(OM($X$1="tab1";Blad1!A:A;OM($X$1="tab2";Blad1!I:I;OM($X$1="tab3";Blad1!Q:Q;""))));"";OM($X$1="tab1";Blad1!A:A;OM($X$1="tab2";Blad1!I:I;OM($X$1="tab3";Blad1!Q:Q;""))))
  18. Jag snabbkollade nyss mitt kontoutdrag och såg till min förvåning posten Tv-avgift 363,60 (på ett ungefär). Eftersom Tv-avgiften är borttagen åkte naturligtvis foliehatten på (det var ju inte i går man föddes i farstun). Ett misslyckat letande efter information om mottagaren i både internetbanken och bankappen steg leder till en stigande respekt för den geniala mästertjuv som inte bara maskerat sin rfid-skimming som en nedlagd räkning utan dessutom lyckas dölja sitt kontonr . Nästa steg är att ringa banken för att få mer info om denna lömska utbetalning. Då visar det sig att det inte är en utbetalning från mitt konto, det är en återbetalning från tv-tjänst... Hur dj@£la svårt kan det där med plus- och minustecken vara ...). Foliehatt av --> dumstrut på
  19. MH_resurrected

    Tv-avgift. ...Nätet gjorde mig paranoid ...

    Det är jättelätt att se i min bank också...
  20. MH_resurrected

    Antal varianter

    Och här har Microsoft ett antal förslag som hanterar tomma celler (kopiera manuellt om klickadressen pekar fel. https://support.office.com/en-us/article/count-unique-values-among-duplicates-8d9a69b3-b867-490e-82e0-a929fbc1e273 PS: Oves formel är korrekt och funkar om alla celler är ifyllda. Men jag fick vara supernoga med vad jag kopierade eftersom det kom med dolda skräptecken i slutet av formeln annars (skräp från forumet, inte från Ove).
  21. MH_resurrected

    Unika värden i droplist

    I namngivna områden är det alltid bäst att låsa referenserna. T.ex Blad2!$A:$A istället för Blad2!A:A. Kolla gärna alternativ till Antal.omf() eftersom den inte är helt lyckad när det gäller felvärden osv Om du inte gillar min produktsumma så kan du testa Mängd() som är gjord för att hanterar felmeddelanden. Den här räknar antal celler med data utan felmeddelanden: =MÄNGD(3;6;Blad2!$A:$A) https://support.office.com/sv-se/article/funktionen-mÄngd-43b9278e-6aa7-4f17-92b6-e19993fa26df Någonting petar in skräptecken och förstör formler i Eforum. Jag testar att lägga in i kodblock. Den här varianten av din formel för "Grupper" borde funka: =INDIREKT(SAMMANFOGA("Blad2!$A$2:$A$";ANTAL.OMF(Blad2!$A:$A;"<>#SAKNAS!";Blad2!$A:$A;"<>"&""))) alternativ: =INDIREKT(SAMMANFOGA("Blad2!$A$2:$A$";MÄNGD(3;6;Blad2!$A:$A))) Personligen föredrar jag Förskjutning istället för Indirekt eftersom det är lite mer "pang på rödbetan". =FÖRSKJUTNING(Blad2!$A$2;0;0;MÄNGD(3;6;Blad2!$A:$A)) PS: Om du vill kontrollera din formel så kan du skriva in den i en cell. Om du ställer dig i formelfältet och Trycker [F9] så visar excel matrisen som skapas av formeln. Tryck [Esc] för att lämna läget
  22. MH_resurrected

    LÖST Färgad rad vid dubletter

    =ANTAL.OMF($L$2:$L$6;$L2;$M$2:$M$6;$M2)>1
  23. MH_resurrected

    LÖST Word kraschar

    Bekräftar Pelle pennas länk-problem (Tradedoubler som jävlas) Dina tinyurl funkar, samma sak om man Kopierar din adress som text.
  24. MH_resurrected

    Unika värden i droplist

    Du måste nog skapa en hjälptabell med unika värden på något sätt. exempelvis så här:: https://exceljet.net/formula/extract-unique-items-from-a-list Det ser ut som om du använder en "exceltabell" . Då borde första kolumnen heta någonting stil med: Tabell1[grupp] Om du adresserar på det viset så kommer det att automatexpanderas när du lägger till nya data Lägg formeln från exceljet på blad 3, cell A2 (antar rubrik i A1) =OMFEL(INDEX(Tabell1[grupp];PASSA(0;ANTAL.OM($A$1:A1;Tabell1[grupp]);0));"") Mata in som Matrisformel (Ctrl+shift+enter) så att den får måsvingar. {=OMFEL(INDEX(Tabell1[grupp];PASSA(0;ANTAL.OM($A$1:A1;Tabell1[grupp]);0));"")} Kopiera ner ett lämpligt antal rader (din gissning om hur många unika värden det kommer att finnas + felgissningsmarginal) Antigen kopplar du dataverifieringen direkt till området, eller också skapar du ett namngivet område som utökas Ctrl+[F3] -> Nytt lämligt namn, t.ex UnikaVärden. Refererar till: =FÖRSKJUTNING(Blad3!$A$1;0;0;PRODUKTSUMMA((Blad3!$A:$A<>"")*1)) eller, om du vill slipa rubriken =FÖRSKJUTNING(Blad3!$A$1;1;0;PRODUKTSUMMA((Blad3!$A:$A<>"")*1)-1) Gå till din inmatningscell och välj dataverifiering, lista, tryck F3 och välj UnikaVärden
  25. Något villkor med IDAG() (dagens datum) i ena änden. Det här visar t.ex 5300 i en cell från och med 2019-03-15 =OM(IDAG()>=DATUM(2019;3;15);5300;"") alt skrivsätt: =OM(IDAG()>=DATUMVÄRDE("2019-03-15");5300;"") (som du märker måste man trixa lite om man vill skriva in ett datum i en formel ) Du kan naturligtvis göra samma sak med en summor på olika sätt. Exempel, förfallodatumen står i kolumn A och beloppet i kolumn B 2018-12-15 5300 2019-01-15 5300 2019-02-15 5300 2019-03-15 5300 2019-04-15 5300 2019-05-15 5300 Då kan du köra en SUMMA.OM() som ökas varje gång ett förfallodatum uppnås: =SUMMA.OM(A1:A100;"<="&IDAG();B1:B100) Är det vad du är ute efter? ****ed**** I din exempelfil blir c6 formeln: =SUMMA.OM(B2:B5;"<="&IDAG();C2:C5)
×