Just nu i M3-nätverket
Gå till innehåll

Lars G

Medlem
  • Antal inlägg

    5
  • Gick med

  • Senaste besök

Om Lars G

  • Medlemstitel
    Nykomling

Senaste profilbesöken

Blocket med senaste besökare är inaktiverat och visas inte för andra besökare.

  1. Jag måste be Hanse om ursäkt. Jag hade problem med utskrift av å ä och ö i VBA för Excel. Kolla språkinställningar så att visningsspråk och redigeringsspråk är på svenska skrev du och det gjorde jag, och allt stämde, men fel ändå. Hanse var på rätt spår men kom inte riktigt fram. Till slut kom jag på lösningen. Gjorde en sökning på Google med texten "write country specific letters VBA Excel" och hitta lösningen. på denna sida https://www.spreadsheet1.com/how-to-display-foreign-characters-in-vbe.html Gjorde i tur och ordning på följande sätt i Win10. 1. Inställningar 2.Tid och språk 3.Till vänster, Språk 4.Uppe till höger, "Administrativa språkinställningar" 5.Ändra systemspråk 6.i rutan Nationella inställningar, ta bort bocken i rutan Beta:Använd Unicode UTF-8 för globalt språkstöd Varför den rutan var ibockad har jag ingen aning om. Vem använder UTF-8 idag? I Sverige används ASCII-tabell enligt ISO/IEC 8859-15 även kallad ISO Latin 9. Nu kan jag skriva ut med både å,ä och ö. i VBA för Excel. Problemet löst. /Lars G
  2. Tyvärr är det inte så enkelt. Har dubbelkollat ett flertal gånger. /Lars G
  3. Är nybörjare i Vba på Excel Om jag i ett macro har följande kommando Cells(1, 39) = "Vinst på följande rader" så får jag följande utskrift på skärmen i cell AM1 Vinst p� f�ljande rader å och ö blir konstiga tecken Vad är det för inställning som är fel? Blir samma på Excel 2004 och 2019 Hur gör jag om Jag vill texten med understreck och ev. färgbakgrund? Tacksam för svar /Lars G
  4. PROBLEMET LÖST Efter lite googlande hitta jag denna lösning för att räkna ?-tecken i en kolumn. =ANTAL.OM(A1:A10;"~?") d.v.s lägg till ~ (tilde), ASCII-kod 126 före ? Fungerar perfekt. Typiskt att det är så enkelt. Se sidan https://www.extendoffice.com/documents/excel/2862-excel-count-question-marks.html Hittade även detta =PRODUKTSUMMA((A1:A10="?")+0) som också fungerar. Lars G
  5. Har stött på ett litet problem. Försöker räkna antalet ? i en kolumn som ser ut såhär 1 @ 1 1 ? 2 2 X ! 1 med den vanliga formeln =ANTAL.OM(A1:A10;"?") Får värdet 4. @ X ! räknas också Försökt med ASCII-koden för ? (63) =ANTAL.OM(A1:A10;TECKENKOD(63)) Samma resultat. Kolumnen är allmänt formaterad. Om jag räknar antal 1, 2, X, @ ger det rätt resultat, men icke ?. Vad gör jag för fel i en så banal formel? Lars G
×
×
  • Skapa nytt...